Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28
  1. #21
    Join Date
    Sep 2005
    Posts
    462
    Plugin Contributions
    0

    Default Re: Email Error: Could not execute: /usr/sbin/sendmail

    sql/mysql_upgrade_zencart_135_to_136.sql:
    Cannot ADD column get_term_table because it already exists.

    Cannot ADD column get_term_name_field because it already exists.

    sql/mysql_upgrade_zencart_136_to_137.sql:
    Cannot insert configuration_key "DEFINE_PAGE_NOT_FOUND_STATUS" because it already exists


    nothing else there...
    I may be blond but at least I found Zen.

  2. #22
    Join Date
    Nov 2006
    Location
    Papworth, Cambridgeshire, UK
    Posts
    731
    Plugin Contributions
    3

    Default Re: Email Error: Could not execute: /usr/sbin/sendmail

    Very strange, because the line

    UPDATE configuration SET configuration_description = 'Defines the method for sending mail.<br /><strong>PHP</strong> is the default, and uses built-in PHP wrappers for processing.<br />Servers running on Windows and MacOS should change this setting to <strong>SMTP</strong>.<br /><br /><strong>SMTPAUTH</strong> should only be used if your server requires SMTP authorization to send messages. You must also configure your SMTPAUTH settings in the appropriate fields in this admin section.<br /><br /><strong>sendmail</strong> is for linux/unix hosts using the sendmail program on the server<br /><strong>"sendmail-f"</strong> is only for servers which require the use of the -f parameter to send mail. This is a security setting often used to prevent spoofing. Will cause errors if your host mailserver is not configured to use it.<br /><br /><strong>Qmail</strong> is used for linux/unix hosts running Qmail as sendmail wrapper at /var/qmail/bin/sendmail.', set_function = 'zen_cfg_select_option(array(\'PHP\', \'sendmail\', \'sendmail-f\', \'smtp\', \'smtpauth\', \'Qmail\'),' where configuration_key = 'EMAIL_TRANSPORT';

    is about the 4th line in the 1.3.5-1.3.6 sql update file. I hope it's the only one missing?

    I guess run the sql in phpMyAdmin, check that the config table entry has updated, and be aware of this as a potential cause of any other missing entries?

  3. #23
    Join Date
    Sep 2005
    Posts
    462
    Plugin Contributions
    0

    Default Re: Email Error: Could not execute: /usr/sbin/sendmail

    Thanks a lot! That helped.
    I wonder if there would be a way to check that the upgrade process has been done otherwise? Or should I run the upgrade process again to be sure?

    Elli
    I may be blond but at least I found Zen.

  4. #24
    Join Date
    Nov 2006
    Location
    Papworth, Cambridgeshire, UK
    Posts
    731
    Plugin Contributions
    3

    Default Re: Email Error: Could not execute: /usr/sbin/sendmail

    I've been wondering that myself, I suppose it's worth a try, just run the databse upgrade and see if it flags anything to be done would be my advice.
    Alternative is to work through the admin settings and see if anything else looks odd.
    Trouble is, there are a LOT of them...

    Rgds,

  5. #25
    Join Date
    Sep 2005
    Posts
    462
    Plugin Contributions
    0

    Default Re: Email Error: Could not execute: /usr/sbin/sendmail

    It's very strange because at the same time than admin Server info tools say that the database batch level is 1.3.7, the installer says like this:

    Previous Zen Cart Installation Found
    Database appears to be Zen Cart v1.3.5
    I may be blond but at least I found Zen.

  6. #26
    Join Date
    Nov 2006
    Location
    Papworth, Cambridgeshire, UK
    Posts
    731
    Plugin Contributions
    3

    Default Re: Email Error: Could not execute: /usr/sbin/sendmail

    That is for me a very good sign, it means that it has picked up that it needs to run the upgrades. I'd be a lot happier if that now runs through successfully, and yes it has happened to me before as well.

  7. #27
    Join Date
    Jan 2004
    Posts
    60,406
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Email Error: Could not execute: /usr/sbin/sendmail

    yes ... please let the installer re-run the upgrades
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  8. #28
    Join Date
    Sep 2005
    Posts
    462
    Plugin Contributions
    0

    Default Re: Email Error: Could not execute: /usr/sbin/sendmail

    I ran the upgrade process again and atleast Email options look fine also now and it went through updating lot of things (although the upgrade procedure said that in first place too).

    Elli
    I may be blond but at least I found Zen.

 

 
Page 3 of 3 FirstFirst 123

Similar Threads

  1. Paypal IPN error - wrong e-mail address
    By Moncia in forum PayPal Express Checkout support
    Replies: 24
    Last Post: 4 Oct 2007, 12:37 PM
  2. missing email addr. in confirm acct. creation
    By Sunabac in forum General Questions
    Replies: 0
    Last Post: 6 Feb 2007, 03:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •