Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2006
    Posts
    138
    Plugin Contributions
    0

    database error database needs patching

    after many issues with hosting over the last few days, seems it has been resolved and I have upgraded as some of my php files seemed corrupted from whatever happened server side with the host.

    Now I get message - Your database appears to need patching to a higher level. See Admin->Tools->Server Information to review patch levels.

    I have updated to 1.3.7, but my database patch is 1.3.0.2
    I have all the new zc 1.3.7 files on my harddrive, is there a way I can just patch my database without wiping old info?

    I had a look through tutorials but couldn't find anything.
    thanks

  2. #2
    Join Date
    Jan 2004
    Posts
    60,313
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: database needs patching

    If you need to upgrade the database level, upload the latest zc_install folder, and access it from your browser. Choose "Database Upgrade" (instead of "Install") from the System Inspection screen.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3
    Join Date
    Oct 2006
    Posts
    138
    Plugin Contributions
    0

    Default Re: database needs patching

    thanks very much for your help

  4. #4
    Join Date
    Oct 2006
    Posts
    138
    Plugin Contributions
    0

    Default Re: database needs patching

    but sorry another question - I upgraded with an autoinstall from my cpanel
    when you say upload the lastest zc install folder (whihc I have downloaded onto my harddrive), where do I put it?

  5. #5
    Join Date
    Jan 2004
    Posts
    60,313
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: database needs patching

    1. Never upgrade using cPanel / fantastico.
    2. Use the upgrade instructions in your /docs folder

    The zc_install folder needs to be uploaded to the same folder as your main index.php and nddbc.html etc files.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  6. #6
    Join Date
    Oct 2006
    Posts
    138
    Plugin Contributions
    0

    Default Re: database needs patching

    thanks, ran it and it all worked perfectly
    now off to donate for much appreciated help over the last few days

  7. #7
    Join Date
    Jan 2004
    Posts
    60,313
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: database needs patching

    Quote Originally Posted by zas View Post
    thanks, ran it and it all worked perfectly

    now off to donate for much appreciated help over the last few days
    ever so grateful :)
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 

Similar Threads

  1. Replies: 0
    Last Post: 2 Mar 2007, 01:52 AM
  2. osC convert - "Your database appears to need patching to a higher level"
    By jeff_fwd in forum Upgrading from 1.3.x to 1.3.9
    Replies: 4
    Last Post: 3 Nov 2006, 03:25 PM
  3. Database Patching is stuck
    By livesol in forum Upgrading from 1.2 to 1.3.x
    Replies: 7
    Last Post: 27 Sep 2006, 02:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •