Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2007
    Posts
    3
    Plugin Contributions
    0

    Default Zen Cart Not Installing?

    Sorry if this has already been covered but I tried searching with no luck...

    I'm new to Zen Cart and am trying to install it on a server running mySQL 5.0.27.

    I went through the configuration settings and everything seemed to go fine. However, when I clicked to install I got a plain white page with this message:

    1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-db_cache where cache_entry_name = 'zc_cc87b632a89abd46e00ac8d4a9a78bbb'' at line 1
    in:
    [db_cache table]


    Now everytime I go to my ZC directory, I get this message. Can anyone tell me what this means and, more importantly, how do I fix it? I've tried re-installing several times and get the same thing. Thanks.[/COLOR]

  2. #2
    Join Date
    Aug 2005
    Posts
    26,493
    Plugin Contributions
    9

    Default Re: Zen Cart Not Installing?

    I went through the configuration settings and everything seemed to go fine. However, when I clicked to install
    Confused??? Did you intall it? and then get a blank page?

    Or Initially when entering zc_install do you get a blank page?

    You can't make configuration settings unless you are in the install....
    Zen-Venom Get Bitten
    Get Your Business Found

  3. #3
    Join Date
    Jun 2007
    Posts
    3
    Plugin Contributions
    0

    Default Re: Zen Cart Not Installing?

    My mistake, let me clarify...

    Ok, I get into the installer fine and go through everything up until I get to the database settings. My settings are all correct, otherwise the installer gives me an error that it cannot connect.

    Now, once I click on the "Save Database Settings" buttons, is when I'm taken to the error message. Sometimes it shows a Zen Cart banner and says Installation in progress with the error message on the line below it. Other times its just a blank white page with the error message in black.


    The ZC system inspection page shows that my PHP API mode is in CGI. Might that have anything to do with my problem (it's the only thing in the checklist that wasn't green/ok)? If so, how do I fix that?

  4. #4
    Join Date
    Jun 2007
    Posts
    3
    Plugin Contributions
    0

    Default Re: Zen Cart Not Installing?

    Well, nevermind... I figured it out

    In the database settings I took out the prefix for the records and everything went like butter. All this time getting frustrated for something I should've done in the beginning.

    Well thanks for your help anyways. I'm sure I'll need it again!

  5. #5
    Join Date
    Aug 2005
    Posts
    26,493
    Plugin Contributions
    9

    Default Re: Zen Cart Not Installing?

    Glad you sorted this
    Zen-Venom Get Bitten
    Get Your Business Found

 

 

Similar Threads

  1. Setting up Zen Cart on Windows XP using Xampp - a howto
    By Briank58 in forum Installing on a Windows Server
    Replies: 92
    Last Post: 2 Dec 2009, 04:56 AM
  2. Is Zen Cart the answer for this site?
    By littlejim84 in forum General Questions
    Replies: 17
    Last Post: 11 Apr 2007, 05:04 PM
  3. Installing zen cart
    By spiked11 in forum General Questions
    Replies: 1
    Last Post: 5 Mar 2007, 04:36 AM
  4. State Selector for Zen Cart 1.36 (with shipping estimator support)
    By Woodymon in forum All Other Contributions/Addons
    Replies: 2
    Last Post: 22 Dec 2006, 05:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •