Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2007
    Location
    Wyoming
    Posts
    1
    Plugin Contributions
    0

    red flag Can't get past database setup

    Sorry if this is covered somewhere else - I tried searching and have been trying to figure this out for days!

    I am trying to install v1.3.7 to a Unix host.

    I have uploaded all of the files via FTP with no problem, set up MySQL databases with no problem, and changed the permissions on all files that I need to via FTP.

    But - I still can't get past the Database Setup portion of the install. No matter what I change the settings to on my Cache folder, I still get the same error:

    ATTENTION: Problems Found The Session/SQL Cache Directory entry is not writeable

    I have tried setting the folder to 777 and to 666 using FTP as well as through my host's control panel and am still having no luck. Even though everything SAYS that the file is writable, I still get the error!

    Help please!

  2. #2
    Join Date
    Jan 2005
    Posts
    26
    Plugin Contributions
    0

    Default Re: Can't get past database setup

    check your database name, if it is not correct it will give the same error - ie. mine is like "football_zcart" some are just "localhost" Also be sure the database has been created. Zen Cart does not create the database

  3. #3
    Join Date
    Jan 2004
    Posts
    60,323
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Can't get past database setup

    What is the exact path you're trying to use for your cache folder on the database-setup screen?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  4. #4
    Join Date
    Oct 2006
    Location
    Alberta, Canada
    Posts
    4,151
    Plugin Contributions
    0

    Default Re: Can't get past database setup

    For fastest results it may be best to contact your Hoster.

    If, for example, PHP is run as CGI then you cannot use 777 permission even though the install says you must, but instead, must use 755 for all directories and 644 for all files. The two config files would also need to be set using another method than through an FTP program or a Control panel.

    Also, there are approx. 1,800 files to upload in a new install and it's not uncommon for a few not to make it. If your FTP provides information on failed uploads you know exactly which ones to reupload. Else, you need to go by some other upload confirmation method.
    The learning is in the doing.

    Potent Products

 

 

Similar Threads

  1. Cannot complete database setup Step. Error encountered while writing /include
    By samcyh in forum Installing on a Windows Server
    Replies: 1
    Last Post: 13 Oct 2006, 03:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •