Thread: oh crap

Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    Join Date
    Aug 2007
    Posts
    38
    Plugin Contributions
    0

    Default oh crap



    What did I just do? Well, I just incorrectly deleted my "template_default" folder from Includes/Templates. Ah geeze, you say.

    I re-uploaded a backup of this folder, but now the individual product info won't appear when I click on the item from the site listing.

    See here: www.tomwatersonline.com

    Anyone have any idea what file I'm missing?!

    Thanks!!

  2. #2
    Join Date
    Jun 2003
    Posts
    33,825
    Plugin Contributions
    0

    Default Re: oh crap

    One post per problem please. Duplicate has been deleted.
    Please do not PM for support issues: a private solution doesn't benefit the community.

    Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

  3. #3
    Join Date
    Jan 2004
    Posts
    59,807
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: oh crap

    Are you sure everything uploaded correctly?

    What *else* were you doing around the time you deleted all that stuff ?
    What template files have you customized? Maybe one of those changes is causing this? ie: especially tpl_product_info_display.php
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #4
    Join Date
    Aug 2007
    Posts
    38
    Plugin Contributions
    0

    Default Re: oh crap

    I wasn't doing anything else at the time. I was looking for buttons to change, but hadn't done anything on the server.

    I'm pretty sure it uploaded ok, I don't really have any way to check, other than the FTP script. It looked fine. I can re-upload again if you think that would help.

    I was looking at the tpl_product_info_display.php file. It sounded like the right one, but it look ok too. I had a customized template file in a CUSTOM folder. I removed that, but still no luck.

  5. #5
    Join Date
    Aug 2007
    Posts
    38
    Plugin Contributions
    0

    Default Re: oh crap

    I do have a downloaded template installed - it has a tpl_modules_product_listing.php in it, but that shouldn't have affected it..

  6. #6
    Join Date
    Jan 2004
    Posts
    59,807
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: oh crap

    Time to pull out the fine-toothed-comb:
    http://www.zen-cart.com/wiki/index.p...Obscure_Issues
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Aug 2007
    Posts
    38
    Plugin Contributions
    0

    Default Re: oh crap

    Thanks, I'll get to work on this right away.

    Theoretically, this shouldn't have broken the site right?

    If all the files are uploaded the same as before, it would be like the delete didn't happen, correct?

    I just need a little guidance here, I'm starting to loose it. I just finished a huge project and I'm terrified I'm going to loose everything.

  8. #8
    Join Date
    Jan 2004
    Posts
    59,807
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: oh crap

    This is one of many reasons to be making regular backups of everything.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  9. #9
    Join Date
    Jan 2004
    Posts
    59,807
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: oh crap

    Quote Originally Posted by Rogue Tiger View Post
    Theoretically, this shouldn't have broken the site right?

    If all the files are uploaded the same as before, it would be like the delete didn't happen, correct?
    If you never edited any of the template_default files directly, then uploading the originals again should fix things.

    I suspect your problem is not with the template_default folder, but perhaps something *else* that you've edited/deleted/etc. Perhaps even a corrupt file in the modules/pages/product folder.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  10. #10
    Join Date
    Aug 2007
    Posts
    38
    Plugin Contributions
    0

    Default Re: oh crap

    how in the world do you sort that out though?

    I've made changes to change to site look, but it worked fine until that folder was deleted. Then, after re-uploading, *poof* no individual product listing. I checked the rest of the site out. Looks like it works fine.


    All I have to go on is the deleted "template default" folder.

    But nothing in there should be able to break the site. Did you look at the link? What did you think?

    (btw, thank you so much)

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Another Crap Bug
    By Surfin_UK in forum General Questions
    Replies: 3
    Last Post: 1 Jul 2007, 01:30 AM
  2. Help: Looks Great in Firefox / Safari - Crap In IE
    By bekinky in forum Templates, Stylesheets, Page Layout
    Replies: 8
    Last Post: 19 Jan 2007, 05:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •