Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2005
    Posts
    64
    Plugin Contributions
    1

    application error Admin errors on fresh installation - module errors and language definition errors

    The shipping and payment modules are not showing correctly in admin after a fresh installation of 1.3.7.1.

    Also, the table headings in the configuration menu are not defined.

    I have reinstalled twice and am having the same problem.

    Here is a screen shot of the payment modules page:
    http://dcsstore.net.au/error.jpg

    Can someone please offer some advise.

    Thanks.

  2. #2
    Join Date
    Jun 2003
    Posts
    33,823
    Plugin Contributions
    0

    Default Re: Admin errors on fresh installation - module errors and language definition errors

    You are missing many files, and it seems like your database didn't get fully installed either.
    Reupload all of the files using a different FTP program, and re-run the installation.
    Please do not PM for support issues: a private solution doesn't benefit the community.

    Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

  3. #3
    Join Date
    Dec 2005
    Posts
    64
    Plugin Contributions
    1

    Default Re: Admin errors on fresh installation - module errors and language definition errors

    I have re-uploaded all the files twice using ws_ftp and again using filezilla. I also did a new database installation. I have checked that there are no missing files but I'm still getting the same errors. Do you have any other ideas?

  4. #4
    Join Date
    Jan 2004
    Posts
    60,160
    Blog Entries
    4
    Plugin Contributions
    49

    Default Re: Admin errors on fresh installation - module errors and language definition errors

    If you're still getting TEXT SHOWING_IN_UPPERCASE_LETTERS LIKE_THIS then you're missing various language files, typically from inside the ...includes/languages folders. See this FAQ:
    http://tutorials.zen-cart.com/index.php?article=95

    And, if you're missing those files, you're likely missing lots of others as well.

    Further, if no modules show up in the list, then ... well ... those files must be missing as well ... they're typically in the /includes/modules subfolders, as well as their corresponding language files under the languages area, as mentioned earlier.

    Additionally, if you're getting messages saying you have no payment or shipping modules activated and none are defined, then it's possible that the database script that pre-sets a couple payment/shipping modules for you ... maybe didn't run correctly -- which would suggest the file was incomplete. And if it's missing "that" part, it'll be missing a lot of other critical components as well.

    If you're convinced that your FTP program is not to blame, then follow this FAQ and download what you uploaded, and compare it to the original Zen Cart files to find out what's missing etc.
    http://www.zen-cart.com/wiki/index.p...Obscure_Issues
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  5. #5
    Join Date
    Dec 2005
    Posts
    64
    Plugin Contributions
    1

    Default Re: Admin errors on fresh installation - module errors and language definition errors

    I've compared all the files to a newly unzipped version of zencart using winmerge and they are identical.

    All of the language files and payment and shipping module files are in place.

    I looked at the database configuration in PHPMyAdmin and it shows that the default payment and shipping modules are enabled.

    Do you think it could be a problem with the web host's server configuration?

  6. #6
    Join Date
    Jan 2004
    Posts
    60,160
    Blog Entries
    4
    Plugin Contributions
    49

    Default Re: Admin errors on fresh installation - module errors and language definition errors

    The only thing I can think of that's similar would be a server configuration which is limiting the number of file handles that can be open concurrently.

    v1.3.7.1 has "some" of the fixes included, but only in files that had to be touched for other reasons. The full set of fixes for this are available in the patch posted in this thread:
    http://www.zen-cart.com/forum/showth...929#post345929

    You could "merge in" the various dir->close() calls from that patch into your current files, and then upload the changed files. Remember, the attachment in that patch was built for v1.3.7 and earlier, and simply overwriting v1.3.7.1 files might lose fixes of other things in v1.3.7.1. So, merging would be appropriate.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •