Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 52
  1. #11
    Join Date
    Oct 2007
    Posts
    13
    Plugin Contributions
    0

    Default Re: No Payment and Wrong Payment Method Error

    Thanks Chris.

    I have been testing further. I uninstalled all payment modules and patched the site up to make sure it is up to the latest version. I then installed only the Paypal Express module and tried it out. The payment method showed up correctly in the confirmation email this time, but no payment has been taken from Paypal. I then reinstalled the cheque/money order module and the old problem returned!

  2. #12
    Join Date
    Jan 2004
    Posts
    60,405
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: No Payment and Wrong Payment Method Error

    What are the differences between your site and a fresh installation of Zen Cart?

    What geographic region are you in?
    What country is your PayPal account domiciled in?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #13
    Join Date
    Oct 2007
    Posts
    13
    Plugin Contributions
    0

    Default Re: No Payment and Wrong Payment Method Error

    There are very many difference but they are mostly small changes to various files to move out of table layouts and to insert images and buttons in different places.

    The geographic region is the UK and I assume that the Paypal account is domiciled there, but Chris will have to verify.

  4. #14
    Join Date
    Sep 2007
    Location
    Vancouver, CA
    Posts
    94
    Plugin Contributions
    0

    Default Re: No Payment and Wrong Payment Method Error

    Quote Originally Posted by olistead View Post
    Thanks Chris.

    I have been testing further. I uninstalled all payment modules and patched the site up to make sure it is up to the latest version. I then installed only the Paypal Express module and tried it out. The payment method showed up correctly in the confirmation email this time, but no payment has been taken from Paypal. I then reinstalled the cheque/money order module and the old problem returned!
    I have the exact same problem. Just got my first order today, customer tried to pay with Paypal. To his eyes, order was completed properly, we received all the correct emails, but the paypal account was not debited.

    In our case, the customer already had an existing Paypal account, and did create an account on our site. The issue is that the payment was never applied via paypal.

    Here is what I think happened: somebody forgot to connect an ethernet cable and all my electronic money is draining out on the ground. Ok, maybe not, hehe... but I hope it at least gets a laugh!

    One other thing: A step I didn't do (before this order) was enable the Instant Payment Notification. This was an oversite on my part, but after reading it, I am not sure that this would cause the error. Perhaps someone else can confirm?

    Thanks,

    PS: Got my first order! I know the guy, but it still counts (once I get Paypal working anyway, haha)

    Todd

  5. #15
    Join Date
    Jan 2004
    Posts
    60,405
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: No Payment and Wrong Payment Method Error

    I just set up a fresh v1.3.7.1 install and selected to include the demo products.
    Then I turned on PayPal Express Checkout in the admin and set it up with my API credentials.
    I left the "CC" and "Check/Money Order" options enabled.

    Then I added a product to my cart.
    Clicked on Express Checkout.
    Went to the PayPal site.
    Did not log in to PayPal. Instead, clicked "continue checkout" so I could enter CC information instead.
    I filled in CC payment details.
    Clicked on Review Payment
    Came back to Zen Cart.
    On the Checkout-Payment page, I just clicked Continue.
    On the Checkout Confirmation page, I just clicked Continue. (I did note that the Payment Method shown under the Billing Address did show "PayPal")
    The order completed.
    I went to My Account and clicked on the order. It shows as Processing, and shows "PayPal Express Checkout" and the various transaction details.

    What step am I missing?
    What's different between my test site and yours?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  6. #16
    Join Date
    Sep 2007
    Location
    Vancouver, CA
    Posts
    94
    Plugin Contributions
    0

    Default Re: No Payment and Wrong Payment Method Error

    Quote Originally Posted by DrByte View Post
    I just set up a fresh v1.3.7.1 install and selected to include the demo products.
    Then I turned on PayPal Express Checkout in the admin and set it up with my API credentials.
    I left the "CC" and "Check/Money Order" options enabled.



    What step am I missing?
    What's different between my test site and yours?
    Ok, I did some more rearranging (didn't have cURL enabled, fixed that), then I also disabled a lot of the "Makes it more Express" options in the Paypal Express Module.

    I also did something a little different: Rather than click on the paypal express, I went through and tried to complete the order that way, and this time the transaction was refused with this error message:

    10413 Transaction refused because of an invalid argument. See additional error messages for details. - The totals of the cart item amounts do not match order amounts.

    I am guessing that this was also causing my other problems where the order would appear to complete in paypal express, but then never get submitted.

    I will browse through the logs on the 10413 error message... odds are I will find the answer quickly, but if you have a pointer, love to hear it!

    Thanks,

  7. #17
    Join Date
    Sep 2007
    Location
    Vancouver, CA
    Posts
    94
    Plugin Contributions
    0

    Default Fixed it!

    Quote Originally Posted by bifficus View Post
    Ok, I did some more rearranging (didn't have cURL enabled, fixed that), then I also disabled a lot of the "Makes it more Express" options in the Paypal Express Module.

    ....

    I will browse through the logs on the 10413 error message... odds are I will find the answer quickly, but if you have a pointer, love to hear it!

    Thanks,
    Hi,

    I fixed it... I changed two things. I updated my exchange rates, but probably more importantly, I noticed that the default currency was set USD in the exchange rate section, but the default currency of my store (and location) is supposed to be Canadian dollars. I switched the default, which then changed all my prices unfortunately, so I will have to fix that... but the order worked!

    Thanks guys for the help.

  8. #18
    Join Date
    Jan 2004
    Posts
    60,405
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Fixed it!

    Quote Originally Posted by bifficus View Post
    but the default currency of my store (and location) is supposed to be Canadian dollars. I switched the default, which then changed all my prices unfortunately, so I will have to fix that... but the order worked!
    When you change your default currency, you should also set it to 1.00000 for the value. That way your prices won't all be busted.

    Then also set your default lang currency in your english.php file to match your default currency.

    http://tutorials.zen-cart.com/index.php?article=214
    http://tutorials.zen-cart.com/index.php?article=96
    http://tutorials.zen-cart.com/index.php?article=79
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  9. #19
    Join Date
    Sep 2007
    Location
    Vancouver, CA
    Posts
    94
    Plugin Contributions
    0

    Default Not actually fixed

    Ok, as usual I write first and then finish testing later. Good thing I never sought a career as a test engineer. This is what happens when you let sales guys muck with the code.

    Anyway, changing the default currency successfuly submitted an order to Paypal, however, it was for about 10% less than what the price was supposed to be. I believe I have seen some other threads on that, so will seach and close the loop after.

  10. #20
    Join Date
    Sep 2007
    Location
    Vancouver, CA
    Posts
    94
    Plugin Contributions
    0

    Default Re: Fixed it!

    Quote Originally Posted by DrByte View Post
    When you change your default currency, you should also set it to 1.00000 for the value. That way your prices won't all be busted.

    Then also set your default lang currency in your english.php file to match your default currency.

    http://tutorials.zen-cart.com/index.php?article=214
    http://tutorials.zen-cart.com/index.php?article=96
    http://tutorials.zen-cart.com/index.php?article=79
    Thanks DrByte! Yer fast! You were right, that did the trick. I changed to CAD in my english.php. And thanks for the 1.0000 tip... saves me some work!

    For anyone else that reads this later, this wiki was also helpful: http://www.zen-cart.com/wiki/index.php/PayPal


 

 
Page 2 of 6 FirstFirst 1234 ... LastLast

Similar Threads

  1. Wrong Price in 2CO Payment Confirmation Page, Help Please!
    By raffiq_eddy in forum Addon Payment Modules
    Replies: 2
    Last Post: 8 Sep 2006, 08:09 AM
  2. payment method
    By justinzhang in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 30 Aug 2006, 08:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •