Page 3 of 14 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 135
  1. #21
    Join Date
    Jan 2004
    Posts
    60,419
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: "There was a security error when trying to login" - v1.3.8

    FAQ on the "security error when trying to login" issue:
    http://tutorials.zen-cart.com/index.php?article=312
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  2. #22
    Join Date
    Jan 2004
    Posts
    60,419
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: "There was a security error when trying to login" - v1.3.8

    Quote Originally Posted by Adds View Post
    But what do I need to edit in the above files to get this to work?
    Just merge all the new changes from the new version of those files into your customized versions of those files.

    If you've been doing an upgrade, you're already using some sort of merge/compare tool, right?
    Just continue with the rest of your upgrade ... an upgrade doesn't include just updating your "core" files ... you ALSO ALWAYS need to merge all the new changes from the default (template, language, modules, etc) files into your customized versions of those same files. Otherwise you'll be missing features ... such as the one discussed in this thread.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #23
    Join Date
    Nov 2005
    Posts
    280
    Plugin Contributions
    0

    Default Re: "There was a security error when trying to login" - v1.3.8

    Quote Originally Posted by Adds View Post
    Just see this:

    "There was a security error when trying to login"

    --------------------------------------------------------------------------------

    Situation:
    I have just upgraded and now getting this error when trying to login from the customer screen "There was a security error when trying to login"


    Cause:
    Zen Cart™ v1.3.8 has an added security feature to prevent spoofed external logins. A "security token" field has been added to all login forms. This token must be current (not expired), and must be submitted with login username+password in order for logins to work properly.


    Remedy:
    If you have customized template "login" files, the new security features need to be merged into your customized template files.

    The following files are affected:
    - /includes/templates/YOUR_TEMPLATE/templates/tpl_login_default.php
    - /includes/templates/YOUR_TEMPLATE/templates/tpl_timeout_default.php

    And if you're encountering it in your Admin area, this file is affected as well:
    - /admin/login.php

    But what do I need to edit in the above files to get this to work?
    Issue resolved.

    Thanks for the support.

  4. #24
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,423
    Plugin Contributions
    20

    Default Re: "There was a security error when trying to login" - v1.3.8

    My problem turned out to be simple - new computer, new install of ftp client with a setting that I finally discovered did not overwrite many of the files on the server.

    Nedward - did you upgrade the database after importing your original sql?

    If not, just run the install again to upgrade.

  5. #25
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,655
    Plugin Contributions
    25

    Default Re: "There was a security error when trying to login" - v1.3.8

    Quote Originally Posted by delia View Post
    My problem turned out to be simple - new computer, new install of ftp client with a setting that I finally discovered did not overwrite many of the files on the server.
    Could you tell us more about that FTP Client setting. I've had a whole spate of Stock by Attribute users reporting problems that come down to the same issue of files not being over-written by uploads during installation - but I've never actually had this problem myself.
    See and test drive Zen Cart's free templates at zencarttemplates.info

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  6. #26
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,423
    Plugin Contributions
    20

    Default Re: "There was a security error when trying to login" - v1.3.8

    I use ws_ftp (ipswitch) pro. Under options / transfers there's a check box for
    Don't transfer older/same files when transferring folders. Turns out it was default checked! It's been so long since I installed it that I forgot about that option. Since files transferred to the server show the transfer date that royally made a mess.

    However, I just found out that my cart is showing the index page title wrong! Soon as I figure that out I'll let y'all know.

  7. #27
    Join Date
    Jan 2004
    Posts
    60,419
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: "There was a security error when trying to login" - v1.3.8

    Quote Originally Posted by delia View Post
    However, I just found out that my cart is showing the index page title wrong! Soon as I figure that out I'll let y'all know.
    Perhaps this issue? http://www.zen-cart.com/forum/showthread.php?t=81766
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  8. #28
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,655
    Plugin Contributions
    25

    Default Re: "There was a security error when trying to login" - v1.3.8

    Quote Originally Posted by delia View Post
    I just found out that my cart is showing the index page title wrong! Soon as I figure that out I'll let y'all know.
    That's because there's new code to be merged into the meta_tags.php language file ... which is a discussion for another thread.
    See and test drive Zen Cart's free templates at zencarttemplates.info

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  9. #29
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,423
    Plugin Contributions
    20

    Default Re: "There was a security error when trying to login" - v1.3.8

    Ah, missed that earlier. Of course! Meta tags changes. Got to imprint that one on my brain.

  10. #30
    Join Date
    Jan 2004
    Posts
    60,419
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: "There was a security error when trying to login" - v1.3.8

    Quote Originally Posted by delia View Post
    Ah, missed that earlier. Of course! Meta tags changes. Got to imprint that one on my brain.
    More importantly ... imprint the fact that all upgrades require merging *all* files ... not just core files.
    Any override files need to be assessed ... ie: merge new features/entries into your customized files.

    Nevertheless, I digress from the topic at hand.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 
Page 3 of 14 FirstFirst 1234513 ... LastLast

Similar Threads

  1. v1.3.8a Released!
    By DrByte in forum Zen Cart Release Announcements
    Replies: 1
    Last Post: 11 Dec 2007, 11:30 PM
  2. Admin login Problem - Security Certificate??
    By AlexK in forum Installing on a Linux/Unix Server
    Replies: 8
    Last Post: 1 Jun 2007, 04:58 PM
  3. Login as customer, brings u back to home page and ask for login again?
    By jenbrink@fuse.net in forum Managing Customers and Orders
    Replies: 4
    Last Post: 17 Feb 2007, 04:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •