Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Dec 2007
    Location
    Lansing, MI
    Posts
    10
    Plugin Contributions
    0

    Default Processing error on Payment Pro

    Hello everyone,
    First thanks for a great online cart and for this forum. This forum is invaluable resource that I have used for months. With that said I have been running in a strange error. Any help would be much appreciated.

    We recently moved to 1.3.8a of zencart and moved to payment pro for our credit card processing. So far everything has work well except on 2 customers we have receive payment errors from paypal.The customer then gets charged multiple times (but we only receive one order confirmation). One customer was charged 5x on his Visa for an order and another was charged 5x on his Discover. Each charge has a different time stamp so it appear that each one was processed individually at a different time.

    Each time this has occurred we receive an email from Paypal contains the following
    subject states: ALERT: PayPal Direct Payment Error ( <!-- -->)
    and the body only contains a single hypen ( - )

    We then receive the normal payment confirmation on each of the duplicate payments.

    The first time this happened I figured it was user error. But after the second time I am not so sure. It still could be the end user causing the problem but I have not be able to repeat it in my testing.

    Background information on the setup:
    The original cart was a very out of date Zencart 1.2.5 [fresh install at the time] --> we then copied the database from the live cart to a test db then --> upgraded files/db to 1.3.7.1 that we use for developing the new template and layout (no payment modules were loaded or testing done with this version)-->then upgraded db/files on the test cart (1.3.7.1) to 1.3.8a after it was released. We then performed some testing on the the 1.3.8a version and loaded the Website Payments Pro module. After the testing was completed we unloaded the Payments Pro module, renamed the test db, and then renamed the live db to the old test db name. Then adjusted the config.php files to correct username/psswd and paths and ran the installer on the "new" cart to upgrade the db schema only. We then reloaded the payment pro module and re-configured it to all the paypal api setting. We then ran a few more tests on the live cart that night (later refunding the tests) and everything seemed to work OK.

    Server config:
    Linux (CentOS): 2.6.9-55.0.9
    Apache: 1.3.37
    PHP: 4.4.4
    mySQL: 4.0.27

    Thanks,
    Chad

  2. #2
    Join Date
    Jan 2004
    Posts
    59,807
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: Processing error on Payment Pro

    Quote Originally Posted by pcc View Post
    The customer then gets charged multiple times (but we only receive one order confirmation). One customer was charged 5x on his Visa for an order and another was charged 5x on his Discover. Each charge has a different time stamp so it appear that each one was processed individually at a different time.

    We then receive the normal payment confirmation on each of the duplicate payments.
    How different were the timestamps? In fact, what were the timestamps on all the duplicate charges of both orders?

    What mode are you using Pro in? PayPal/Payflow-UK/Payflow-US?


    Is it possible that a customer could have been making a transaction during a time that PayPal's servers were running slowly? And got impatient, and clicked the submit button repeatedly, thus resulting in 5 charges?
    Granted, "5" in both cases seems odd. And the error email should never be blank either.

    Can you replicate this problem at all?

    Do you have debug logging enabled by any chance?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Dec 2007
    Location
    Lansing, MI
    Posts
    10
    Plugin Contributions
    0

    Default Re: Processing error on Payment Pro

    Thanks for the response Dr. Byte,

    The mode we are using is Paypal.
    The timestamps were all different
    Order1:
    on Dec. 19th
    16:16:59 PST
    16:18:19 PST
    16:21:13 PST
    16:22:31 PST
    16:53:06 PST<--the one that actually went thru correctly

    Order2:
    on Dec. 24th
    17:12:30 PST
    17:15:32 PST
    17:18:13 PST
    17:21:17 PST
    17:27:38 PST <--the one that actually went thru correctly

    As I look at the time stamps more closely I am more apt to believe that it is user error (becoming impatience and hitting the confirm button over and over). The longer delay between the 4th and 5th attempts on both orders seems to indicate this to me. But it's hard to tell.

    In addition, I have not been able to replicate this at all. The blank email, well an email with just a single hyphen, seems weird to me. I did not have debug mode on at the time but I turned it on the as of other day (12/27). Also I would not think that this would affect the paypal payments pro module but I also have the Paypal Express module installed.

    Thanks,
    Chad

  4. #4
    Join Date
    Dec 2007
    Location
    Lansing, MI
    Posts
    10
    Plugin Contributions
    0

    Default Re: Processing error on Payment Pro

    Well it happened again...this time only 3x duplicate payments. I was online at the time it happened and tried my own test transaction (to see if paypal's servers were slow) and I had no issues. The transaction went right through.

    I did capture the errors (had the payment module in debug log mode). I have included just 2 of the payment logs. One is the correct transaction and one is the error transaction. I did find in the error log the <-- --> that shows up in the error email I receive from the cart. Note: I masked (with XXXX) the customer info for privacy reasons.

  5. #5
    Join Date
    Jan 2005
    Location
    Tennessee
    Posts
    1,137
    Plugin Contributions
    0

    Default Re: Processing error on Payment Pro

    I have had the same situation. I spoke with the customer to get this info. After pressing the final confirmation button the program took him back to the select shipping page. The customer was using WEBTV.
    Last edited by stagebrace; 24 May 2010 at 07:01 PM.

  6. #6
    Join Date
    Dec 2007
    Location
    Lansing, MI
    Posts
    10
    Plugin Contributions
    0

    Default Re: Processing error on Payment Pro

    Anyone having any luck in figuring out where this error is coming from? I have been trying to work on figuring it out but have been swamped with in-house application upgrades. My boss keeps asking me if I have a solution yet...
    Any assistance would be great.

    Thanks,
    Chad

  7. #7
    Join Date
    Jan 2005
    Location
    Tennessee
    Posts
    1,137
    Plugin Contributions
    0

    Default Re: Processing error on Payment Pro

    More data on the Error with out an error number.

    I got this three times in a row with the same customer. Each time the authorization was approved on the PayPal side, but no order was generated on the Zen Cart side. Does PayPal check the email address for a domain that exist? The customer mistyped hotmail.com as hotmai.com. Could that make a differance for PayPay not to tell Zen Cart not to generate an order and move to the sucess page? (also posted at paypaldeveloper.com)
    Last edited by stagebrace; 24 May 2010 at 07:01 PM.

  8. #8
    Join Date
    Dec 2007
    Location
    Lansing, MI
    Posts
    10
    Plugin Contributions
    0

    Default Re: Processing error on Payment Pro

    Update:
    The last customer that received the error on my cart stated that he was using OS X with Safari as a browser when the error happened (3x). The use of Safari was the only thing (that I could tell) that was different from the other transactions that day.

    He switch to Firefox and the transaction went through fine.

  9. #9
    Join Date
    Jan 2005
    Location
    Tennessee
    Posts
    1,137
    Plugin Contributions
    0

    Default Re: Processing error on Payment Pro

    Check out these posts on the paypal developer fourm. Its exactly what is happening to me with Check Cards.

    http://www.paypaldeveloper.com/pdn/b...&thread.id=770

  10. #10
    Join Date
    Aug 2005
    Posts
    154
    Plugin Contributions
    0

    Default Re: Processing error on Payment Pro

    This just happened to me!!! Our customer was charged 5 times... is this because they are hitting the button multiple times or what?

    This is an old thread, so I hope you guys figured it out... any one mind sharing with me the fix? Thanks!

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. tell me am wrong "paypal express"
    By chrisnasah in forum PayPal Express Checkout support
    Replies: 4
    Last Post: 28 Sep 2007, 03:05 PM
  2. PayPay Payment Pro - UK
    By rubear in forum Built-in Shipping and Payment Modules
    Replies: 4
    Last Post: 16 Aug 2007, 03:10 PM
  3. PayPal Website Payment Pro
    By balsama in forum Addon Payment Modules
    Replies: 7
    Last Post: 14 Jun 2007, 04:52 AM
  4. Paypal Website Payment Pro - Mislead!
    By maxima in forum PayPal Express Checkout support
    Replies: 13
    Last Post: 25 Feb 2007, 03:17 PM
  5. Paypal Web Site Payment Pro Setup
    By dsaini in forum Addon Payment Modules
    Replies: 5
    Last Post: 12 Jun 2006, 03:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •