Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    Oct 2007
    Location
    Fairbanks, Alaska
    Posts
    426
    Plugin Contributions
    0

    Default backup mysite mod -- is it working?

    I installed the backup mysite mod and it shows up in the admin-tools but when I click on the backup button I get an hourglass for 10 seconds then done.

    does anyone know what this mod does like where it puts the backup if it makes one? and should there not be more then just that?

  2. #2
    Join Date
    Aug 2007
    Posts
    62
    Plugin Contributions
    0

    Default Re: backup mysite mod -- is it working?

    I have the same question. It shows done, but I cannot find where it puts the backup (if it does at all).

  3. #3
    Join Date
    Aug 2007
    Posts
    62
    Plugin Contributions
    0

    Default Re: backup mysite mod -- is it working?

    Someone suggested it should be in admin/backups, but it is not there.

    I installed the mysql backup, and that works correctly and I found the file in admin/backups, but the site backup mod does not do the same.

  4. #4
    Join Date
    Nov 2006
    Location
    Sapin
    Posts
    39
    Plugin Contributions
    0

    Default Re: backup mysite mod -- is it working?

    Hello: i Have problem whit backup mysite i install it but but i think doesn't work. I did all things but it don't do nothing, only after long time get a blank screen whit "Error"

    Anyone have ideas?

    Thank you very much in avanced for your help

  5. #5
    Join Date
    Nov 2005
    Posts
    36
    Plugin Contributions
    1

    Default Re: backup mysite mod -- is it working?

    I simply changed the line

    if (strlen($pathfile) > 99) die('Error'); in admin/backup_mysite.php
    to
    if (strlen($pathfile) > 9999) die('Error');

    This corrected the problem of it not saving to your computer and also not backing up the entire site. Not sure why changing it from 99 to 9999 worked. So, the update was found by accident. It may have something to do with the number of files it will back up??? Not sure.
    Last edited by rmkiser; 19 Dec 2008 at 03:34 AM.

  6. #6
    Join Date
    Oct 2007
    Location
    Fairbanks, Alaska
    Posts
    426
    Plugin Contributions
    0

    Default Re: backup mysite mod -- is it working?

    I changed the file but that did not make the module work, after I made the changes the backup button still does nothing or if it is doing something I don't know what it is, to bad i would like to see this work!

    pete

  7. #7
    Join Date
    Jul 2004
    Location
    Australia
    Posts
    51
    Plugin Contributions
    0

    Default Re: backup mysite mod -- is it working?

    did anybody get this working?
    Jen

    Red Instead design. print. web. photography.

  8. #8
    Join Date
    Jun 2009
    Posts
    22
    Plugin Contributions
    0

    Default Re: backup mysite mod -- is it working?

    I did get this working after making a couple of mods to the backup_mysite.php file. I had coded a comparable extension for Vanilla forum software and decided to compare the two.

    If you edit that file and look in the function Tar_Archive, I added an "@" and then 2 lines of code as follows:

    readfile($tar_file);
    @unlink($tar_file); /*jimw add @*/
    if (strtoupper(substr(PHP_OS, 0, 3)) != 'WIN') touch($tar_file); /*jimw add*/
    ob_end_flush(); /*jimw add*/

    Then I modified the following line:

    $tar = new Tar_Archive("$tar_file"); /*jimw remove $ before new*/

    I've attached the modified file.
    Attached Files Attached Files

  9. #9
    Join Date
    Nov 2007
    Location
    Upstate NY
    Posts
    230
    Plugin Contributions
    0

    Default Re: backup mysite mod -- is it working?

    THANK YOU THANK YOU jwurster!!

    You should package this, or have the mods or someone update the package in the DL area. that one is dangerous.

    I have had nothing but errors from that orig module, like these:
    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/public_html/.../admin/backup_mysite.php on line 66
    Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/.../admin/backup_mysite.php:66) in /home/darenec/public_html/.../admin/backup_mysite.php on line 45

    And then it breaks the admin page, prints my htaccess file behind various text boxes, displays install instructions for htmlarea (??), etc. Scary, scary behaviour.

    Quote Originally Posted by jwurster View Post
    I did get this working after making a couple of mods to the backup_mysite.php file. I had coded a comparable extension for Vanilla forum software and decided to compare the two.

    If you edit that file and look in the function Tar_Archive, I added an "@" and then 2 lines of code as follows:

    readfile($tar_file);
    @unlink($tar_file); /*jimw add @*/
    if (strtoupper(substr(PHP_OS, 0, 3)) != 'WIN') touch($tar_file); /*jimw add*/
    ob_end_flush(); /*jimw add*/

    Then I modified the following line:

    $tar = new Tar_Archive("$tar_file"); /*jimw remove $ before new*/

    I've attached the modified file.

  10. #10
    Join Date
    Jul 2009
    Posts
    68
    Plugin Contributions
    0

    Default Re: backup mysite mod -- is it working?

    well, i'm confused, because even this 'updated' file did not do the trick for me!
    i still get blanc pages afther my pushing the button...
    i don't know what i did or where the mistake is i made..
    i did everything according to the plan :-) but i have to have made a mistake in my cart ... but where....

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. How to load mysite.com
    By batteryman in forum General Questions
    Replies: 7
    Last Post: 5 Sep 2007, 08:17 PM
  2. Backup MySQL Database vs using cPanel backup option?
    By IronMan101 in forum All Other Contributions/Addons
    Replies: 0
    Last Post: 30 Jul 2007, 08:46 AM
  3. Backup MYSQL Plugin - no backup button
    By mrtorrez in forum All Other Contributions/Addons
    Replies: 30
    Last Post: 29 Jun 2007, 11:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •