Difference between revisions of "Installation"

From Zen Cart(tm) Wiki
Jump to: navigation, search
(Required)
m
Line 35: Line 35:
  
 
{{warningBox|Warning!|If you are running on a Unix/Linux host with [http://www.zen-cart.com/wiki/index.php/Troubleshoot_-_PHP_as_CGI PHP running as CGI], you may have some difficulties. It is recommended to use PHP as an Apache module, not as a CGI app.}}
 
{{warningBox|Warning!|If you are running on a Unix/Linux host with [http://www.zen-cart.com/wiki/index.php/Troubleshoot_-_PHP_as_CGI PHP running as CGI], you may have some difficulties. It is recommended to use PHP as an Apache module, not as a CGI app.}}
 +
  
 
{{warningBox|Warning!|Using Zen Cart v1.3.x+ with a PHP version lower than 4.3.2 will result in problems with maintaining sessions. }}
 
{{warningBox|Warning!|Using Zen Cart v1.3.x+ with a PHP version lower than 4.3.2 will result in problems with maintaining sessions. }}

Revision as of 03:43, 19 July 2006


Introduction

Required

The minimum suggested server requirements for running Zen Cart™ v1.3.x and higher are:

  • PHP 4.3.2 or higher (PHP 4.4.x for optimal performance),
  • Apache 1.3.x
  • MySQL 3.2x or higher. (MySQL 4 is better)
  • Register Globals may be on or off
  • PHP safe_mode = off recommended.


The ideal server configuration is:

  • PHP 4.4.x or higher
  • Apache 1.3.x or 2.x
  • MySQL 3.2x or 4.0.x (with significant memory resources devoted to the MySQL processes)
  • Register Globals = off
  • PHP Safe_Mode = off


Idea.png Hint!
Many shipping and payment modules require cURL to be installed and compiled with php.


Idea.png Hint!
Support for HTTPS may be required depending on the payment methods being accepted. The use of SSL during account creation and checkout is recommended.


Warning.png Warning!
If you are running on a Unix/Linux host with PHP running as CGI, you may have some difficulties. It is recommended to use PHP as an Apache module, not as a CGI app.


Warning.png Warning!
Using Zen Cart v1.3.x+ with a PHP version lower than 4.3.2 will result in problems with maintaining sessions.


PHP5

PHP5 is not officially supported by Zen Cart™ at the present time since it hasn't been exhaustively tested; however, many shopowners are successfully running their shops on servers using PHP5. The development of v1.3.x is using constructs that are more compliant with PHP5 but full specific testing for PHP5 is not a primary goal of the 1.3.x series.


MySQL 4.1.x and 5.x

MySQL 4.1.x uses an encryption scheme that is not 100% supported by PHP4 on older servers, so may not work with Zen Cart unless your host has upgraded their support for compatibility between the two systems.

MySQL 5 has some tighter constraints on various SQL statement constructs. Zen Cart™ v1.2.x requires some coding alterations in order to work in a MySQL5 environment. Zen Cart™ v1.3.x has repaired these constructs and thus is expected to be compatible. Exhaustive testing has not yet been completed.

Zen Cart™ has not been designed to use the advanced database features in MySQL5.

Getting the code

  1. Download the latest code group_id=83781&package_id=171544 here. This will take you to SourceForge, which is where our files are distributed from. On that page you can choose the file you wish to download. You will be asked to select a mirror (mirrors are different servers where the same files are hosted, but scattered around the world). It's best to choose one close to your own geographic location.
  2. Unzip the file you downloaded.
  3. Using a tool like WinZip or WinRAR, you can extract the distribution files to your local computer.


Idea.png Hint!
If you need to access an older version of Zen Cart™, you can find those files group_id=83781 here.