AutoTweet

Description
AutoTweet automatically updates your Twitter followers whenever you add a new product to your store. It will tweet your product's name as well as a shortened URL to the specific product's page without you having to do all the work.

NOTE: CURL is required.
+ Download Latest

Submit An Updated Version
Zen Cart® Versions v1.5.5
Original Author jamielife
Last Updated by davewest - 28 Sep 2018
Downloads 5,098

Version History

AutoTweet   -   Version: v4
This modification automatically updates your Twitter followers every time you add a product to your store. It will tweet your product's name, price, URL, and image too without you ever having to log in to twitter. Using Codebird to connect to the Twitter API from your update product code.... all using just one library. Codebird supports full 3-way OAuth as well as application-only auth.

Requirements
PHP 7.1.0 or higher
OpenSSL extension
Twitter Account
Twitter Developer Account
ZC 1.5.5x
  + Download
Zen Cart® Versions v1.5.5
Date Added 28 Sep 2018
Author davewest
File Size 140.5 KB
PHP 5.3 Safe? No
Downloads 19
 
AutoTweet   -   Version: 3.0
This update uses twitter's OAuth authentication method which will be the required method as of August 16th 2010.

Added real time error reporting
Added ability to set twitter & bit.ly time out.
  + Download
Zen Cart® Versions v1.3.9
Date Added 11 Aug 2010
Author jamielife
File Size 16.1 KB
PHP 5.3 Safe? Yes
Downloads 3,274
 
AutoTweet   -   Version: 2.0
Change log v2.0:
Made install much easier (about 3 minutes)
Added option to turn on/off price.
Added twitter error checking set 10 second timeout so store doesn't break if twitter goes down.
Added bit.ly error checking in case links don't shortening.

Rquirements:
php5+
cURL
Zen Cart 1.3.8 or greater
  + Download
Zen Cart® Versions v1.3.9
Date Added 7 Aug 2010
Author jamielife
File Size 6.3 KB
PHP 5.3 Safe? Yes
Downloads 150
 
AutoTweet   -   Version: 1.01
This is an updated version of AutoTweet. It has been tested and works on Zencart 1.3.8 and 1.3.9a.

Change log:
Updated for zencart 1.3.9a
Fixed 'cannot redeclare class bug' caused by bilingual stores
Fixed cURL Followlocation Error.
Added better support for future version of Zen Cart.

Rquirements:
php5+
json support
cURL
Zen Cart 1.3.8 or greater

Getting Help:
Help is available via the Zen Cart forums at http://www.zen-cart.com/forum/showthread.php?t=148069
  + Download
Zen Cart® Versions v1.3.9
Date Added 21 Apr 2010
Author jamielife
File Size 20.7 KB
PHP 5.3 Safe? Yes
Downloads 877
 
AutoTweet   -   Version: 1.0
This is not an version upgrade just a reminder that support for this mod is available in the forum at http://www.zen-cart.com/forum/showthread.php?t=148069. Also PHP 5 or greater as well as cURL are required.   + Download
Zen Cart® Versions v1.3.8
Date Added 19 Feb 2010
Author jamielife
File Size 19.6 KB
PHP 5.3 Safe? Unknown
Downloads 555
 
AutoTweet   -   Version: 1.0
  + Download
Zen Cart® Versions v1.3.8
Date Added 2 Feb 2010
Author jamielife
File Size 19.6 KB
PHP 5.3 Safe? Unknown
Downloads 223
 


disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR