Thanks for updating Conor.

If this is compatible with 1.51, could the plugin's page be updated to say so?

Are you allowed to link to your website from the plugin's page? There's a lot of useful...