Search:

Type: Posts; User: badarac

Page 1 of 10 1 2 3 4

Search: Search took 0.03 seconds.

  1. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    I added that and as expected it works correctly. Thanks


    Unfortunately this was created long before I got here. This customer does not use zencart as a shopping platform. They do everything via...
  2. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    Yes. The only change I made was to have all pages load with https in the config file.
  3. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    This is the redirect section from header_php.php

    } // end action==send


    if (ENABLE_SSL == 'true' && $request_type != 'SSL') {
    zen_redirect(zen_href_link(FILENAME_REQUEST_A_QUOTE, '',...
  4. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    I didn't still have that trigger code on. I can put it on and set my server back to the problem state if you'd like though.
  5. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    We have a winner!!!! The query string is lost going from a non-ssl to ssl page. I just copied the original header_php and template back and it now works correctly. This is probably something that...
  6. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    No but I'll fix that right now ;-)
  7. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    I have tried it altering the position, number, and name of the parameters. It gives the same results. By accident I changed the parameter while on a category page and left the page name the same...
  8. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    Sorry. The testing is being done on a fresh install of 1.5.6c with no mods and using the responsive_classic template. The request_a_quote page was added for testing. In an attempt to discover where...
  9. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    So I can recreate this on my server. The interesting part is that it either works or doesn't depending on the page the url is entered. If the url containing the query string is entered on any page...
  10. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    You are correct. The new site is in a subdirectory on the live site which is in the root. The .htaccess is in the root. I currently have the site on my server installed in a subdirectory. I'll copy...
  11. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    So just a quick update. I decided to do the fresh install on my server. I used the demo data and the only change was the request a quote page. It worked fine. I did a fresh install with the demo data...
  12. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    I will but I'll need to remove all customer info first.
  13. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    No worries. I'm trying anything no matter how crazy it seems ;-) I'm going to do a fresh install on my server and put that page only on. At least then I'll have some control over the environment and...
  14. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    I turned off USU on the live site and it had no effect. I also commented out the notifier and had the first line echo the contents of the GET variable. It was empty. Still scratching my head.
  15. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    It looks lke it is being passed

    xxx.xxx.xxx.xxx - - [14/Jan/2020:13:41:55 +0000] "GET /test/index.php?main_page=request_a_quote&prod=362&itemnumb=4-18-Z-100 HTTP/1.1" 302 20...
  16. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    The page is called from a link in product_info that contains the query string. The url is stripped off as the page is loaded (url in the browser window does not contain the query string and GET...
  17. Replies
    33
    Views
    1,878

    v156 Re: GET query string being stripped from url

    It's an almost clean install with only the bootstrap template, and superglobals plugin installed. The ultimate url mod was installed but I've uninstalled that since it was an obvious candidate. I...
  18. Replies
    33
    Views
    1,878

    v156 GET query string being stripped from url

    I'm drawing a blank trying to figure this one out. Upgrading a site from 1.5.4 to 1.5.6c php 7.3. There is a customer form which was cloned from the contact page. This form is called from the product...
  19. Replies
    253
    Views
    18,874

    v155 Re: ZCA Bootstrap Template

    I did download the zip from plugins again and the extra /div is defiantly there. I also found it in the file on github (around line 270).
  20. Replies
    253
    Views
    18,874

    v155 Re: ZCA Bootstrap Template

    Formatting of attributes with images are broken due to extra closing divs (</div></div>) in includes/modules/bootstrap/attributes.php. Radio buttons could not be clicked. Moved zen_draw_radio_field...
  21. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    I used this on footedshaftllc dot com. It's currently live on 1.5.5f
  22. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    Two issues opened in github. Other than those two items things look good.

    For anyone wondering what the issues are, the fix for the alert on the required pull down fields was incomplete. The...
  23. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    You da man!!
  24. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    The close of the if, div, and list item also needs to be moved or the formatting of the second and third rows moves outside the container. Here's the correct code:

    <?php
    // test if sidebox...
  25. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    Found another one this morning. I've already opened an issue on github.
    More information appears in the hamburger menu even though EZPAGES_STATUS_SIDEBOX is turned off. What I found was the if...
  26. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    My pleasure. Thanks to you and Cindy. This was a huge undertaking as I've discovered just implementing it. Awesome job!!!
  27. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    I found an additional issue related to this which I had fixed. It affected includes/templates/bootstrap/tpl_modules_create_account.php .
    The pull down for the state was creating both the pull down...
  28. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    Issue opened
  29. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    Here's the change I made to includes/classes/observers/ZcaBootstrapObserver.php. It affects all pull downs not just required.

    case 'NOTIFY_ZEN_DRAW_PULL_DOWN_MENU':
    ...
  30. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    I understand that the text boxes have the placeholder. This is a minor formatting issue which resulted from bootstrap. It caused the * added to required dropdowns to move to a new line. The solution...
  31. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    No worries. I've already fixed it with the solution I provided. If you want to give me access to upload to github I'll open an issue and fix.
  32. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    I want to go back to the tagline problem. In includes/templates/bootstrap/common/header.php there is a test for the sales text being blank. If blank it does not include the tagline. This caused...
  33. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    On the create account page, items with drop down menus (state, country) have an * on the line following to indicate it's required. As a text box they have the placeholder set to *.
  34. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    I thought I'd document here that I installed Image handler from https://github.com/lat9/zen_Image-Handler along with bootstrap on a 1.5.5f site. I only needed to change one file in...
  35. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    Or I could do that :cool::blink::blush:
  36. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    Here's the change I made

    <?php } else {echo ' <div id="taglineWrapper" class="text-center col-sm-8"><br/>';}
    // no HEADER_SALES_TEXT or SHOW_BANNERS_GROUP_SET2 ?>
    </div>
    <br /> <br/>...
  37. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    If you set
    define('HEADER_SALES_TEXT', '');
    in includes/languages/english/your_template/header.php it throws off the formatting of the columns on the page. They go full-width with no margin.
  38. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    Disregard. My problem.
  39. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    The problem is fixed sort of. The radio button now work and the contents are aligned correctly. There is what appears to be a second radio button on each row now. Not clickable but appearing...
  40. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    A formatting issue on the checkout_shipping page. If the UPS or USPS modules are used for shipping and multiple shipping options are presented, the names are shown on the left and the prices are...
  41. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    A class was removed hiddenField. I found this on the shipping estimator popup where it displayed an additional field under the state pulldown. I added it back to the css .hiddenField...
  42. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    I found the problem. In includes/functions/zca_bootstrap_functions.php there is a test for the template bootstrap being loaded.

    function zca_bootstrap_active()
    {
    return...
  43. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    I've installed the template from github on 1.5.5f . Everything works ok so far with the zca bootstrap template installed. I installed the clone template plugin and created a copy of the bootstrap...
  44. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    OOPS! I missed that distinction. My bad
  45. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    I just downloaded this from the plugins and it looks like some things were not included. It did not auto install, the core file overwrites are still there and Cindy's replacements were not included....
  46. Replies
    74
    Views
    6,284

    v155 Re: ZCA Bootstrap Template (BETA)

    Nice job! Looking forward to using it.
  47. Replies
    19
    Views
    898

    Re: Logo Image Not showing Up

    No, you're the one seeing the wrong thing.
    17473
    17474
  48. Replies
    19
    Views
    898

    Re: Logo Image Not showing Up

    You probably need to clear the cache in you browser. The new image is appearing but has the same name as the zencart logo
  49. Replies
    19
    Views
    898

    Re: Logo Image Not showing Up

    In includes/languages/english/header.php the define should be
    define('HEADER_LOGO_IMAGE', 'logo.gif');

    What is being generated on you site is
    <img...
  50. v155 Re: 155e install only has classic_responsive in template_select folder

    Glad you figured it out. The good news is that I now have a clean 1.5.5e install with a cloned template. ;-)
Results 1 to 50 of 500
Page 1 of 10 1 2 3 4
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR