Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2004
    Location
    portsmouth, nh us
    Posts
    119
    Plugin Contributions
    4

    Default Duplicate orders using Cybersource

    Is anyone else experiencing duplicate orders using the cybersource payment gateway?

    I am on v 1.2.6 and am having a problem where an order seems to be missed. What will happen is someone will place an order, they get sent back to the last confirmation screen with a general error message and never are able to process the order. In the meantime, cybersource charges the card and the next person that comes through places their order which is the same as the other order Number in cybersource but zencart never actually gets the order.

    I would be willing to pay anyone willing to rewrite the cybersource gateway script for zencart.
    "You must be the change you wish to see in the world" - Ghandi

  2. #2
    Join Date
    Aug 2006
    Location
    Kirkland, WA
    Posts
    79
    Plugin Contributions
    2

    Default Re: Duplicate orders using Cybersource

    Over the last two years, monitoring reported anomalies on the ZC Forum pertaining to the CyberSource Payment Module, I found that the majority of these anomalies are related to 2 major causes:

    Improper CyberSource Business Center parameter settings
    Only the Silent Order POST (SOP) Connection Method along with a SSL certificate installed on the ZC Host will provide a satisfactory environment. I have not seen one working environment using the Hosted Order Page Connection Method and I was never successful in implementing such an environment. CyberSource SOP Userís Manual installation instructions must be strictly adhered to. Involuntary mixing the SOP and HOP connection method settings is a sure way to unsuccessful testing.
    A corollary of improper parameters settings is the wrong interpretation of the meaning of a specific setting. Smart Auth Settings for address or card verification being a good example of this interpretation problem.
    Please verify your CyberSource Business Center settings against a known working set:
    http://www.zen-cart.com/index.php?ma...roducts_id=665
    Incompatible Host server environment (mostly certain php builds)
    From your description and without further investigation, it seems that the problem may be related to your host server, unless numerous ZC modifications were implemented. Please review recent history of php build implementation on the host server and see if the problem coincides with any such build implementation.
    My suggestion is to move to ZC v1.3.8 as a first step. Should the problem persists, then install a debug logging utility to track php errors:
    http://www.zen-cart.com/index.php?ma...roducts_id=860
    You may find a case where an error is never reported (the cybs_sha1() function being a well known case).
    The incompatible php build environment is not easy to identify and, I found it mostly a case-by-case process. Experience is the better guide, so your Host Provider Support Team is a first choice.

    deBeaujeu

 

 

Similar Threads

  1. Replies: 2
    Last Post: 10 Feb 2010, 04:21 AM
  2. Cybersource & Canadian orders
    By ccheney in forum Addon Payment Modules
    Replies: 8
    Last Post: 14 Dec 2008, 08:31 PM
  3. duplicate orders using cybersource module
    By romanus in forum Addon Payment Modules
    Replies: 0
    Last Post: 4 Jun 2008, 03:00 AM
  4. Prevent duplicate orders by using javascript on confirm button?
    By emtecmedia in forum General Questions
    Replies: 4
    Last Post: 5 Dec 2006, 10:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR