Linux; Zen Cart v1.3.8a; Apache v2.0.63; PHP v5.2.5; MySQL v5.0.51a

I have been trying to install Zen Cart on a subdomain i.e www.subdomain.domain.com using the new installation instructions. I had uploaded the entire Zen Cart directory to /public_html/subdomain/zencart and tried to browse to the same location using the following different URL's :

www.subdomain.domain.com/zencart
www.domain.com/subdomain/zencart

www.subdomain.domain.com/zencart/zc_install
www.domain.com/subdomain/zencart/zc_install

with exactly the same results:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


The error logs on the cpanel show the following message:

File does not exist: /home/username/public_html/500.shtml
[Mon Jul 07 07:24:21 2008] [error] [client -.-.-.-] SoftException in Application.cpp:544: Directory "/home/username/public_html/subdomain" is writeable by group


I have tried deleting all Zen Cart files and uploading them again and also htaccess file.

Any other possible solutions to resolve this would be appreciated.

Thank you.