Results 1 to 7 of 7
  1. #1
    Join Date
    Aug 2008
    Posts
    16
    Plugin Contributions
    2

    Default Help with SSL and Admin Page Not Working

    ok i set up 2 test sites, and i get errors on one of them. INFO BELOW


    http://chuck68tx.net/zencart/admin this is the link without SSL on and i did not change anything in the files and everything works , main page and admin section........

    only thing i added was the cherry_zen template to both


    with the site without SSL on i can use all the links in the header and all the pages show.

    the site with SSL on the links for My Account and Checkout only bring up blank pages also.



    the error below is what comes up when i try to go to my admin with this link:
    http://chuck68tx.net/admin , only thing i changed was the info for setting up SSL

    i followed the instructions
    in the turtorials section on setting up SSL....... the main site for http://chuck68tx.net itself works ......

    This is the error i get with the SSL on trying to log into the Admin on http://chuck68tx.net/admin


    Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/content/c/h/u/chuck68tx/html/admin/includes/configure.php:183) in /home/content/c/h/u/chuck68tx/html/includes/functions/sessions.php on line 108

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/content/c/h/u/chuck68tx/html/admin/includes/configure.php:183) in /home/content/c/h/u/chuck68tx/html/includes/functions/sessions.php on line 108

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/c/h/u/chuck68tx/html/admin/includes/configure.php:183) in /home/content/c/h/u/chuck68tx/html/admin/includes/init_includes/init_templates.php on line 36

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/c/h/u/chuck68tx/html/admin/includes/configure.php:183) in /home/content/c/h/u/chuck68tx/html/admin/includes/functions/general.php on line 21


    Admin Includes Config:

    PHP Code:
    define('HTTP_SERVER''http://chuck68tx.net');

      
    define('HTTPS_SERVER''https://chuck68tx.net');

      
    define('HTTP_CATALOG_SERVER''http://chuck68tx.net');

      
    define('HTTPS_CATALOG_SERVER''https://chuck68tx.net');



      
    // secure webserver for catalog module and/or admin areas?

      
    define('ENABLE_SSL_CATALOG'' true' );

      
    define('ENABLE_SSL_ADMIN'' false' );


    // * DIR_WS_* = Webserver directories (virtual/URL)

      // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)

      
    define('DIR_WS_ADMIN''/admin/');

      
    define('DIR_WS_CATALOG''/');

      
    define('DIR_WS_HTTPS_ADMIN''/admin/');

      
    define('DIR_WS_HTTPS_CATALOG''/'); 

    Includes Config:

    PHP Code:
    // Define the webserver and path parameters

    // HTTP_SERVER is your Main webserver: eg-http://www.yourdomain.com

    // HTTPS_SERVER is your Secure webserver: eg-https://www.yourdomain.com

    define('HTTP_SERVER''http://chuck68tx.net');

    define('HTTPS_SERVER''https://chuck68tx.net');


    // Use secure webserver for checkout procedure?

    define('ENABLE_SSL'' true' );

    define('DIR_WS_CATALOG''/');

    define('DIR_WS_HTTPS_CATALOG''/');



    define('DIR_WS_IMAGES''images/');

    define('DIR_WS_INCLUDES''includes/');

    define('DIR_WS_FUNCTIONS'DIR_WS_INCLUDES 'functions/');

    define('DIR_WS_CLASSES'DIR_WS_INCLUDES 'classes/');

    define('DIR_WS_MODULES'DIR_WS_INCLUDES 'modules/');

    define('DIR_WS_LANGUAGES'DIR_WS_INCLUDES 'languages/');

    define('DIR_WS_DOWNLOAD_PUBLIC'DIR_WS_CATALOG 'pub/'); 

    not sure why i get the problems with SSL on


    Chuck68tx

  2. #2
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    74

    Default Re: Help with SSL and Admin Page Not Working

    1. Why do you have spaces inside the ' true' and ' false' values for your SSL settings?

    2. Why are your files double-spaced?

    3. Since the error message is telling you there's a problem on line 183 of your admin configure.php file, what's on line 183 ?
    http://tutorials.zen-cart.com/index.php?article=87
    Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /home/content/c/h/u/chuck68tx/html/admin/includes/configure.php:183) in
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Aug 2008
    Posts
    16
    Plugin Contributions
    2

    Default Re: Help with SSL and Admin Page Not Working

    this is the info where line 183 is: i have tried all 3 methods it says and tried both permission settings and still get the same errors. oh and not sure why there are spaces inside the true and false i fixed that.

    PHP Code:
    // The next 2 "defines" are for SQL cache support.

      // For SQL_CACHE_METHOD, you can select from:  none, database, or file

      // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache 

      // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder

      // ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash 

      
    define('SQL_CACHE_METHOD''none');

      
    define('DIR_FS_SQL_CACHE''/home/content/c/h/u/chuck68tx/html/cache'); 
    Last edited by chuck68tx; 21 Aug 2008 at 08:23 PM.

  4. #4
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    74

    Default Re: Help with SSL and Admin Page Not Working

    What's on lines 175-thru-185 ?
    (change your password to xxxxxx when posting, if that's on one of those lines)
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Aug 2008
    Posts
    16
    Plugin Contributions
    2

    Default Re: Help with SSL and Admin Page Not Working

    Ok i deleted out my server info before i posted this. this is my whole admin/includes/configure.php file. thought it might be easier to post the whole thing . there are no passwords showing i took them out.

    PHP Code:
    <?php

    /**

     * dist-configure.php

     *

     * @package Configuration Settings

     * @package Admin

     * @copyright Copyright 2003-2007 Zen Cart Development Team

     * @copyright Portions Copyright 2003 osCommerce

     * @license [url]http://www.zen-cart.com/license/2_0.txt[/url] GNU Public License V2.0

     * @version $Id: dist-configure.php 6329 2007-05-16 15:36:56Z drbyte $

     * @private

     */



    // Define the webserver and path parameters

    // HTTP_SERVER is your Main webserver: eg-http://www.yourdomain.com

    // HTTPS_SERVER is your Secure webserver: eg-https://www.yourdomain.com

    // HTTP_CATALOG_SERVER is your Main webserver: eg-http://www.yourdomain.com

    // HTTPS_CATALOG_SERVER is your Secure webserver: eg-https://www.yourdomain.com

    /* 

     * URL's for your site will be built via:  

     *     HTTP_SERVER plus DIR_WS_ADMIN or

     *     HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or 

     *     HTTP_SERVER plus DIR_WS_CATALOG or 

     *     HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG

     * ...depending on your system configuration settings

     *

     * If you desire your *entire* admin to be SSL-protected, make sure you use a "https:" URL for all 4 of the following:

     */

      
    define('HTTP_SERVER''http://chuck68tx.net');

      
    define('HTTPS_SERVER''https://chuck68tx.net');

      
    define('HTTP_CATALOG_SERVER''http://chuck68tx.net');

      
    define('HTTPS_CATALOG_SERVER''https://chuck68tx.net');



      
    // secure webserver for catalog module and/or admin areas?

      
    define('ENABLE_SSL_CATALOG''true');

      
    define('ENABLE_SSL_ADMIN''true');



    // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!



    // * DIR_WS_* = Webserver directories (virtual/URL)

      // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)

      
    define('DIR_WS_ADMIN''/admin/');

      
    define('DIR_WS_CATALOG''/');

      
    define('DIR_WS_HTTPS_ADMIN''/admin/');

      
    define('DIR_WS_HTTPS_CATALOG''/');



      
    define('DIR_WS_IMAGES''images/');

      
    define('DIR_WS_ICONS'DIR_WS_IMAGES 'icons/');

      
    define('DIR_WS_CATALOG_IMAGES'HTTP_CATALOG_SERVER DIR_WS_CATALOG 'images/');

      
    define('DIR_WS_CATALOG_TEMPLATE'HTTP_CATALOG_SERVER DIR_WS_CATALOG 'includes/templates/');

      
    define('DIR_WS_INCLUDES''includes/');

      
    define('DIR_WS_BOXES'DIR_WS_INCLUDES 'boxes/');

      
    define('DIR_WS_FUNCTIONS'DIR_WS_INCLUDES 'functions/');

      
    define('DIR_WS_CLASSES'DIR_WS_INCLUDES 'classes/');

      
    define('DIR_WS_MODULES'DIR_WS_INCLUDES 'modules/');

      
    define('DIR_WS_LANGUAGES'DIR_WS_INCLUDES 'languages/');

      
    define('DIR_WS_CATALOG_LANGUAGES'HTTP_CATALOG_SERVER DIR_WS_CATALOG 'includes/languages/');



    // * DIR_FS_* = Filesystem directories (local/physical)

      //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/

      
    define('DIR_FS_ADMIN''/home/content/c/h/u/chuck68tx/html/admin/');

      
    define('DIR_FS_CATALOG''/home/content/c/h/u/chuck68tx/html/');



      
    define('DIR_FS_CATALOG_LANGUAGES'DIR_FS_CATALOG 'includes/languages/');

      
    define('DIR_FS_CATALOG_IMAGES'DIR_FS_CATALOG 'images/');

      
    define('DIR_FS_CATALOG_MODULES'DIR_FS_CATALOG 'includes/modules/');

      
    define('DIR_FS_CATALOG_TEMPLATES'DIR_FS_CATALOG 'includes/templates/');

      
    define('DIR_FS_BACKUP'DIR_FS_ADMIN 'backups/');

      
    define('DIR_FS_EMAIL_TEMPLATES'DIR_FS_CATALOG 'email/');

      
    define('DIR_FS_DOWNLOAD'DIR_FS_CATALOG 'download/');



    // define our database connection

      
    define('DB_TYPE''mysql');

      
    define('DB_PREFIX''zen_');

      
    define('DB_SERVER'''); 

      
    define('DB_SERVER_USERNAME''');

      
    define('DB_SERVER_PASSWORD''');

      
    define('DB_DATABASE''');

      
    define('USE_PCONNECT''false');

      
    define('STORE_SESSIONS''db'); 

      
    // use 'db' for best support, or '' for file-based storage



      // The next 2 "defines" are for SQL cache support.

      // For SQL_CACHE_METHOD, you can select from:  none, database, or file

      // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache 

      // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder

      // ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash 

      
    define('SQL_CACHE_METHOD''none');

      
    define('DIR_FS_SQL_CACHE''/home/content/c/h/u/chuck68tx/html/cache');



    ?>

  6. #6
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    74

    Default Re: Help with SSL and Admin Page Not Working

    Well, since line 183 is likely the last line of the file, you most likely have extra blank lines or spaces at the end of the file, after the closing ?>
    http://tutorials.zen-cart.com/index.php?article=87


    The rest of the PHP syntax looks fine. I'm a little surprised to see that you've chosen to manually edit the dist-configure.php file directly instead of letting the installer build your configure.php files for you. But, naturally, you can use whatever approach you like as long as it works.

    I recommend getting rid of the double-spacing in the file though ... that's most likely what's caused you the headache in the first place.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Aug 2008
    Posts
    16
    Plugin Contributions
    2

    Default Re: Help with SSL and Admin Page Not Working

    that is the way the lines were after the install, only files i edited were the includes config and the admin/includes config. i will fix the files and try it ...i appreciate your help.


    Chuck

 

 

Similar Threads

  1. v151 SSL / Not working, having to logn back in admin, every page refresh
    By Fearless Freap in forum General Questions
    Replies: 10
    Last Post: 30 Jul 2014, 07:14 PM
  2. Replies: 5
    Last Post: 23 Jun 2010, 12:39 AM
  3. Admin SSL not working!
    By helpme in forum Basic Configuration
    Replies: 1
    Last Post: 27 Aug 2007, 03:58 PM
  4. Admin SSL not working??
    By styledata in forum Basic Configuration
    Replies: 16
    Last Post: 27 Jan 2007, 11:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR