Page 13 of 13 FirstFirst ... 3111213
Results 121 to 128 of 128
  1. #121
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Beanstream Payment Module Support Thread

    NOTE: Bambora is sending emails to all merchants who are not passing a CVD (CVV) value with their transactions, because starting October 1, 2018 all transactions missing a CVD will fail.

    TWO THINGS TO CHECK:
    1. Admin->Modules->Payment->Bambora/Beanstream->Edit ... is your "Require CVD Number?" set to True?
    (NOTE: This setting may not exist if you've upgraded to the Bambora v1.60 module, since the setting must always be True.)

    2. Are you using v1.60 of the Bambora/Beanstream payment module? If not, Upgrade here.

    You need Bambora module v1.50 or newer for 2 reasons:
    a) in August 2018 Bambora required switching to use API transactions, and this support was added in v1.50.
    b) v1.50 of the module forces the CVD setting to True.
    and v1.60 of the module removed the CVD setting since it assumes it to be always True per Bambora's new requirements.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  2. #122
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Beanstream Payment Module Support Thread

    Note: v1.60 has been posted, which applies the fix proposed for dbltoe earlier, plus a number of PHP 7.2 compatibility updates. It also forces the CVD and removed the CVD setting altogether.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #123
    Join Date
    Oct 2007
    Posts
    28
    Plugin Contributions
    0

    Default Re: Beanstream Payment Module Support Thread

    I'm getting the error:

    PHP Fatal error: Call to undefined method beanstream::get_error() in / /public_html/includes/modules/pages/checkout_payment/header_php.php on line 117

    when I enter an invalid CC number.
    Any idea how to fix this?

  4. #124
    Join Date
    Oct 2007
    Posts
    28
    Plugin Contributions
    0

    Default Re: Beanstream Payment Module Support Thread

    I added this block of code back in from the original Beansteam module in beanstream.php, and all seems to be working again.

    Code:
     /**
       * Used to display error message details
       *
       * @return array
       */
      function get_error() {
        $error = array('title' => MODULE_PAYMENT_BEANSTREAM_TEXT_ERROR,
                       'error' => stripslashes(urldecode($_GET['error'])));
        return $error;
      }

  5. #125
    Join Date
    Mar 2007
    Location
    Taiwan
    Posts
    241
    Plugin Contributions
    0

    Default Re: Beanstream Payment Module Support Thread

    I'm interested in using this module, and am wondering if it qualifies for PCI SAQ A compliance.

    The Bambora website has a section for Custom Checkout which is PCI SAQ A compliant - https://dev.na.bambora.com/docs/guides/custom_checkout/

    But I think the Zen Cart module is not using this Custom Checkout, but rather the API integration. So it's not clear whether API integration is PCI SAQ A compliant.

    Also - when talking to a Bambora rep, they did not know about a Zen Cart partnership (to qualify for lower rates) as mentioned in the Zen Cart docs.

  6. #126
    Join Date
    Mar 2007
    Location
    Taiwan
    Posts
    241
    Plugin Contributions
    0

    Default Re: Beanstream Payment Module Support Thread

    Quote Originally Posted by robraymond View Post
    I added this block of code back in from the original Beansteam module in beanstream.php, and all seems to be working again.
    Thanks robraymond. I was also getting the same error and this fixes it. From the users perspective, they get a blank page if they enter the credit card number incorrectly - e.g. not enough digits.

    It would be best if error detection could be handled by the javascript and get a popup notification, as is the case if you don't enter the CVV

  7. #127
    Join Date
    Jan 2008
    Location
    Toronto
    Posts
    71
    Plugin Contributions
    0

    Default Re: Beanstream Payment Module Support Thread

    We have finally gotten them to implement Visa Debit for our bambora account. How does this work? When I set the Interact Mod to "True" it just shows a Radio Button on the site with no Card Field. Do I use the CC field Above? Do I need to upgrade the mod? How do I tell which version we are using? It doesn't show in the Mod.
    Thanks!
    New Zenner

  8. #128
    Join Date
    Mar 2007
    Location
    Taiwan
    Posts
    241
    Plugin Contributions
    0

    Default Re: Beanstream Payment Module Support Thread

    ZC 157c PHP 7.3

    I've been getting the following warning when accessing admin->customers->orders->order edit:
    Code:
    Illegal string offset of "id" includes/modules/payment/beanstream.php line 110
    The following change fixes this:

    Around line 106 change this:

    Code:
        if (!isset($order->billing['country'])) return;
    to this:
    Code:
         if (!isset($order->billing['country']['id'])) return;

 

 
Page 13 of 13 FirstFirst ... 3111213

Similar Threads

  1. v155 Quote Payment Module Support Thread
    By swguy in forum Addon Payment Modules
    Replies: 8
    Last Post: 13 Jan 2022, 09:07 PM
  2. INTERAC via Beanstream Support Thread
    By swguy in forum Addon Payment Modules
    Replies: 49
    Last Post: 9 Oct 2015, 04:58 PM
  3. Installment Plan Payment Module [Support thread]
    By swguy in forum Addon Payment Modules
    Replies: 53
    Last Post: 5 Mar 2013, 09:56 PM
  4. Paycard payment module - support thread
    By prez in forum Addon Payment Modules
    Replies: 0
    Last Post: 1 May 2011, 01:02 AM
  5. Layaway Payment Module Support Thread
    By Danielle in forum Addon Payment Modules
    Replies: 0
    Last Post: 21 Nov 2006, 06:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR