Thread: SitemapXML v.2

Page 186 of 197 FirstFirst ... 86136176184185186187188196 ... LastLast
Results 1,851 to 1,860 of 1961
  1. #1851
    Join Date
    Jan 2011
    Location
    Adelaide, Australia
    Posts
    1,441
    Plugin Contributions
    1

    Default Re: SitemapXML v.2

    Quote Originally Posted by jeking View Post
    Have you checked your robots.txt file to be sure images are not being blocked?
    Hi Jim and thanks for your response - there is nothing in robots text blocking images.

    As you are aware Images folder is in the root and I doubt that Googlebot would index every image in the folder as it contains all manner of images so I can only assume that Googlebot will index images from the Products pages - so I don't know if there is any instructions in the sitemapproducts.xml telling Googlebot to look specifically for images in the products sitemap - I somehow doubt it but it is strange that normally images show up in Google Webmaster Tools in sitemaps in addition to url's with a graph showing how many submitted and how many indexed. This is happening as it should with 5 of 6 of my sites but not with one in particular - only url's submitted/indexed - no mention of images at all.

    Any ideas?

    cheers, Mike

  2. #1852
    Join Date
    Jan 2014
    Posts
    62
    Plugin Contributions
    0

    Default Re: SitemapXML v.2

    hello, just playing around with the news box, (read that you haven't look at it for a decate) and found what actually caused the problem. it's the name of a table which has changed. so I corrected the table name to reflect the db

    from this
    PHP Code:
     $last_date $db->Execute("SELECT MAX(GREATEST(news_added_date, IFNULL(news_modified_date, '0001-01-01 00:00:00'), [COLOR="#FF0000"]news_published_date[/COLOR])) AS last_date 
    to this
    PHP Code:
    $last_date $db->Execute("SELECT MAX(GREATEST(n.news_added_date, IFNULL(n.news_modified_date, '0001-01-01 00:00:00'), [COLOR="#FF0000"]n.news_start_date[/COLOR])) AS last_date 
    now it does not longer throw an error, but no data is written to the xml file

    the result is

    XML Parsing Error: no root element found
    Location: https://xxxxxxxxxxxx/sitemap/sitemapboxnews.xml
    Line Number 1, Column 1:

    any idea where to look now?

    thanks for reading.

  3. #1853
    Join Date
    Mar 2009
    Location
    Italy
    Posts
    156
    Plugin Contributions
    0

    Default Re: SitemapXML v.2

    Hi all,

    I'm trying to install SitemapXML on an existing site running zencart 1.55e. The problem i'm facing has already been reported a couple of page back but not the cause nor the solution (the solution given was simply reinstall on a fresh 1.55e install, but i cannot do it).
    In a few words, installed SitemapXML (renamed admin directory and copied all the stuff, all went good). Under Configuration the menu show correctly with all the options.

    Under Tools the menu shows, if i enter It there is the Button "Upgrade SitemapXML SQL", pressing it runs the script and all seems ok (like in the pictures posted before) but no changes in the page, simply it show anly the button.
    Maybe it is something related to the database, even if the script seems to work it really doesnt do anything... no error log.. nothing so i'm quite in a dire situation...
    What should the script do? Is ther a way to do it manually (to test it)?

    Any help would be appreciated

    Best Regards.

    Zencart 1.55e
    SitemapXML 3.95
    MySQL 5.5.57
    Version PHP: 5.6.31

  4. #1854
    Join Date
    Jun 2012
    Location
    California
    Posts
    88
    Plugin Contributions
    0

    Default Re: SitemapXML v.2

    Not sure if this should be here but wasn't sure where else to put it.
    I have SiteMapXml setup and it is working but every time I try to run a Cron job, via Bluehost, using the different examples given I always get an error back via email stating:

    "/bin/sh: 5: command not found"

    The last Cron job command line was as follows:

    5 * * * curl -s 'http://www.wildsteedworx.com/index.php?main_page=sitemapxml\&rebuild=yes\&ping=yes'

    I have tried all the examples but I am new at this so I don't fully understand it yet.
    To have update sitemaps and automatically notify crawlers, you will need to set up a Cron job via your host's control panel.
    To run it as a cron job (at 5:0am like you wanted), put in your crontab something like the following:
    "0 5 * * * GET 'http://your_domain/index.php?main_page=sitemapxml\&rebuild=yes\&ping=yes'
    or
    0 5 * * * wget -q 'http://your_domain/index.php?main_page=sitemapxml\&rebuild=yes\&ping=yes' -O /dev/null
    or
    0 5 * * * curl -s 'http://your_domain/index.php?main_page=sitemapxml\&rebuild=yes\&ping=yes'
    or
    0 5 * * * php -f <path to shop>/cgi-bin/sitemapxml.php rebuild=yes ping=yes"

    Any assistance would be greatly appreciated.

    Thank You

  5. #1855
    Join Date
    May 2007
    Posts
    120
    Plugin Contributions
    0

    Default Re: SitemapXML v.2

    ZC-1.5.5e, PHP 5.6.32, Database patch level 1.5.5

    I'm getting the following error:

    [14-Dec-2017 05:00:01 America/Denver] Request URI: /mysite/index.php?main_page=sitemapxml\&rebuild=yes\ping=yes, IP address: 173.254.47.110
    #1 mysqli_free_result() called at [/home2/sub/public_html/mysite/includes/modules/pages/sitemapxml/sitemapxml_products.php:122]
    #2 include(/home2/sub/public_html/mysite/includes/modules/pages/sitemapxml/sitemapxml_products.php) called at [/home2/sub/public_html/mysite/includes/templates/template_default/sitemapxml/tpl_main_page.php:21]
    #3 require(/home2/sub/public_html/mysite/includes/templates/template_default/sitemapxml/tpl_main_page.php) called at [/home2/sub/public_html/mysite/index.php:97]

    [14-Dec-2017 05:00:01 America/Denver] PHP Warning: mysqli_free_result() expects parameter 1 to be mysqli_result, null given in /home2/sub/public_html/mysite/includes/modules/pages/sitemapxml/sitemapxml_products.php on line 122

    All of the sitemap files seem to be generated without any other problems.

    Any help would be appreciated


  6. #1856
    Join Date
    May 2007
    Posts
    120
    Plugin Contributions
    0

    Default Re: SitemapXML v.2

    ZC-1.5.5e, PHP 5.6.32, Database patch level 1.5.5
    Resoled the previous issue (curl error)but now getting another log error.



    [24-Dec-2017 11:15:46 America/Denver] Request URI: /xxx/index.php?main_page=sitemapxml&inline=yes, IP address: 100.2.73.215
    #1 mysqli_free_result() called at [/home2/sub/public_html/xxx/includes/modules/pages/sitemapxml/sitemapxml_products.php:122]
    #2 include(/home2/sub/public_html/xxx/includes/modules/pages/sitemapxml/sitemapxml_products.php) called at [/home2/sub/public_html/xxx/includes/templates/mmm/sitemapxml/tpl_main_page.php:21]
    #3 require(/home2/sub/public_html/xxx/includes/templates/mmm/sitemapxml/tpl_main_page.php) called at [/home2/sub/public_html/xxx/index.php:97]

    [24-Dec-2017 11:15:46 America/Denver] PHP Warning: mysqli_free_result() expects parameter 1 to be mysqli_result, null given in /home2/sub/public_html/xxx/includes/modules/pages/sitemapxml/sitemapxml_products.php on line 122


    Where is the above request coming from? The error is reproduced every time with that address entered into a browser.
    If this address is used, no errors: /xxx/sitemap.xml

  7. #1857
    Join Date
    Mar 2005
    Posts
    222
    Plugin Contributions
    0

    Default Re: SitemapXML v.2

    Same here, on
    ZC 1.5.5e,
    PHP 7.0.22-0ubuntu0.16.04.1 (Zend: 3.0.0)
    MySQL 5.7.20-0ubuntu0.16.04.1
    MySQL Mode: STRICT_TRANS_TABLES, ERROR_FOR_DIVISION_BY_ZERO, NO_AUTO_CREATE_USER, NO_ENGINE_SUBSTITUTION

    Keeps giving the upgrade button, does the upgrade (at least says so) and back to the upgrade button.

    Anyone have a fix ?

  8. #1858
    Join Date
    Apr 2015
    Location
    United States
    Posts
    147
    Plugin Contributions
    0

    Default Re: SitemapXML v.2

    Same problem as above in post #1857. Anyone have a fix?

    Using Zen 1.55e
    XMLsitemap 3.95

  9. #1859
    Join Date
    Apr 2015
    Location
    United States
    Posts
    147
    Plugin Contributions
    0

    Default Re: SitemapXML v.2

    Quote Originally Posted by fjbern1943 View Post
    Same problem as above in post #1857. Anyone have a fix?

    Using Zen 1.55e
    XMLsitemap 3.95
    Fix is in post #1800
    File is in your admin directory

  10. #1860
    Join Date
    Aug 2004
    Location
    Saint Petersburg, Russia
    Posts
    1,790
    Plugin Contributions
    13

    Default Re: SitemapXML v.2

    Hi,
    Quote Originally Posted by mikebr View Post
    ZC-1.5.5e, PHP 5.6.32, Database patch level 1.5.5

    I'm getting the following error:

    [14-Dec-2017 05:00:01 America/Denver] Request URI: /mysite/index.php?main_page=sitemapxml\&rebuild=yes\ping=yes, IP address: 173.254.47.110
    #1 mysqli_free_result() called at [/home2/sub/public_html/mysite/includes/modules/pages/sitemapxml/sitemapxml_products.php:122]
    #2 include(/home2/sub/public_html/mysite/includes/modules/pages/sitemapxml/sitemapxml_products.php) called at [/home2/sub/public_html/mysite/includes/templates/template_default/sitemapxml/tpl_main_page.php:21]
    #3 require(/home2/sub/public_html/mysite/includes/templates/template_default/sitemapxml/tpl_main_page.php) called at [/home2/sub/public_html/mysite/index.php:97]

    [14-Dec-2017 05:00:01 America/Denver] PHP Warning: mysqli_free_result() expects parameter 1 to be mysqli_result, null given in /home2/sub/public_html/mysite/includes/modules/pages/sitemapxml/sitemapxml_products.php on line 122

    All of the sitemap files seem to be generated without any other problems.

    Any help would be appreciated

    Quick bug fix:
    File includes/modules/pages/sitemapxml/sitemapxml_products.php
    Find
    Code:
    mysqli_free_result($products->resource);
    Replace by
    Code:
    //mysqli_free_result($products->resource);
    Good luck,
    Andrew
    Russian Zen-Cart forum

 

 

Similar Threads

  1. v151 SitemapXML v.2
    By rmu065 in forum General Questions
    Replies: 2
    Last Post: 20 Apr 2013, 05:14 PM
  2. google sitemapxml
    By 4cards in forum All Other Contributions/Addons
    Replies: 1
    Last Post: 2 Feb 2010, 02:57 AM
  3. sitemapXML installation
    By rjgonzalez in forum General Questions
    Replies: 3
    Last Post: 21 Jul 2009, 01:21 AM
  4. SitemapXML Timeout
    By BarryLegal in forum All Other Contributions/Addons
    Replies: 1
    Last Post: 23 Jun 2009, 04:15 PM
  5. installing sitemapxml problems
    By Soul39 in forum All Other Contributions/Addons
    Replies: 2
    Last Post: 15 May 2009, 04:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR