Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Mar 2004
    Posts
    136
    Plugin Contributions
    0

    Default Problem with Admin after changing directory name for Admin

    I followed explicitly the directions for changing the Admin directory to a more secure name.

    After doing so and then visiting the new directory in my browser, I got the following page...

    Hello. Thank you for loading Zen Cart™.
    You are seeing this page for one or more reasons:
    1. This is your first time using Zen Cart™ and you haven't yet completed the normal Installation procedure.
    If this is the case for you, you will need to upload the "zc_install" folder using your FTP program, and then run zc_install/index.php via your browser (or reload this page to see a link to it).
    2. Your /includes/configure.php and/or /admin/includes/configure.php file contains invalid path information and/or invalid database-connection information.
    If you recently edited your configure.php files for any reason, or maybe moved your site to a different folder or different server, then you'll need to review and update all your settings to the correct values for your server.
    See the Online FAQ and Tutorials area on the Zen Cart™ website for assistance.
    To begin installation ...
    1. The Installation Documentation can be read by clicking here: Documentation
    2. You will need to upload the "zc_install" folder using your FTP program, and then run zc_install/index.php via your browser (or reload this page to see a link to it).
    3. The Online FAQ and Tutorials area on the Zen Cart™ website will also be of value if you run into difficulties.

    Copyright © 2003-2009 Zen Cart™


    I do not know how to proceed at this point. This scenario was not described in the "How do I rename my Admin folder to prevent unauthorized access?" document.

    After receiving the error page, I changed the config file back to its original /admin/ and changed the directory back to admin and the error page persists.

    I cannot access my Admin area now at all and I do not know how to proceed.

    Please advise.
    Last edited by cnymike; 29 Jun 2009 at 03:29 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    27,825
    Plugin Contributions
    9

    Default Re: Problem with Admin after changing directory name for Admin

    After receiving the error page, I changed the config file back to its original /admin/ and changed the directory back to admin and the error page persists.
    As this only deals with the one file and one folder you have messed something up...

    Check your config file for byte size(not "0") and content
    Zen-Venom Get Bitten

  3. #3
    Join Date
    Mar 2004
    Posts
    136
    Plugin Contributions
    0

    Default Re: Problem with Admin after changing directory name for Admin

    I don't know how I messed something up since I followed the instructions.

    I went to my /includes/configure.php file

    I located

    define('DIR_WS_ADMIN', '/store/admin/');
    define('DIR_WS_CATALOG', '/store/');
    define('DIR_WS_HTTPS_ADMIN', '/admin/');
    define('DIR_WS_HTTPS_CATALOG', '/store/');

    and

    define('DIR_FS_ADMIN', '/usr/www/users/xxxx/store/admin/');
    define('DIR_FS_CATALOG', '/usr/www/users/xxxx/public/');

    I changed those to

    define('DIR_WS_ADMIN', '/store/my-new-directory/');
    define('DIR_WS_CATALOG', '/store/');
    define('DIR_WS_HTTPS_ADMIN', '/my-new-directory/');
    define('DIR_WS_HTTPS_CATALOG', '/store/');
    and

    define('DIR_FS_ADMIN', '/usr/www/users/xxxx/store/my-new-directory/');
    define('DIR_FS_CATALOG', '/usr/www/users/xxxx/public/');

    I saved the changes.
    I went to mysite/store/admin and changed the admin directory name to
    mysite/store/my-new-directory

    I then go to the URL of my-new-directory in my browser and get the error page.

    What did I screw up?

    The byte size of my configure.php file is 4.4KB

  4. #4
    Join Date
    Jun 2009
    Posts
    7
    Plugin Contributions
    0

    Default Re: Problem with Admin after changing directory name for Admin

    I'm having a problem as well. I was not the person to set up ZenCart and I notice that we have a admin folder both under private.html and public.html.

    Should the private/admin/includes/configure.php be left untouched?

    I've tried the change under both files and neither will allow me back into my ZenCart admin panel.

    Any help you can provide is greatly appreciated.

    Thank you,
    Valarie

  5. #5
    Join Date
    Mar 2004
    Posts
    136
    Plugin Contributions
    0

    Default Re: Problem with Admin after changing directory name for Admin

    So thankfully I had made a backup before I began this procedure and restored my configure.php file and admin directory name to its original state.

    I started all over again and this time it worked with no issues.

    I must have had a typo somewhere that I hadn't noticed.

    All is well now.

    And this should serve as a note of caution to others that having a backup can save you from a lot of heartache when doing updates. If I had not had a backup, who knows how many hours I would have lost trying to fix this issue.

  6. #6
    Join Date
    Jun 2009
    Posts
    6
    Plugin Contributions
    0

    Default Re: Problem with Admin after changing directory name for Admin

    After changing my /admin/ name, I receive the message "Hello. Thank you for loading Zen Cart™."

    Version: zen-cart-v1.3.8a-full-fileset-12112007

    I performed the following actions after a successful installation:

    • installed security patch
    • installed easy populate
    • Changed admin folder name


    I don't have the configure.php file that everybody seems to have and am not sure what to do.

    In the following directories, I have these type of configuration files:

    /includes/
    dist-configure.php (no option to rename /admin/ here)

    /admin/includes/

    dist-configure.php (/admin/ is here)

    I have followed the instructions from the tutorial: http://tutorials.zen-cart.com/index.php?article=33

    ...And made the following adjustments in the dist-configure.php

    After changing my /admin/ name, I receive the message "Hello. Thank you for loading Zen Cart™."


  7. #7
    Join Date
    Jun 2009
    Posts
    6
    Plugin Contributions
    0

    Default Re: Problem with Admin after changing directory name for Admin

    I just re-downloaded the software, and started over....

    The configure.php file now exists... Must of had a corrupt download/upload the 1st time...

    Sorry for the multiple post, I had several tabs open and was not sure which one was the appropriate one...


  8. #8
    Join Date
    Feb 2009
    Posts
    13
    Plugin Contributions
    0

    Default Re: Problem with Admin after changing directory name for Admin

    Sorry folks... I am in the same boat.

    Except I even put back my original backup file for the configure.php and still getting a white screen.

    I have read through all the faq's, guides, and forums but still can't find any solution that works for me.

    I had done the same thing as everyone else here, followed steps to change admin area to different name. When that failed, I tried to back track to back up files, but the problem remains.

    I have tried to use the debug error fixing utility, but it won't even generate a report.

    I also tried to just view source code of the admin logon page, but it doesn't show anything.

    Thought? I am sure it is some thing simple and I will feel like an idiot once I discover the problem, but until then, I am still stuck without and admin log on page. Makes business rather difficult.

    Thanks in advance!

  9. #9
    Join Date
    Jun 2009
    Posts
    5
    Plugin Contributions
    0

    Default Re: Problem with Admin after changing directory name for Admin

    Thank you. This security update has been nothing but a pain in the a$$.

    I followed all of the steps EXACTLY and got the same default ZenCart set up screen.

    The only way I could get it to work was to rename the admin directory back to 'Admin'. Grrrrreeat.

    Second, my website has somehow miraculously reverted back to the default template setup, and totally discarded my changes/edits I made to the site! Some edits remained while others were thrown away.

    The site was working just fine. Now this is just irritating me and wasting time.

    Can someone explain why my site will display one thing and the admin panel say another?

    EXAMPLE: The categories displayed on the site are "Baquettes, Bowling, Clutches, Evening Fabric, etc." and from the admin panel I have the categories correctly as "Vests, Shoes, Belts, Head and Neckwear" etc. What could cause this discrepancy?

    Another problem is the items I added are not showing - only the example items.

    If I had to guess - my configure files are f*cked up.

    www.modishboutique.com

    Thanks Zen Gurus
    Last edited by alexb123; 1 Jul 2009 at 11:49 PM.

  10. #10
    Join Date
    Jun 2009
    Posts
    5
    Plugin Contributions
    0

    Default Re: Problem with Admin after changing directory name for Admin

    Figured it out.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Cannot log into admin after changing directory name
    By brennen in forum Customization from the Admin
    Replies: 4
    Last Post: 13 Sep 2010, 05:11 PM
  2. error when trying to log into admin after changing admin name
    By pcrcanada in forum General Questions
    Replies: 8
    Last Post: 29 Jun 2009, 08:51 PM
  3. Replies: 11
    Last Post: 4 Oct 2007, 06:53 PM
  4. Replies: 0
    Last Post: 25 Apr 2007, 05:05 PM
  5. Problem Accessing Admin After Changing Folder Name
    By enchantedone in forum Templates, Stylesheets, Page Layout
    Replies: 7
    Last Post: 12 Jun 2006, 05:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR