Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2009
    Posts
    5
    Plugin Contributions
    0

    Default Authorize.net Sends Response "1" but Zen Cart Throws Error

    Hello!
    I've been using Zen Cart for a while on an older installation (1.2.7) but just this week managed to upgrade to 1.3.8a. It took a while to do the upgrade, but everything was straight forward and worked well, until I did my first test transaction. I'm using the Authorize.net SIM module with all the correct settings (I have verified this with Authorize).

    I'm in production mode on both sites and when I run a card (I've tried four cards, two active Visas and a Discover and an inactive Visa) I get the correct response from Authorize either accepted or declined (see logfile below for accepted card) but either way Zen Cart throws the "There has been an error processing your credit card. Please try again." error in response and the order is not saved.

    I do notice that the Hash fails, but I have confirmed that I have the correct Hash in both Authorize and Zen Cart.

    I hope that's enough information to diagnose the problem. Thanks!

    Code:
    Oct-15-2009 12:07:48
    =================================
    
    Response Code: 1.
    Response Text: This transaction has been approved.
    
    Results Received back from Authorizenet: Array
    (
        [x_response_code] => 1
        [x_response_subcode] => 1
        [x_response_reason_code] => 1
        [x_response_reason_text] => This transaction has been approved.
        [x_auth_code] => 060713
        [x_avs_code] => Y
        [x_trans_id] => 2657055350
        [x_invoice_num] => 
        [x_description] => Website Purchase from Good Steward Books
        [x_amount] => 0.85
        [x_method] => CC
        [x_type] => auth_capture
        [x_cust_id] => 2333
        [x_first_name] => Daniel R.
        [x_last_name] => Ziegler
        [x_company] => 
        [x_address] => 9827 Rosedale-Milford Center Rd.
        [x_city] => Irwin
        [x_state] => Ohio
        [x_zip] => 43029
        [x_country] => United States
        [x_phone] => 740.604.1316
        [x_fax] => 
        [x_email] => drziegler######################
        [x_ship_to_first_name] => Daniel R.
        [x_ship_to_last_name] => Ziegler
        [x_ship_to_company] => 
        [x_ship_to_address] => 9827 Rosedale-Milford Center Rd.
        [x_ship_to_city] => Irwin
        [x_ship_to_state] => Ohio
        [x_ship_to_zip] => 43029
        [x_ship_to_country] => United States
        [x_tax] => 0.0000
        [x_duty] => 0.0000
        [x_freight] => 0.0000
        [x_tax_exempt] => FALSE
        [x_po_num] => 
        [x_MD5_Hash] => E2AE1BDD4243E2994DBCB107FB7C1A98
        [x_cavv_response] => 
        [x_test_request] => false
        [x_relay_form] => TRUE
        [zenid] => 758fae8e7219ebcf25338e605b5f390a
        [HashValidationValue] => FD2651ADAAFD97EEBC29A52F78F7641D
        [HashMatchStatus] => FAIL
        [url] => https://secure.authorize.net/gateway/transact.dll
    )

  2. #2
    Join Date
    Jan 2004
    Posts
    63,429
    Blog Entries
    5
    Plugin Contributions
    62

    Default Re: Authorize.net Sends Response "1" but Zen Cart Throws Error

    Whatever you use for a hash code must be less than 20 characters. I suggest choosing another shorter word/phrase for your md5-hash value.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 

Similar Threads

  1. v154 authorize.net "Card Declined" response is unformatted
    By themanorhouselibrary in forum Installing on a Linux/Unix Server
    Replies: 9
    Last Post: 30 Dec 2015, 11:20 PM
  2. v150 price display error in "Customer also bought" in template by zen-cart-power.net
    By discoverytdi in forum Upgrading from 1.3.x to 1.5.x
    Replies: 2
    Last Post: 15 Apr 2012, 01:43 AM
  3. Authorize.net is approving cards, but my store says "There has been an error..."
    By Dr Tweak in forum Built-in Shipping and Payment Modules
    Replies: 2
    Last Post: 12 Jan 2012, 10:40 PM
  4. Issues with authorize.net aim "communications error"
    By ericlewis in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 12 Oct 2011, 04:47 AM
  5. Authorize.net SIM Working but AIM Always "Declined"
    By alexsbrown in forum Built-in Shipping and Payment Modules
    Replies: 5
    Last Post: 1 Feb 2009, 12:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR