Page 1 of 3 123 LastLast
Results 1 to 10 of 28
  1. #1
    Join Date
    Nov 2009
    Location
    Maldives
    Posts
    22
    Plugin Contributions
    0

    Default search not working

    I installed Zen Cart 1.3.8a and the shop where I installed it is working properly, I can add categories and products and they can be viewed but the problem is when I searched for that product or any in through my website, it always saying that "There is no product that matches the search criteria". I am new and I couldnt find a solution for this problem. I did not change anything yet, its a fresh installation and the website where I installed mine is

    http:www.fahimagu.com/shop

    Any answer will be highly appreciated.
    Thanks

  2. #2
    Join Date
    Nov 2007
    Location
    Melbourne, Australia
    Posts
    552
    Plugin Contributions
    0

    Default Re: Zen Cart 1.3.8a A Fresh installation, search not working

    Somehow you search doesnt work for words starting with a Capital letter. Others work, e.g. http://www.fahimagu.com/shop/index.p...word=advocates

    But i dont know what causes this problem though.

  3. #3
    Join Date
    Nov 2009
    Location
    Maldives
    Posts
    22
    Plugin Contributions
    0

    Default Re: Zen Cart 1.3.8a A Fresh installation, search not working

    Thanks a lot, that rings a bell. Until your reply, I was lost in nowhere and was thinking whether its a problem of zen cart or where I host my site. Now I think its a problem in zen cart where I could try to fix. Thanks. However, I will still be very happy if somebody else could help me with fixing the problem. Thanks

  4. #4
    Join Date
    Nov 2009
    Location
    Maldives
    Posts
    22
    Plugin Contributions
    0

    Default Search problem

    I installed a fresh copy of zen cart 1.38a and after adding a category and some 2 products to that category and when I searched for the products I listed, nothing appears at first. When I posted that probelm in here, somebody had a look at my website and told me that if the product title has any Uppercase letters, nothing appears in search results and then I changed the product titles to lower case and it works fine. But I need to use correct format of English and the titles should be starting with Uppercase letters and so on. Anybody has any idea how my search results will bring up the results ignoring the upper/lower case.

    My website I am trying to set the storefront is
    http://www.fahimagu.com/shop

    Any help will be highly appreciated.
    Thanks

  5. #5
    Join Date
    Jun 2007
    Location
    Phoenix, AZ
    Posts
    69
    Plugin Contributions
    0

    Default Re: search not working

    I would go back and check to make sure no files were modified for advanced_search_result, including:

    includes/modules/pages/advanced_search_result/header_php.php
    includes/templates/YOUR_TEMPLATE/tpl_advanced_search_result.php

    When I click on your "All Products" link, I see two Nintendo products, however when I search for "Nintendo" I only see one. I was unable to replicate the behavior regarding capitalization from the post above.

    The quickest thing to do will be to switch back to the classic template and see if the issue goes away; if it does, then you know it's in your custom template files somewhere. If you've been editing files under includes/modules/pages, then all bets are off, you've introduced a bug that you'll have to track down.

    Good luck!
    Generations Crafting (Our Zen-Cart storefront)
    "
    And that's just it, Doc - my mind has always been my Achilles' heel!" -- The Tick

  6. #6
    Join Date
    Jun 2007
    Location
    Phoenix, AZ
    Posts
    69
    Plugin Contributions
    0

    Default Re: search not working

    One other thing: Your template doesn't set up you language defines correctly. You should not be seeing the "HEADING_TITLE" on the home page.
    Generations Crafting (Our Zen-Cart storefront)
    "
    And that's just it, Doc - my mind has always been my Achilles' heel!" -- The Tick

  7. #7
    Join Date
    Nov 2009
    Location
    Maldives
    Posts
    22
    Plugin Contributions
    0

    Default Re: search not working

    thanks for the quick reply. I am in the process of editing the site however, I DID NOT TOUCH any SEARCH PAGES. Its still there as it is and even when I switched to classic template, same problem: ie; I can browse the products but when I searched for the items, only titles that matched the search with lowercase appears. For instance if you seached for "Nintendo" only one item appears but if you searched for "intendo" you will get the two items there. You can see how I wrote the products titles.
    Any help would be highly appreciated.
    Thanks

  8. #8
    Join Date
    Jun 2007
    Location
    Phoenix, AZ
    Posts
    69
    Plugin Contributions
    0

    Default Re: search not working

    Are you using MySQL for the backend? If so, what version? Have you changed any system settings on MySQL? Normally, database searches are not case-sensitive.
    Generations Crafting (Our Zen-Cart storefront)
    "
    And that's just it, Doc - my mind has always been my Achilles' heel!" -- The Tick

  9. #9
    Join Date
    Nov 2009
    Location
    Maldives
    Posts
    22
    Plugin Contributions
    0

    Default Re: search not working

    Thanks but as I said before, I havent touch anything relating to search and especially the database. I am a novice and I have no idea how I could access the database. I have only been fiddling with banner boxes and things like greeting messages.
    I had a look at the control panel of my hosting provider (hostmonster) and I found out that I am using MySQL and the version is 5.0.81-community-log. Any help would be highly appreciated.
    Thanks

  10. #10
    Join Date
    Jun 2007
    Location
    Phoenix, AZ
    Posts
    69
    Plugin Contributions
    0

    Default Re: search not working

    I looked at this a little more and I don't think it's a file issue. I think the Nintendo DSi product got corrupted in the database somehow. It doesn't come up no matter what you search on. If you search for "DSi" you don't get any products at all. Can you please delete the DSi and re-add it? Afterward, try searching for "Nintendo" again. Do you see both products?
    Last edited by Tick; 7 Dec 2009 at 06:50 AM. Reason: Fix typo
    Generations Crafting (Our Zen-Cart storefront)
    "
    And that's just it, Doc - my mind has always been my Achilles' heel!" -- The Tick

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 4
    Last Post: 9 Feb 2013, 06:12 PM
  2. Search not working
    By charliebee17 in forum General Questions
    Replies: 7
    Last Post: 6 Jun 2012, 02:17 AM
  3. Search not working..
    By z3n in forum General Questions
    Replies: 1
    Last Post: 3 Dec 2009, 08:19 PM
  4. Search not working?
    By dcase in forum General Questions
    Replies: 6
    Last Post: 19 Jul 2007, 11:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR