Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Join Date
    Jan 2004
    Posts
    65,288
    Blog Entries
    7
    Plugin Contributions
    227

    Default Re: ALERT: PayPal Direct Payment Error ( _!-- --_)

    That is correct. All the improvements were built in to the next version.

    And, you cannot hack the 1.3.9 capabilities out of it and into 1.3.8 because there are numerous codependencies on other parts of the code that are shared with many other infrastructure pieces. To get the benefits, including security improvements and bugfixes, of v1.3.9, you need to upgrade to 1.3.9.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  2. #12
    Join Date
    Dec 2007
    Posts
    83
    Plugin Contributions
    0

    red flag Re: ALERT: PayPal Direct Payment Error ( _!-- --_)

    Quote Originally Posted by DrByte View Post
    That is correct. All the improvements were built in to the next version.

    And, you cannot hack the 1.3.9 capabilities out of it and into 1.3.8 because there are numerous codependencies on other parts of the code that are shared with many other infrastructure pieces. To get the benefits, including security improvements and bugfixes, of v1.3.9, you need to upgrade to 1.3.9.

    Hello Dr Byte,

    In relation to this answer are you saying that version 1.38a is no longer properly compatible with Pay Pal? i am still using this version and believe it to be still working fine, is there something i should know about? is upgrading critical now for all 1.38a users who use Pay Pal? I use a lot of modules with this version and upgrading would be a serious expense. If everything is working fine do i really need to go to the expense of upgrading? Your information on this subject would be greatly appreciated.
    I love Zencart!

  3. #13
    Join Date
    Jan 2004
    Posts
    65,288
    Blog Entries
    7
    Plugin Contributions
    227

    Default Re: ALERT: PayPal Direct Payment Error ( _!-- --_)

    Ah, the ever popular "can I avoid upgrading?" question.

    1. v1.3.8a is presently still compatible with PayPal, but there are hundreds of improvements and added features in v1.3.9 that make it a prudent choice to upgrade.
    2. PayPal recently announced an "All New Checkout" which takes advantage of features added in v1.3.9. As such, if you don't upgrade, you'll find that some things in the "All New Checkout" displays will not appear with as much detail as you might prefer. Not all merchants have the "All New Checkout" enabled in their PayPal account yet. It's being rolled out over time. If you have questions about the "All New Checkout", as PayPal directly.
    3. v1.3.9 contains a LOT of security improvements which v1.3.8a does not contain. There are some serious vulnerabilities in unpatched v1.3.8a code, which are fixed in v1.3.9.
    4. When the next release after v1.3.9 is out, v1.3.8a will be officially no longer supported, just as v1.3.7 is no longer supported now that v1.3.9 is out.

    Now that that's out of the way, was there something on-topic to this thread that you had a question about?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #14
    Join Date
    Dec 2007
    Posts
    83
    Plugin Contributions
    0

    red flag Re: ALERT: PayPal Direct Payment Error ( _!-- --_)

    Thanks for the info Dr Byte, as always a great help in making the correct decision. Sorry that it was slightly off topic but i found it hard to find a section on if the upgrade was critical or not i do have the new pay pal setup but it still seems to work ok, the upgrade for my site is now being done, thanks once again for your great help.
    I love Zencart!

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. ALERT: PayPal Direct Payment Error (0 )
    By rubear in forum PayPal Website Payments Pro support
    Replies: 9
    Last Post: 16 Jan 2011, 11:50 AM
  2. ALERT: PayPal Direct Payment Error (10001 <!-- -->)
    By malice95 in forum PayPal Website Payments Pro support
    Replies: 13
    Last Post: 19 Aug 2010, 03:13 AM
  3. ALERT: PayPal Direct Payment Error (10413 <!-- -->)
    By terytubby in forum PayPal Website Payments Pro support
    Replies: 21
    Last Post: 2 Feb 2010, 03:48 PM
  4. ALERT: PayPal Direct Payment Error ( <!-- -->)
    By stagebrace in forum PayPal Website Payments Pro support
    Replies: 32
    Last Post: 9 Mar 2009, 04:03 AM
  5. ALERT: Paypal Direct Payment Error (103)
    By HeathenMagic in forum PayPal Website Payments Pro support
    Replies: 4
    Last Post: 5 Dec 2007, 09:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR