Page 1 of 70 1231151 ... LastLast
Results 1 to 10 of 692
  1. #1
    Join Date
    Dec 2009
    Location
    Richmond, VA
    Posts
    167
    Plugin Contributions
    3

    Default AutoFacebook [Support]

    This is the official thread for the AutoFacebook mod recently made available in the add-ons section at http://www.zen-cart.com/index.php?ma...oducts_id=1623.

    The modification allows you to automatically update your facebook's buisness page everytime you add a new product.

    AutoFacebook has only been tested on English (one language) Zen Cart 1.3.8 with php 5.3 however it should work fine as long as you're using php > 5.

    Also please make sure you're server supports JSON

    Hope ya like it

  2. #2
    Join Date
    Mar 2008
    Posts
    46
    Plugin Contributions
    0

    Default Re: AutoFacebook [Support]

    hi...
    i got thir error after click "" link

    API Error Code: 100
    API Error Description: Invalid parameter
    Error Message: Param fbconnect must be a boolean
    pls refer attachments for refference.
    thanks.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	autofbook01.gif 
Views:	894 
Size:	5.3 KB 
ID:	7414   Click image for larger version. 

Name:	autofbook02.gif 
Views:	575 
Size:	2.2 KB 
ID:	7415  
    My Online Store
    Sumri (The Founder)

  3. #3
    Join Date
    Dec 2009
    Location
    Richmond, VA
    Posts
    167
    Plugin Contributions
    3

    Default Re: AutoFacebook [Support]

    K It looks as if Facebook changed their connect proceedure. of course this happened after the application was submitted to Zen Cart.

    Anyway heres the fix.

    go into your application's settings (same area from steps 5-7) and change the following:

    1st you'll see a Migration tab:
    Switch "New Data Permissions" to "Disabled"

    2nd now click the Connect tab:
    and switch your "connect url" to:
    http://apps.facebook.com/

  4. #4
    Join Date
    Mar 2008
    Posts
    46
    Plugin Contributions
    0

    Default Re: AutoFacebook [Support]

    Thanks.
    Successfully configures.
    But I get this error after adding product.

    Warning: include_once(facebook/php/facebook.php) [function.include-once]: failed to open stream: No such file or directory in /home/vshopgr9/public_html/admin/includes/modules/update_product.php on line 145

    Warning: include_once() [function.include]: Failed opening 'facebook/php/facebook.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/vshopgr9/public_html/admin/includes/modules/update_product.php on line 145

    Fatal error: Class 'Facebook' not found in /home/vshopgr9/public_html/admin/includes/modules/update_product.php on line 147
    My Online Store
    Sumri (The Founder)

  5. #5
    Join Date
    Dec 2009
    Location
    Richmond, VA
    Posts
    167
    Plugin Contributions
    3

    Default Re: AutoFacebook [Support]

    try changing (around) line 149 of your update_product.php file in the admin/includes/modules folder
    where you see
    PHP Code:
    include_once 'facebook/php/facebook.php'
    to:
    PHP Code:
    include_once 'includes/modules/facebook/php/facebook.php'

  6. #6
    Join Date
    Mar 2008
    Posts
    46
    Plugin Contributions
    0

    Default Re: AutoFacebook [Support]

    Quote Originally Posted by jamielife View Post
    try changing (around) line 149 of your update_product.php file in the admin/includes/modules folder
    where you see
    PHP Code:
    include_once 'facebook/php/facebook.php'
    to:
    PHP Code:
    include_once 'includes/modules/facebook/php/facebook.php'
    same result :
    Warning: include_once(includes/modules/facebook/php/facebook.php) [function.include-once]: failed to open stream: No such file or directory in /home/vshopgr9/public_html/admin/includes/modules/update_product.php on line 145

    Warning: include_once() [function.include]: Failed opening 'includes/modules/facebook/php/facebook.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/vshopgr9/public_html/admin/includes/modules/update_product.php on line 145

    Fatal error: Class 'Facebook' not found in /home/vshopgr9/public_html/admin/includes/modules/update_product.php on line 147
    My Online Store
    Sumri (The Founder)

  7. #7
    Join Date
    Dec 2009
    Location
    Richmond, VA
    Posts
    167
    Plugin Contributions
    3

    Default Re: AutoFacebook [Support]

    It looks like your include_path is set to a specific folder... Check your php.ini settings or try adding before the include_once line so it looks like:

    PHP Code:
    set_include_path('/home/vshopgr9/public_html/admin/includes/modules/)';
    include_once 
    'facebook/php/facebook.php'

  8. #8
    Join Date
    Dec 2009
    Location
    Richmond, VA
    Posts
    167
    Plugin Contributions
    3

    Default Re: AutoFacebook [Support]

    maybe play around with the paths

  9. #9
    Join Date
    Mar 2008
    Posts
    46
    Plugin Contributions
    0

    Default Re: AutoFacebook [Support]

    Thanks.
    works fine.
    But new problem came out.
    My website has been suspended due to usage of CPU was more than allowed by hosting provider.
    Is it because of this module?
    Just curious because my website has been suspended after I add few new products right after i've installed autofacebook mod.
    Thanks again.
    My Online Store
    Sumri (The Founder)

  10. #10
    Join Date
    Dec 2009
    Location
    Richmond, VA
    Posts
    167
    Plugin Contributions
    3

    Default Re: AutoFacebook [Support]

    I'd doubt it. When writing/testing it, I probably used it about 100 times a day(at least), of course that's on an ipower server. All it is doing is making a single JSON request to facebook. I wouldn't imagine that this would have got you suspended but I don't know your server's settings. Best to call them and find out.

 

 
Page 1 of 70 1231151 ... LastLast

Similar Threads

  1. v151 autofacebook help
    By sean g in forum All Other Contributions/Addons
    Replies: 0
    Last Post: 27 Nov 2014, 08:52 PM
  2. AutoFacebook and Canada Post Modules
    By DJLQD in forum General Questions
    Replies: 0
    Last Post: 27 Feb 2013, 02:32 PM
  3. v139h Help please with Autofacebook - Support thread is no longer supported
    By shags38 in forum General Questions
    Replies: 0
    Last Post: 18 Jul 2012, 01:49 PM
  4. Problems with AutoFacebook
    By amanda099 in forum All Other Contributions/Addons
    Replies: 1
    Last Post: 31 Aug 2010, 10:12 AM
  5. AutoFacebook OG 1.3.9 addon problems
    By eOstrE in forum All Other Contributions/Addons
    Replies: 0
    Last Post: 7 Jul 2010, 09:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR