Results 1 to 5 of 5
  1. #1
    Join Date
    May 2009
    Posts
    765
    Plugin Contributions
    1

    Default Admin Password required to proceed with upgrade

    Hi.

    I am trying to upgrade from 1.38 to 1.39.

    What I did:
    uploaded all the new files, renamed to _old the ones that are said to have been deleted in the docs list

    Launched the zc_install, and when asked to upgrade database, I did so, problem is it keeps reporting:
    Admin Password required to proceed with upgrade

    At first I thought I had forgotten the password, so I went to cpanel, and changed it using a hash convertor, went back, and still got the same error.

    What have I done wrong, and how to solve it?

    Thank you

  2. #2
    Join Date
    Jan 2005
    Location
    Lake Havasu, AZ
    Posts
    1,152
    Plugin Contributions
    0

    Default Re: Admin Password required to proceed with upgrade

    It is the user/pw that you use to login to your site admin - not your database user/pw info.

    Hope that helps!
    When the world gets in my face I say Have A Nice Day.
    * I DO Think and I HAVE BEEN Zenned - therefore, I AM * I donate - do you?
    Custom Templates and Zen Services CRS Designs, Inc.

  3. #3
    Join Date
    May 2009
    Posts
    765
    Plugin Contributions
    1

    Default Re: Admin Password required to proceed with upgrade

    Thanks, sorry I was not very clear, that is exactly what I am using: the admin id and password.

  4. #4
    Join Date
    Jan 2004
    Posts
    59,807
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: Admin Password required to proceed with upgrade

    Quote Originally Posted by keneso View Post
    At first I thought I had forgotten the password, so I went to cpanel, and changed it using a hash convertor, went back, and still got the same error.
    Um, you can't just hack the passwords in Zen Cart like that. If you changed the password by manually keying some generated code in via phpMyAdmin or any other "cpanel" interface, then it's definitely not going to work. Zen Cart's security is more sophisticated than that.

    ref: http://tutorials.zen-cart.com/index.php?article=2
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    May 2009
    Posts
    765
    Plugin Contributions
    1

    Default Re: Admin Password required to proceed with upgrade

    Thank you DrByte.
    It worked.

    Now I have to reload the 1.39b files ... I hope all will be fine ...

 

 

Similar Threads

  1. No password required/Quick Checkout
    By asterix in forum General Questions
    Replies: 8
    Last Post: 14 Aug 2008, 11:42 AM
  2. required password still causing problems
    By gsdcypher in forum General Questions
    Replies: 3
    Last Post: 23 Jan 2008, 04:34 PM
  3. State Field Not Required During Registration but Required in Admin?
    By Stenrique in forum Templates, Stylesheets, Page Layout
    Replies: 3
    Last Post: 2 Jun 2007, 09:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •