Page 6 of 23 FirstFirst ... 4567816 ... LastLast
Results 51 to 60 of 225
  1. #51
    Join Date
    May 2010
    Posts
    13
    Plugin Contributions
    0

    Default HTML Code in Email

    I need help to resolve this problem, i have been looking through the threads and have not found a solution yet.

    I upgraded to v1.3.9g from v1.3.9f yesterday, and when i did my emails in nowing showing html code in the final product for example

    when the email comes through it shows:

    <p>How are you</p>

    in the actual email

    i had to switch to text email, but i prefer html so i can send out pictures. Is there a file i can upload again to fix the rich text html editor from showing the code in the actual email.

  2. #52
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,402
    Plugin Contributions
    6

    Default Re: HTML tags show after upgrade to 1.3.9g

    NOTE: v1.3.9h has been released, which FIXES the issue, and makes the following workaround UNNECESSARY. The best solution is to upgrade.

    Try using for the extra_white_list.php file:
    /admin/includes/extra_configures/extra_white_list.php

    and put into that file the code:
    Code:
    <?php
    $global_xss_whitelist = isset($global_xss_whitelist) ? $global_xss_whitelist : array();
    $my_whitelist  = array('file_contents', 'banners_html_text', 'pages_title', 'message_html', 'manufacturers_name', 'symbol_left', 'symbol_right', 'query_string');
    $global_xss_whitelist = array_merge($my_whitelist, $global_xss_whitelist);
    and then try to edit the Define Page or Banner HTML or EZPage Title or Send Email once more and save it to see if this displays correctly ...

    NOTE: the file
    /admin/includes/extra_configures/extra_white_list.php

    is a file that you create for this code ...

    NOTE: Updated for Manufactuers Name, Currencies Left Symbol and Currencies Right Symbols and Install SQL Patches

    Steps to use the above code:
    1 create the file:
    /admin/includes/extra_configures/extra_white_list.php

    2 add the code posted above

    3 FTP the file to your server

    4 edit the section where you have the problem and save/update it to correct the issue
    Last edited by Ajeh; 23 Oct 2010 at 03:08 PM. Reason: update whitelist
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

  3. #53
    Join Date
    Jun 2008
    Location
    Canada
    Posts
    274
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Linda, You are the best! Thank you!

  4. #54
    Join Date
    Oct 2010
    Posts
    33
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Yes, I'm seeing the same thing in emails if you use Mime email true.

    I've applied the patch and it works for the other pages, but now the HTML emails are not working.

    Any patch for that?

  5. #55
    Join Date
    Oct 2010
    Posts
    33
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Also, in the patch code is the ending ?> purposely left off?

  6. #56
    Join Date
    May 2010
    Posts
    13
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Thank You!!!

    the extra_white_list.php file, resolved the issue with the email

  7. #57
    Join Date
    Apr 2006
    Location
    West Salem, IL
    Posts
    2,660
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Quote Originally Posted by azimpact View Post
    Also, in the patch code is the ending ?> purposely left off?
    That is fine, the closing php tag is not required
    Mike
    GeekHost - Zen Cart Certified & PCI Compliant Hosting
    The Zen Cart Forum...Better than a monitor covered with post-it notes!

  8. #58
    Join Date
    Oct 2010
    Posts
    33
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    All my issues are now fixed.

    I was using the first code that was posted so I was having issues but once I added the last code posted things are working good again.

    Thanks for the patch!

  9. #59
    Join Date
    Oct 2010
    Posts
    5
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Quote Originally Posted by Ajeh View Post
    NOTE: the file
    /admin/includes/extra_configures/extra_white_list.php

    is a file that you create for this code ...

    I just created this file using the exact code you have above and uploaded to the folder specified. My site won't load at all now. Admin still works, but the main site no longer renders at all: www.plrnichemart.com
    Last edited by acpaulley; 3 Oct 2010 at 07:34 AM.

  10. #60
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: HTML tags show after upgrade to 1.3.9g

    Quote Originally Posted by acpaulley View Post
    I just created this file using the exact code you have above and uploaded to the folder specified. My site won't load at all now. Admin still works, but the main site no longer renders at all: www.plrnichemart.com
    Making the changes discussed in this thread can't break the storefront, since they're only applicable to the admin side.

    You must have something else wrong in your storefront files.
    ref: https://www.zen-cart.com/tutorials/index.php?article=82
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 6 of 23 FirstFirst ... 4567816 ... LastLast

Similar Threads

  1. Replies: 25
    Last Post: 15 May 2010, 06:20 AM
  2. Replies: 11
    Last Post: 23 Nov 2009, 02:57 AM
  3. Replies: 5
    Last Post: 22 Jan 2009, 10:23 AM
  4. Replies: 4
    Last Post: 7 Jul 2008, 12:04 AM
  5. No HTML Editor after 1.3.6 upgrade
    By KADesign in forum Upgrading from 1.3.x to 1.3.9
    Replies: 13
    Last Post: 8 Nov 2006, 04:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR