Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2006
    Posts
    10
    Plugin Contributions
    0

    Default SSL Issues - not able to add items to the cart

    Hi.
    I have had an issue for a while now.
    When setting the config.php to what (i think) the correct settings should be you cannot had items to the cart.

    On Windows Server, if I configure the config.php to
    This works (But is using the wrong domain names for the end users web site)
    define('HTTP_SERVER', 'http://cc.dencom.co.nz/techbooks');
    define('HTTPS_SERVER', 'https://cc.dencom.co.nz/techbooks');


    This does not work, you cannot cannot add items to the Cart
    define('HTTP_SERVER', 'http://www.techbooks.co.nz');
    define('HTTPS_SERVER', 'https://cc.dencom.co.nz/techbooks');

    (i have a test server with a Shared Cert which also has the same issue)
    define('HTTP_SERVER', 'http://www.techbooks.co.nz');
    define('HTTPS_SERVER', 'https://www.techbooks.co.nz/techbooks');


    In teh last case using the shared Cert
    https://www.techbooks.co.nz/techbooks' is actually
    https://cc.dencom.co.nz/techbooks

    Sessions id's are stored in the DB.


    Ross

  2. #2
    Join Date
    Nov 2007
    Location
    Sunny Coast, Australia
    Posts
    3,188
    Plugin Contributions
    9

    Default Re: SSL Issues - not able to add items to the cart

    I arrived at (non-SSL) http://cc.dencom.co.nz/techbooks/ without problems.

    Then added a product to the cart - again no problem.

    Clicked the Checkout button and it took me to the secure Login page (as it should be). There were no errors.

    Worked fine for me ...

  3. #3
    Join Date
    Sep 2006
    Posts
    10
    Plugin Contributions
    0

    Default Re: SSL Issues - not able to add items to the cart

    Yes it does work for the Live Site, but I have had to set the configure.php to use the wrong domain names. I can only get it working using the cc.dencom.co.nz

    Should be (using a Shared Cert, in the Test Server)
    define('HTTP_SERVER', 'http://www.techbooks.co.nz');
    define('HTTPS_SERVER', 'https://www.techbooks.co.nz/techbooks');

    Seems to be an issue with the ZenID when changing from one virtual server to another. As I noticed a customer cannot login also.

  4. #4
    Join Date
    Nov 2007
    Location
    Sunny Coast, Australia
    Posts
    3,188
    Plugin Contributions
    9

    Default Re: SSL Issues - not able to add items to the cart

    Quote Originally Posted by dencom View Post
    Yes it does work for the Live Site, but I have had to set the configure.php to use the wrong domain names. I can only get it working using the cc.dencom.co.nz ...
    Any SSL cert only works for the domain it has been purchased/issued for.

    If the cert was issued explicitly for http://cc.dencom.co.nz then it *will not work* for http://www.techbooks.co.nz no matter how you set your 2 configure.php files.

    There are many other posts scattered through the forums dealing with exactly this same issue.

    For anyone else having this problem please see this tutorial which I posted about 12 months ago.

 

 

Similar Threads

  1. shopping cart box Items- issues
    By Develop&Promote in forum General Questions
    Replies: 3
    Last Post: 5 May 2010, 09:43 PM
  2. Sort Order Issues (items keeps rotating at random)
    By datatv in forum Templates, Stylesheets, Page Layout
    Replies: 6
    Last Post: 12 Dec 2009, 03:08 AM
  3. Cart Items Spacing Issues
    By UranusApparel in forum Templates, Stylesheets, Page Layout
    Replies: 4
    Last Post: 31 Mar 2009, 11:39 PM
  4. PHP 5.x - Issues with Zen-Cart
    By rwoody in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 24 Aug 2006, 11:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR