Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2011
    Posts
    4
    Plugin Contributions
    0

    Default Blank Page after fresh install

    I get a Blank Page for the store after a fresh install and the admin page comes up with an error page warning that my configure.php files have invalid paths or I never did the install. Checked both configure.php files and no invalid paths.

    The following applies:
    Zen- Cart v 1.3.9
    Running Solaris 10 OS
    No addons
    Checked FAQ
    Followeds steps in https://www.zen-cart.com/tutorials/index.php?
    Add Code:
    define('STRICT_ERROR_REPORTING', true);
    to the file /includes/local/configure.php produces nothing.
    Check cache directory for DEBUG messages, found none.

    I get the following error in my Apache access logs when accessing store main page: GET /index.php HTTP/1.1" 500 -
    Also get the following in Apache Error logs when accessing admin page: GET /admin/index.php HTTP/1.1" 200 2741
    GET /includes/templates/template_default/images/logo.gif HTTP/1.1" 304 -

    My mysql database get populated with the store tables.
    Any ideas on whats going on here?

  2. #2
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Blank Page after fresh install

    Many servers don't like the use of 777 permissions on files/folders, so you'll need to use a lower value.

    Or, for the EXACT cause of YOUR 500 error, ask your hosting company. They can look it up in the server's logs.
    https://www.zen-cart.com/tutorials/index.php?article=63
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Jul 2011
    Posts
    4
    Plugin Contributions
    0

    Default Re: Blank Page after fresh install

    This server has no problem with 777 permissions, running other pages with 777 permissions. The http 500 error is the generic error the web server gets when it cannot fulfill the request. There is no external malfunction with the web server. I am running other PHP apps that can access Mysql perfectly fine.

    My zencart is failing after a call to autoload_func.php.

  4. #4
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Blank Page after fresh install

    Okay, so what's the exact error message recorded by the server, in the server's logs?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Jul 2011
    Posts
    4
    Plugin Contributions
    0

    Default Re: Blank Page after fresh install

    Sorry if I was not clear in explaining the errors earlier.
    When accessing the main page i.e. "www.mydomain.com/index.php" I do not get any errors in the Apache web logs however in the access logs I get the following:
    GET /index.php HTTP/1.1" 500 -

    When accessing the admin page i.e "www.mydowmain.com/admin/index.php" I get an error in the Apache web logs as following:
    GET /admin/index.php HTTP/1.1" 200 2741
    GET /includes/templates/template_default/images/logo.gif HTTP/1.1" 304 -

    There were reported error in the servers system logs.

  6. #6
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Blank Page after fresh install

    Quote Originally Posted by wgee View Post
    however in the access logs I get the following:
    GET /index.php HTTP/1.1" 500 -
    Naturally, yes. The *access* logs will simply show a GET and a 500 response code. That's mostly all that the *access* logs will tell you.

    It's the *error* or *mod_security* logs that you need to consult for the cause of 500 errors. The *access* logs are useless as far as causes of errors.
    Quote Originally Posted by wgee View Post
    When accessing the admin page i.e "www.mydowmain.com/admin/index.php" I get an error in the Apache web logs as following:
    GET /admin/index.php HTTP/1.1" 200 2741
    That's entirely normal. A 200 response is not an error.
    Quote Originally Posted by wgee View Post
    GET /includes/templates/template_default/images/logo.gif HTTP/1.1" 304 -
    That's not an error. A 304 response simply means the page was requested and the cached copy of the file had not changed, so it didn't need to reload the image file. Again, completely normal. That's an access-log response, not an error-log response.
    Quote Originally Posted by wgee View Post
    There were reported error in the servers system logs.
    Um ... then please post them.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Jul 2011
    Posts
    4
    Plugin Contributions
    0

    Default Re: Blank Page after fresh install

    When accessing the main store page I do not get any error message written to the error log file, but the page is blank. Can you explain why this happens?

    I made a mistake in my last response there are no reported errors in the system logs.

    With the admin page the application is writing to the error logs. I see a page that states that "You are seeing this page for one or more reasons:"

    Then it list two reasons.
    1. I haven't completed the installation, which I have.

    2. My /includes/configure.php and/or /admin/configure.php files contain an invalid path or invalid database-connection information.

    I checked my paths over and over again paths are good. The database connection is good because my database was populated.

 

 

Similar Threads

  1. Admin page in loop after fresh install
    By jeffiec in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 27 Apr 2011, 02:22 AM
  2. Complete fresh install = blank website
    By audiomandan in forum General Questions
    Replies: 7
    Last Post: 29 Nov 2010, 02:32 AM
  3. Blank page after install
    By cvc505 in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 9 Jul 2010, 11:17 PM
  4. blank page on sumbit! PHP errors? fresh install!
    By slappadudle in forum General Questions
    Replies: 1
    Last Post: 27 Jun 2009, 06:15 AM
  5. Fresh Install, Blank Page when I try to get to admin
    By Cyopz in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 15 Aug 2008, 01:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR