Thread: Moving troubles

Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Join Date
    Apr 2008
    Posts
    29
    Plugin Contributions
    0

    Default Moving troubles

    1.3.8a version
    no upgrade, moving from one server to a new one
    no addons
    just appearance on customization

    Ok basically this. Moved from one server to another.
    I followed the tutorial to the letter.
    http://tutorials.zen-cart.com/index.php?article=100
    It worked until i got to number 6.

    Ran fix_cache_key and got this in my browser

    1146 Table 'wolfpeng_znc2.wolfpeng_configuration' doesn't exist
    in:
    [select configuration_key as cfgkey, configuration_value as cfgvalue from wolfpeng_configuration]


    wolfpeng_znc2 does exist. i don't know where its getting wolfpeng_znc2.wolfpeng_configuration from. AND like fixkey said, it didn't sync up and didn't fix the problem it found.

    Where do i go now?

    what other info might be needed

  2. #2
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,616
    Plugin Contributions
    25

    Default Re: Moving troubles

    It looks as though you have added wolfpeng_ as a database prefix. Do your database tables start with this? Do they have a different prefix? Or no prefix at all (i.e. your configuration table is simply called configuration and not, say, zen_configuration)?

    And do you have an upgrade scheduled for after this move?
    See and test drive Zen Cart's free templates at (sorry, site offline)

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  3. #3
    Join Date
    Apr 2008
    Posts
    29
    Plugin Contributions
    0

    Default Re: Moving troubles

    Quote Originally Posted by kuroi View Post
    It looks as though you have added wolfpeng_ as a database prefix. Do your database tables start with this? Do they have a different prefix? Or no prefix at all (i.e. your configuration table is simply called configuration and not, say, zen_configuration)?

    And do you have an upgrade scheduled for after this move?
    uggggh
    uhmm i remember adding wolfpen as a prefix somehwere

  4. #4
    Join Date
    Apr 2008
    Posts
    29
    Plugin Contributions
    0

    Default Re: Moving troubles

    how do i fix my foobar

  5. #5
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,616
    Plugin Contributions
    25

    Default Re: Moving troubles

    If you're not using a prefix, then check whether it has been added to your includes/configure.php and admin/includes/configure.php files, and if so, remove it.
    See and test drive Zen Cart's free templates at (sorry, site offline)

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  6. #6
    Join Date
    Apr 2008
    Posts
    29
    Plugin Contributions
    0

    Default Re: Moving troubles

    Ok got new error..



    1146 Table 'wolfpeng_znc2.configuration' doesn't exist
    in:
    [select configuration_key as cfgkey, configuration_value as cfgvalue from configuration]

    i removed the dbprefix from the configure.php in both directories

  7. #7
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,616
    Plugin Contributions
    25

    Default Re: Moving troubles

    You've never answered the question about whether or not you're using a database prefix (other than "wolfpeng_").

    So two possibilities:
    • either you haven't moved the tables properly and really don't have a configuration table OR
    • you're using a database prefix but haven't told your Zen Cart what it is.
    See and test drive Zen Cart's free templates at (sorry, site offline)

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  8. #8
    Join Date
    Apr 2008
    Posts
    29
    Plugin Contributions
    0

    Default Re: Moving troubles

    Quote Originally Posted by kuroi View Post
    You've never answered the question about whether or not you're using a database prefix (other than "wolfpeng_").

    So two possibilities:
    • either you haven't moved the tables properly and really don't have a configuration table OR
    • you're using a database prefix but haven't told your Zen Cart what it is.
    Uggh Ok bear with me please. I am not a dba. LOL. Uhm my database name is...

    OK i think i did but here it goes. I DID use wolfpen_ as a identifier. I removed it from the configure.php files.

    Now i redid the fixkey I even dropped tables and imported back in and then ran fixkey. Still no go
    Last edited by skruzich; 14 Aug 2011 at 05:42 PM.

  9. #9
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,616
    Plugin Contributions
    25

    Default Re: Moving troubles

    What is the full name of your table with the name ending configuration?
    See and test drive Zen Cart's free templates at (sorry, site offline)

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  10. #10
    Join Date
    Apr 2008
    Posts
    29
    Plugin Contributions
    0

    Default Re: Moving troubles

    thank you for your patience. I jjust reinstalled the software and reimorted the database. fixed it right up for me. Now i know what caused the roblem the extension i won't make that error again. :) Thank you!

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Moving on now domen troubles
    By kobra8 in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 28 Jan 2012, 06:30 PM
  2. IE 7 troubles
    By AndyII in forum General Questions
    Replies: 2
    Last Post: 20 Mar 2009, 04:17 PM
  3. Template troubles
    By FaustusTheAwesome in forum General Questions
    Replies: 2
    Last Post: 17 Jul 2008, 10:58 AM
  4. htaccess troubles
    By GrandmaJ in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 20 Feb 2007, 05:47 AM
  5. DB Troubles
    By kobra in forum Upgrading from 1.2 to 1.3.x
    Replies: 6
    Last Post: 7 Jun 2006, 06:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR