Page 21 of 56 FirstFirst ... 11192021222331 ... LastLast
Results 201 to 210 of 551
  1. #201
    Join Date
    May 2007
    Posts
    71
    Plugin Contributions
    0

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    Thanks Steve
    All my language feeds now have unique Ids.

    With the new version 1.12.5 , for the german and french feeds I'm getting diamond shaped question marks ie occup�

    I didn't get this problem with the earlier versions.

    I tried removing the htmlentities function from Googlefroogle as previously suggested however it didnt work.

    Any help would be appreciated.

  2. #202
    Join Date
    Aug 2007
    Location
    Gijón, Asturias, Spain
    Posts
    1,211
    Plugin Contributions
    24

    Default v1.12.5 corrupted characters in feeds

    Being the masochist I am, I decided to try out 1.12.5, despite my version working perfectly.
    I found my feed being rejected where a degree symbol was in use and a corrupted character (square) was being created.
    I find the reason in google_base.php (as always), in the sanita function which has been moved and mostly commented out.
    PHP Code:
        function google_base_sanita($str$rt=false) {
          
    //global $products;
          
    $str str_replace(array("\r\n""\r""\n"" "), ' '$str);
          
    $str strip_tags($str);
          
    //$charset = 'UTF-8';
          //if (defined(CHARSET)) {
            //$charset = strtoupper(CHARSET);
          //}
          
    $str html_entity_decode($strENT_QUOTES);//, $charset);
          //$str = html_entity_decode($str, ENT_QUOTES, $charset);
          //$str = htmlspecialchars($str, ENT_QUOTES, '', false);
          //$str = htmlentities($str, ENT_QUOTES, $charset, false); 
          
    return $str;
        } 
    Regressing this code to include the charset again:
    PHP Code:
        function google_base_sanita($str$rt=false) {
          
    //global $products;
          
    $str str_replace("\r\n"' '$str);
          
    $str strip_tags($str);
          
    $charset 'UTF-8';
          if (
    defined(CHARSET)) {
            
    $charset strtoupper(CHARSET);
          }
          
    $str html_entity_decode($strENT_QUOTES$charset);
          
    //$str = html_entity_decode($str, ENT_QUOTES, $charset);
          //$str = htmlspecialchars($str, ENT_QUOTES, '', false);
          //$str = htmlentities($str, ENT_QUOTES, $charset, false); 
          
    return $str;
        } 
    Fixed my problem.
    Steve
    "Totally Zenned" my a*se!

  3. #203
    Join Date
    May 2008
    Posts
    263
    Plugin Contributions
    0

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    Just installed 1.12.4 over an old version that was throwing out the "availability" error and causing 0 products to show up in google.

    Ran the uninstall script, then the install script. Everything looks ok on the admin side, but when clicking the xml file, it is blank. Before this upgrade, if the xml link was clicked, it showed all of the products like an rss feed.

    Tried to upload it to google and only a handful of products were inserted, all of which were sold long ago. The feed level messages shows "XML formatting error - Error".

  4. #204
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,302
    Plugin Contributions
    18

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    Quote Originally Posted by pricediscrimination View Post
    Just installed 1.12.4 over an old version that was throwing out the "availability" error and causing 0 products to show up in google.

    Ran the uninstall script, then the install script. Everything looks ok on the admin side, but when clicking the xml file, it is blank. Before this upgrade, if the xml link was clicked, it showed all of the products like an rss feed.

    Tried to upload it to google and only a handful of products were inserted, all of which were sold long ago. The feed level messages shows "XML formatting error - Error".
    Turn on the sanitizer function and see if that makes a difference.

  5. #205
    Join Date
    May 2008
    Posts
    263
    Plugin Contributions
    0

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    Quote Originally Posted by delia View Post
    Turn on the sanitizer function and see if that makes a difference.
    Does that mean go to includes/classes/google_base.php and remove the comment-out between lines 439 and 442 as in @torvista's post above?

    I just did that. Nothing changed. Nothing showing up in the XML.

  6. #206
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,302
    Plugin Contributions
    18

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    No, it kinda sounds like it's not installed properly. Did you turn on debugging so that you can see the products as you export?

  7. #207
    Join Date
    May 2008
    Posts
    263
    Plugin Contributions
    0

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    Quote Originally Posted by delia View Post
    No, it kinda sounds like it's not installed properly. Did you turn on debugging so that you can see the products as you export?
    With debug mode on, the popup shows that the products are being exported without errors, but then the actual xml file is still not showing anything.

  8. #208
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,302
    Plugin Contributions
    18

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    Quote Originally Posted by pricediscrimination View Post
    With debug mode on, the popup shows that the products are being exported without errors, but then the actual xml file is still not showing anything.
    Are you only trying to view the xml file in the browser or are you downloading it and opening it on your computer? Just because you can't see anything in the browser does not mean the file is empty.

  9. #209
    Join Date
    May 2008
    Posts
    263
    Plugin Contributions
    0

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    Also, it is still trying to include products that are located in a category that is excluded in the Google Base Feeder Configuration admin.

  10. #210
    Join Date
    May 2008
    Posts
    263
    Plugin Contributions
    0

    Default Re: The NEW Google Merchant Thread - Version 1.12.0

    Quote Originally Posted by delia View Post
    Are you only trying to view the xml file in the browser or are you downloading it and opening it on your computer? Just because you can't see anything in the browser does not mean the file is empty.
    Good point. When viewing in the browser, nothing is there. But before, it used to display each product almost like looking at a blog's RSS feed.

    After opening it file in wordpad, the actual XML appears to have the content there. But again, is showing products from a category that is supposed to be excluded.

    I upgraded from an older (don't even know how old) version. Uploaded all the files. Then ran the update_1_12_4 SQL script then ran the uninstall script, then ran the install script again. Not the right way probably, I know. But the weird thing is that all of the settings in admin seem to have stayed the same. Is that normal?

 

 
Page 21 of 56 FirstFirst ... 11192021222331 ... LastLast

Similar Threads

  1. v150 Numinix Fedex Module 1.30
    By Limitless in forum Addon Shipping Modules
    Replies: 2
    Last Post: 2 Oct 2012, 03:47 AM
  2. Numinix FedEx Module on 1.39 - Error in Processing Transaction
    By giantfan in forum Addon Shipping Modules
    Replies: 2
    Last Post: 5 Jun 2012, 09:56 PM
  3. NUMINIX FedEx Web Services Module Question - List Rates
    By janellez in forum Addon Shipping Modules
    Replies: 4
    Last Post: 23 Mar 2012, 09:18 PM
  4. Periship module from Numinix - Problem with recipient info
    By hockey2112 in forum Addon Shipping Modules
    Replies: 1
    Last Post: 12 Jan 2012, 11:25 PM
  5. FedEx module Numinix 1.4.5.2 getting started
    By FlawlessDzign in forum Addon Shipping Modules
    Replies: 10
    Last Post: 27 Mar 2011, 08:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •