Page 347 of 348 FirstFirst ... 247297337345346347348 LastLast
Results 3,461 to 3,470 of 3479
  1. #3461
    Join Date
    Jan 2011
    Location
    Adelaide, Australia
    Posts
    1,628
    Plugin Contributions
    1

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by mc12345678 View Post
    Change the spaces in the filename to... well non-spaces. E.g, underscore, dash, squashed together, whatever... no extra effort was made to handle filenames with spaces.
    many thanks MC ... with filename change I get the file to upload and import but with error 'no category provided for this new item' - the category name column is complete for all entries - there are 194 products in the file, 36 are products that already exist on the site, 158 are 'new products' - the anomoly here is 'new products' - see the summary below. (new products data copied from another file from another site and added to this file - all columns are complete).

    Not sure why it is not adding the new products??

    Finished Processing Import File

    Updated records: 36
    New Imported records: 0
    Errors Detected: 158
    Warnings Detected: 0
    Memory Usage: 1318792
    Memory Peak: 1728704
    Execution Time: 0 seconds.

    Click image for larger version. 

Name:	Clip-On-Earrings-import-file-results.jpg 
Views:	44 
Size:	60.2 KB 
ID:	20142

  2. #3462
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by shags38 View Post
    many thanks MC ... with filename change I get the file to upload and import but with error 'no category provided for this new item' - the category name column is complete for all entries - there are 194 products in the file, 36 are products that already exist on the site, 158 are 'new products' - the anomoly here is 'new products' - see the summary below. (new products data copied from another file from another site and added to this file - all columns are complete).

    Not sure why it is not adding the new products??

    Finished Processing Import File

    Updated records: 36
    New Imported records: 0
    Errors Detected: 158
    Warnings Detected: 0
    Memory Usage: 1318792
    Memory Peak: 1728704
    Execution Time: 0 seconds.

    Click image for larger version. 

Name:	Clip-On-Earrings-import-file-results.jpg 
Views:	44 
Size:	60.2 KB 
ID:	20142
    I have guesses, but need more info. Just about anything will help, but first thing that comes to mind is the settings in configuration for the module, then there is a list of the headers of your import file, and then an example of one of these existent field's data.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  3. #3463
    Join Date
    Apr 2006
    Location
    Dark Side of the Moon
    Posts
    987
    Plugin Contributions
    1

    Default Re: EasyPopulate 4.0 Support Thread

    Hiya MC12345678!!!

    Fresh install of EP4 on clean install of Zen 1.5.8 and php 8.1:

    First issue I had was the blank page... made the private to public change noted above in query factory but it did not fix blank page.
    Checked error logs and there is some issue with ep4 error logging folder...

    So I un-commented line 97 of easypopulate_4.php:

    Code:
     $ep_debug_logging_all = false; // do not comment out.. make false instead This is now controlled from admin.
    and was able to run the EP4 installer.

    I created a couple directories and test products with sub-categories manually.
    Exported a FULL EP4 file, and turned around and was able to import and all "updated" correctly.

    I then manually deleted these products and categories from the admin and re-ran the import and received this:

    SKIPPED! - v_products_model: TEST_Model - No category provided for this new product
    SKIPPED! - v_products_model: TEST_Model_2 - No category provided for this new product

    Haven't looked any deeper yet. I'm going to have to sweep the cobwebs out of my brain and look at the code again. Been quite a few years since you adopted EP4! Glad to see you are still taking good care of it!

    Almost 3500 posts! Holy Cow!

  4. #3464
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    8,697
    Plugin Contributions
    9

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by chadderuski View Post
    Almost 3500 posts! Holy Cow!
    Yep, it's popular and complicated. The best way to help at this point (moving into 1.5.8) is to post in github witht the following in mind:

    **Describe the bug**A clear and concise description of what the bug is.
    Be sure to explain the business problem that this bug is affecting.


    **Version**
    Zen Cart version:
    PHP version:
    MySQL version:
    Plugins that may be related:
    What older/newer versions were also tested?


    **To Reproduce**
    Steps to reproduce/demonstrate the behavior:
    1. Go to '...'
    2. Click on '....'
    3. Scroll down to '....'
    4. See such-and-such


    **Expected behavior**
    A clear and concise description of what the bug is preventing from happening correctly.
    It's helpful also to explain why what you expected to happen is important. (eg: is this a "software bug" or a "this bugs me" situation?)


    **Screenshots**
    If applicable, add screenshots to help explain.


    **Debug/Error Logs**
    Include debug logs containing PHP and/or MySQL error details. These are often found in your /logs/ directory as myDebug-xxxxx.log files.

    **Devices (please complete the following information):**
    - Operating System: [e.g. Windows, Mac, Android, iOS]
    - Browser [e.g. chrome, firefox] and version number


    **Additional context**
    Add any other context about the problem here.

  5. #3465
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by chadderuski View Post
    Hiya MC12345678!!!

    Fresh install of EP4 on clean install of Zen 1.5.8 and php 8.1:

    First issue I had was the blank page... made the private to public change noted above in query factory but it did not fix blank page.
    Checked error logs and there is some issue with ep4 error logging folder...

    So I un-commented line 97 of easypopulate_4.php:

    Code:
     $ep_debug_logging_all = false; // do not comment out.. make false instead This is now controlled from admin.
    and was able to run the EP4 installer.

    I created a couple directories and test products with sub-categories manually.
    Exported a FULL EP4 file, and turned around and was able to import and all "updated" correctly.

    I then manually deleted these products and categories from the admin and re-ran the import and received this:

    SKIPPED! - v_products_model: TEST_Model - No category provided for this new product
    SKIPPED! - v_products_model: TEST_Model_2 - No category provided for this new product

    Haven't looked any deeper yet. I'm going to have to sweep the cobwebs out of my brain and look at the code again. Been quite a few years since you adopted EP4! Glad to see you are still taking good care of it!

    Almost 3500 posts! Holy Cow!
    Yeah, bad assembly of a distribution package.

    I was going to make all language based fields default to using the language code (en, es, de, etc.) Then realized how much trouble that would cause existing users, so went back in the code to default to language id (1, 2, 3, etc), but the sql install has already been set to default to language code basically.

    Essentially, ensure alignment with language import configuration settings with what you have or want to have in your import file. There is also an export setting about how the fields will be titled (code, id, or both). It's been made versatile, but has a known initial installation problem to be fixed on the next update.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  6. #3466
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by dbltoe View Post
    Yep, it's popular and complicated. The best way to help at this point (moving into 1.5.8) is to post in github witht the following in mind:
    The quoted text of the above message is absolutely appropriate to report the associated issue; however, one could claim that the design of this module is why it is an issue and something I expect response to indicate that the module should either be revamped or dismissed. The central issue though is that the Zen Cart 1.5.8 redesign prohibits the use of any mysqli_xxx code that requires the mysql object of the database using the associated database. Based on the writeup by the individual that submitted the PR, reason and consideration as to why any of those features might be considered necessary or concerns of making the member public as compared to offering an access method to the member.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  7. #3467
    Join Date
    Jan 2011
    Posts
    65
    Plugin Contributions
    0

    Default Re: EasyPopulate 4.0 Support Thread

    Hello,

    I'm running ZC 1.5.7d and php 7.4. Everything about EASYPOPULATE looks like it works correctly, except I cannot seem to successfully import the edited changes to the "v_products_name_1" column, which are the product titles.

    The import message shows no errors - everything imports, but the product titles don't reflect the edits made to the CSV.

    Has anyone else encountered this problem or can suggest where to start looking to resolve this?

    Thanks in advance!

    Click image for larger version. 

Name:	Screenshot 2022-11-27 173820.jpg 
Views:	5 
Size:	45.0 KB 
ID:	20167

  8. #3468
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by RoboPhung View Post
    Hello,

    I'm running ZC 1.5.7d and php 7.4. Everything about EASYPOPULATE looks like it works correctly, except I cannot seem to successfully import the edited changes to the "v_products_name_1" column, which are the product titles.

    The import message shows no errors - everything imports, but the product titles don't reflect the edits made to the CSV.

    Has anyone else encountered this problem or can suggest where to start looking to resolve this?

    Thanks in advance!

    Click image for larger version. 

Name:	Screenshot 2022-11-27 173820.jpg 
Views:	5 
Size:	45.0 KB 
ID:	20167
    There are always a number of reasons that something may have gone wrong. Generally it is because of the configuration of something or another. Best to start with is to show the configuration settings for EP4 and identify the name of the file being used to import
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  9. #3469
    Join Date
    Jan 2011
    Posts
    65
    Plugin Contributions
    0

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by mc12345678 View Post
    There are always a number of reasons that something may have gone wrong. Generally it is because of the configuration of something or another. Best to start with is to show the configuration settings for EP4 and identify the name of the file being used to import
    Thank you for the quick reply. These are my Easypopulate settings:

    Uploads Directory eptemp/ Info
    Upload File Date Format m-d-y Info
    Default Raw Time 09:00:00 Info
    Upload/Download Prices Include Tax false Info
    Verbose Feedback true Info
    Make Zero Qty Products Inactive false Info
    Smart Tags Replacement of Newlines true Info
    Advanced Smart Tags false Info
    Debug Logging true Info
    Maximum Quantity Discounts 3 Info
    Split On Number of Records 2000 Info
    Script Execution Time 60 Info
    Convert Curly Quotes, etc. 0 Info
    Convert Character 0x92 1 Info
    Enable Products Meta Data 0 Info
    Enable Products Music Data 0 Info
    User Defined Products Fields Info
    Uploads Directory Admin/Catalog true Info
    Import/Export Primary Key products_model Info
    Import Language Override language_code_only Info
    Import/Export CSV Delimiter , Info
    Export Language Identifier id Info
    Export Price Decimals 2 Info
    Export Filename Date Y-m-d Info
    Show all EP4 Filetypes with Files true Info
    Replace Blank Image false Info
    Activate Blank Featured true Info
    Remove Blank Specials negative Info
    Auto-extend fields false Info
    Export URI with Prod and or Cat 0

    Click image for larger version. 

Name:	Screenshot.jpg 
Views:	3 
Size:	25.9 KB 
ID:	20168

    I should have expanded my original post and explain that the other numerical fields in the CSV, such as product weight, and stock quantity, can update via EASYPOPULATE successfully when I modify these values in the CSV. The only field that doesn't update, and does not show any error or warning messages after import is the v_products_name_1 field.
    Last edited by RoboPhung; 28 Nov 2022 at 05:15 AM. Reason: Add Image

  10. #3470
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by RoboPhung View Post
    Thank you for the quick reply. These are my Easypopulate settings:

    Uploads Directory eptemp/ Info
    Upload File Date Format m-d-y Info
    Default Raw Time 09:00:00 Info
    Upload/Download Prices Include Tax false Info
    Verbose Feedback true Info
    Make Zero Qty Products Inactive false Info
    Smart Tags Replacement of Newlines true Info
    Advanced Smart Tags false Info
    Debug Logging true Info
    Maximum Quantity Discounts 3 Info
    Split On Number of Records 2000 Info
    Script Execution Time 60 Info
    Convert Curly Quotes, etc. 0 Info
    Convert Character 0x92 1 Info
    Enable Products Meta Data 0 Info
    Enable Products Music Data 0 Info
    User Defined Products Fields Info
    Uploads Directory Admin/Catalog true Info
    Import/Export Primary Key products_model Info
    Import Language Override language_code_only Info
    Import/Export CSV Delimiter , Info
    Export Language Identifier id Info
    Export Price Decimals 2 Info
    Export Filename Date Y-m-d Info
    Show all EP4 Filetypes with Files true Info
    Replace Blank Image false Info
    Activate Blank Featured true Info
    Remove Blank Specials negative Info
    Auto-extend fields false Info
    Export URI with Prod and or Cat 0

    Click image for larger version. 

Name:	Screenshot.jpg 
Views:	3 
Size:	25.9 KB 
ID:	20168

    I should have expanded my original post and explain that the other numerical fields in the CSV, such as product weight, and stock quantity, can update via EASYPOPULATE successfully when I modify these values in the CSV. The only field that doesn't update, and does not show any error or warning messages after import is the v_products_name_1 field.
    It normally also helps to also know what other fields are in the import file, but I already can sort the issue based on the five or six ways that it has been described over as many or more page threads.

    Change: Import Language Override language_code_only Info

    Literally to any other value. Right now it only imports language type fields that are provided using the two letter language code. What is provided in your import file is the language field using the language_id. As recently described to chadderuski (basically the original developer of EP4) there is an alignment to be had between what is to be imported and what is allowed to be imported. I changed the plan on mid distribution development. The default setting for that option should have been: language_id_only.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

 

 

Similar Threads

  1. Hebrew Support - latest release [Support Thread]
    By eranariel in forum Addon Language Packs
    Replies: 19
    Last Post: 23 Jan 2023, 08:04 AM
  2. BackUp ZC [Support Thread]
    By skipwater in forum All Other Contributions/Addons
    Replies: 285
    Last Post: 23 Dec 2020, 10:40 AM
  3. Wordpress On ZC [Support Thread]
    By hira in forum All Other Contributions/Addons
    Replies: 1858
    Last Post: 17 Jan 2014, 01:24 AM
  4. ZJ Black 2 support thread
    By Liamv in forum Addon Templates
    Replies: 1
    Last Post: 15 Feb 2010, 02:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR