Page 333 of 348 FirstFirst ... 233283323331332333334335343 ... LastLast
Results 3,321 to 3,330 of 3479
  1. #3321
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by g2ktcf View Post
    I just want to EXPORT so I can import the shipping info from my store into Shippo since that their API is so old.
    Ohhh... Darnit, I deleted the link that I had found for Orders Exporter. Sorry... I went too far into the "dilemma". :)
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  2. #3322
    Join Date
    Jul 2017
    Location
    United States
    Posts
    10
    Plugin Contributions
    0

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by mc12345678 View Post
    What's the name of the file? I am assuming that it has a space in it...
    She-Loves-Color-Secret-Shop-2021.csv

  3. #3323
    Join Date
    Jul 2017
    Location
    United States
    Posts
    10
    Plugin Contributions
    0

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by Reviresco View Post
    She-Loves-Color-Secret-Shop-2021.csv

    Still trying to get this to work.

  4. #3324
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by Reviresco View Post
    I've changed the menu option Import Language Override to language_id, and I'm still getting the same result: when I click the Import button, I get redirected to the admin main page and nothing has been imported; also no errors anywhere. This also happens if I click the Delete button.
    Quote Originally Posted by mc12345678 View Post
    What's the name of the file? I am assuming that it has a space in it...
    Quote Originally Posted by Reviresco View Post
    She-Loves-Color-Secret-Shop-2021.csv
    Quote Originally Posted by Reviresco View Post
    Still trying to get this to work.
    While I have it (version 4.0.36.13/ZC) working with ZC 1.5.7x I am not seeing the above issue(s) occurring... I could see a possible problem if files in a site's directory were in some way "locked" down, for example, clicking the delete button for a file that is prevented from being deleted, possibly. I don't see anything special about the filename that would prevent deletion (as stated typical/historical issues with filenames as far as preventing something from happening) has been spaces in the filename or some other character that is not accepted by the filesystem where the file has been stored.

    The only other time that I have seen ZC 1.5.7 respond the way that is described is when a form (user input area) is set to provide information in the browser address bar instead of passing the information along in the background. In EP4 the links that are like this "problem" area are the clickable links below the filters (they export data) and the download link adjacent to each stored filename. Even those in that situation feed back to the same file. Feeding back to the same file actually is a good thing as it actually eliminates a problem.

    Perhaps attempt to upload the files again? I know Chadderuski used to suggest verifying file load to include possibly building a temporary site, loading the files to it and then attempt to upload and import the file(s).

    Basically either I need to be able to see the issue in action or I need to be able to reproduce it in order to find a solution.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  5. #3325
    Join Date
    Jul 2017
    Location
    United States
    Posts
    10
    Plugin Contributions
    0

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by mc12345678 View Post
    While I have it (version 4.0.36.13/ZC) working with ZC 1.5.7x I am not seeing the above issue(s) occurring... I could see a possible problem if files in a site's directory were in some way "locked" down, for example, clicking the delete button for a file that is prevented from being deleted, possibly. I don't see anything special about the filename that would prevent deletion (as stated typical/historical issues with filenames as far as preventing something from happening) has been spaces in the filename or some other character that is not accepted by the filesystem where the file has been stored.

    The only other time that I have seen ZC 1.5.7 respond the way that is described is when a form (user input area) is set to provide information in the browser address bar instead of passing the information along in the background. In EP4 the links that are like this "problem" area are the clickable links below the filters (they export data) and the download link adjacent to each stored filename. Even those in that situation feed back to the same file. Feeding back to the same file actually is a good thing as it actually eliminates a problem.

    Perhaps attempt to upload the files again? I know Chadderuski used to suggest verifying file load to include possibly building a temporary site, loading the files to it and then attempt to upload and import the file(s).

    Basically either I need to be able to see the issue in action or I need to be able to reproduce it in order to find a solution.
    Here's what the form looks like:

    HTML Code:
    <form name="import_form" action="https://www.mysite.com/my-shop/my-admin/index.php?cmd=easypopulate_4.php" method="post"><input type="hidden" name="securityToken" value="securitytokenhere"><input type="hidden" name="import" value="She-Loves-Color-Secret-Shop-2021.csv"><input type="submit" name="import_button" value="Import"></form>

  6. #3326
    Join Date
    Jul 2017
    Location
    United States
    Posts
    10
    Plugin Contributions
    0

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by Reviresco View Post
    Here's what the form looks like:

    HTML Code:
    <form name="import_form" action="https://www.mysite.com/my-shop/my-admin/index.php?cmd=easypopulate_4.php" method="post"><input type="hidden" name="securityToken" value="securitytokenhere"><input type="hidden" name="import" value="She-Loves-Color-Secret-Shop-2021.csv"><input type="submit" name="import_button" value="Import"></form>
    When I change (in the browser console):

    index.php?cmd=easypopulate_4.php

    to just:

    easypopulate_4.php

    it works.

    What's the best way to change this? Is it a global setting I need to change in Zen Cart? Htaccess? Something else? All the links in the admin "Tools" dropdown menu use the "index.php?cmd=xxxx" format.

  7. #3327
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by Reviresco View Post
    Here's what the form looks like:

    HTML Code:
    <form name="import_form" action="https://www.mysite.com/my-shop/my-admin/index.php?cmd=easypopulate_4.php" method="post"><input type="hidden" name="securityToken" value="securitytokenhere"><input type="hidden" name="import" value="She-Loves-Color-Secret-Shop-2021.csv"><input type="submit" name="import_button" value="Import"></form>
    That is the content expected...

    Quote Originally Posted by Reviresco View Post
    When I change (in the browser console):

    index.php?cmd=easypopulate_4.php

    to just:

    easypopulate_4.php

    it works.

    What's the best way to change this? Is it a global setting I need to change in Zen Cart? Htaccess? Something else? All the links in the admin "Tools" dropdown menu use the "index.php?cmd=xxxx" format.
    Hmmm.. What specific version/sub-version of ZC 1.5.7 is installed?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  8. #3328
    Join Date
    Jul 2017
    Location
    United States
    Posts
    10
    Plugin Contributions
    0

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by mc12345678 View Post
    That is the content expected...


    Hmmm.. What specific version/sub-version of ZC 1.5.7 is installed?
    "You are presently using: v1.5.7"

  9. #3329
    Join Date
    Jul 2017
    Location
    United States
    Posts
    10
    Plugin Contributions
    0

    Default Re: EasyPopulate 4.0 Support Thread

    Okay here's how I got it to work:

    In easypopulate_4.php, change:

    Code:
    zen_draw_form('import_form', basename($_SERVER['SCRIPT_NAME']), /*$parameters = */'', 'post', /*$params =*/ '', $request_type == 'SSL')
    to:

    Code:
    zen_draw_form('import_form', FILENAME_EASYPOPULATE_4, /*$parameters = */'', 'post', /*$params =*/ '', $request_type == 'SSL')
    and also do the same with the forms "delete_form" and "split_form"

    Changing
    Code:
    basename($_SERVER['SCRIPT_NAME'])
    to
    Code:
    basename($_SERVER['SCRIPT_NAME'], '.php')
    also works.
    Last edited by Reviresco; 10 Aug 2021 at 07:32 PM.

  10. #3330
    Join Date
    Jul 2012
    Posts
    16,488
    Plugin Contributions
    17

    Default Re: EasyPopulate 4.0 Support Thread

    Quote Originally Posted by mc12345678 View Post
    That is the content expected...


    Hmmm.. What specific version/sub-version of ZC 1.5.7 is installed?
    Also, is the file: admin/includes/extra_datafiles/easypopulate_4_filenames.php
    having the content:
    Code:
    <?php
    // $Id: easypopulate_filenames.php, v4.0.35.ZC.2 10-03-2016 mc12345678 $
    define('FILENAME_EASYPOPULATE_4', 'easypopulate_4');
    Loaded to the server?
    (I'm not where I can test system response without that file, so this is a little bit of a possible reason or as otherwise known: a guess. :))
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

 

 

Similar Threads

  1. Hebrew Support - latest release [Support Thread]
    By eranariel in forum Addon Language Packs
    Replies: 19
    Last Post: 23 Jan 2023, 08:04 AM
  2. BackUp ZC [Support Thread]
    By skipwater in forum All Other Contributions/Addons
    Replies: 285
    Last Post: 23 Dec 2020, 10:40 AM
  3. Wordpress On ZC [Support Thread]
    By hira in forum All Other Contributions/Addons
    Replies: 1858
    Last Post: 17 Jan 2014, 01:24 AM
  4. ZJ Black 2 support thread
    By Liamv in forum Addon Templates
    Replies: 1
    Last Post: 15 Feb 2010, 02:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR