Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    Join Date
    Mar 2012
    Posts
    5
    Plugin Contributions
    0

    database error PayPal Website Payments Pro still asking for SSL...

    I have read what I think is all the info on this topic on this forum, but my problem has not been solved by any of it...

    Basically, I'm trying to install the PayPal Website Payments Pro Module, but I am unable to get past the point where it keeps giving me this message: "ALERT: For security reasons, Installation of this module is disabled until your Admin is configured for SSL."

    Using Zen-Cart Version: 1.5.0
    Installed manually and looking/working fine (x-cept this)

    Here is what I've done:

    1) SSL Is working on my site... check it out: https://www.the-computer-tutor.info

    2) I renamed the "admin" folder to [something else] (I don't want to say publicly, but I followed all instructions exactly)

    2) Here is a clip from the following files:

    FROM "{my admin folder}/includes/configure.php"
    Code:
    /**
     * WE RECOMMEND THAT YOU USE SSL PROTECTION FOR YOUR ENTIRE ADMIN:
     * To do that, make sure you use a "https:" URL for BOTH the HTTP_SERVER and HTTPS_SERVER entries:
     */
      define('HTTP_SERVER', 'https://www.the-computer-tutor.info');
      define('HTTPS_SERVER', 'https://www.the-computer-tutor.info');
      define('HTTP_CATALOG_SERVER', 'https://www.the-computer-tutor.info');
      define('HTTPS_CATALOG_SERVER', 'https://www.the-computer-tutor.info');
    
      // secure webserver for admin?  Valid choices are 'true' or 'false' (including quotes).
      define('ENABLE_SSL_ADMIN', 'true');
    
      // secure webserver for storefront?  Valid choices are 'true' or 'false' (including quotes).
      define('ENABLE_SSL_CATALOG', 'true');
    FROM "includes/configure.php"
    Code:
    // Define the webserver and path parameters
      // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com
      // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com
      define('HTTP_SERVER', 'https://www.the-computer-tutor.info');
      define('HTTPS_SERVER', 'https://www.the-computer-tutor.info');
    
      // Use secure webserver for checkout procedure?
      define('ENABLE_SSL', 'true');

    I am at wits end! I have been trying different options for 3 hours now! As you can see above, I even changed all of the URLs to be "https" instead of just "http" for some... at this point I have NO IDEA, why I can't install PayPal WPP...

    PLEASE HELP.

    -Josh

    PS.

    a) Express Checkout is enabled
    b) My PayPal Account is working fine- Pro Account
    c) Permissions on both configure.php files are set to 777, but I have set to "read-only" too... still won't let me install PPWPP!
    d) SSL is "active" on hosting account (as you can see above)

    PLEASE HELP!

  2. #2
    Join Date
    Jan 2004
    Posts
    66,356
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: PayPal Website Payments Pro still asking for SSL...

    Sounds like the changes to your admin-side configure.php file did NOT actually save to the server.

    Remember, anytime you edit your configure.php files, you need to first make them writable, then upload your changes, and then make them read-only again.
    As long as they're read-only, any changes you make won't save.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Mar 2012
    Posts
    5
    Plugin Contributions
    0

    Default Re: PayPal Website Payments Pro still asking for SSL...

    I did this. I logged in, then changed the permissions to "777". Then, I made the mods... saved the file. Then I changed the permissions back to "read-only"...

    Is there any setting in the control panel that I may be missing? Perhaps anything to do with the fact that my domain is .info instead of .net or .com?

  4. #4
    Join Date
    Jan 2004
    Posts
    66,356
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: PayPal Website Payments Pro still asking for SSL...

    The payment module will ONLY trigger the "this module is disabled until your Admin is configured for SSL" message when the HTTP_SERVER and HTTPS_SERVER do not contain an https address and ENABLE_SSL_ADMIN is not set to 'true'.

    It has nothing to do with the NON-ADMIN version of configure.php (so put the HTTP_SERVER for that file back to an http:// address)
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Mar 2012
    Posts
    5
    Plugin Contributions
    0

    Default Re: PayPal Website Payments Pro still asking for SSL...

    Nothing seems to be working... I know that the changes are saving because I get a confirmed message and I look at the last edited column and it indicates time/date of when I saved it. Are there any more possibilities of why this module is not letting me install?

  6. #6
    Join Date
    Mar 2012
    Posts
    5
    Plugin Contributions
    0

    Default Re: PayPal Website Payments Pro still asking for SSL...

    Here's some ideas that I came up with that may be the source of the problem:

    1) Do the hyphens in my domain name cause a problem? (I saw something that replaces "-" with another character)
    2) Does the "//" in the domain name create a problem? (I know that "//" is for comments in php)
    3) Are the items ENABLE_SSL_ADMIN and ENABLE_SSL_CATALOG mentioned anywhere else? (can't find them anywhere else)
    4) Did I accidentally change a setting in the admin panel? (I seem to remember something in the admin panel about SSL)


    I really really really NEED to get past this. Thanks anyone for any help you can offer...

  7. #7
    Join Date
    Mar 2012
    Posts
    5
    Plugin Contributions
    0

    Default Re: PayPal Website Payments Pro still asking for SSL...

    OK, sorry to keep posting...

    I figured out what the problem was. It had to do with my hosting account. There is an app called "Fix Cache Key" that could help diagnose if your host is using cached version of your site rather than the updated/changed version.

    When diagnosing these types of problems, just remember to check with your hosting company too...

  8. #8
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,167
    Plugin Contributions
    7

    Default Re: PayPal Website Payments Pro still asking for SSL...

    Quote Originally Posted by easyjtm View Post
    When diagnosing these types of problems, just remember to check with your hosting company too...
    Good advice :)

    Also, in response to your questions..

    Quote Originally Posted by easyjtm View Post
    1) Do the hyphens in my domain name cause a problem? (I saw something that replaces "-" with another character)
    If it does, then something is wrong with the script. This would/should almost never happen.

    Quote Originally Posted by easyjtm View Post
    2) Does the "//" in the domain name create a problem? (I know that "//" is for comments in php)
    Domain names will never contain these characters..
    From wikipedia:
    DNS names may technically consist of any character representable in an octet. However, the allowed formulation of domain names in the DNS root zone, and most other sub domains, uses a preferred format and character set. The characters allowed in a label are a subset of the ASCII character set, and includes the characters a through z, A through Z, digits 0 through 9, and the hyphen. This rule is known as the LDH rule (letters, digits, hyphen). Domain names are interpreted in case-independent manner.[11] Labels may not start or end with a hyphen.[12]

    Quote Originally Posted by easyjtm View Post
    3) Are the items ENABLE_SSL_ADMIN and ENABLE_SSL_CATALOG mentioned anywhere else? (can't find them anywhere else)
    "Anywhere else" assumes that we know which reference you are currently referring too.
    Things in all UPPERCASE are known as 'Constants", and the easiest way to find where they are used is to use Zencarts Developers Toolkit (located in the "Tools" menu)
    Quote Originally Posted by easyjtm View Post
    4) Did I accidentally change a setting in the admin panel?
    If a tree falls in the forest and no-one is there to witness it, did it really fall? We cannot know what you may have done by accident, we weren't there to see it

    Cheers
    Rod

  9. #9
    Join Date
    Mar 2012
    Posts
    4
    Plugin Contributions
    0

    Default Re: PayPal Website Payments Pro still asking for SSL...

    I am actually having the same problem, I have triple checked both files and all the settings are correct to the settings , I am not showing anything out of the ordinary, the ssl is working perfectly fine with the website. but I am also getting the same error and it will not change... any help would be greatly be helpful

  10. #10
    Join Date
    Jan 2004
    Posts
    66,356
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: PayPal Website Payments Pro still asking for SSL...

    The ONLY control Zen Cart looks at for it is that the HTTP_SERVER and ENABLE_SSL_ADMIN are properly set.
    So, that tells me that your admin configure.php file ON THE SERVER hasn't been set properly for the situation you seek.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. v151 PayPal Website Payments Pro still asking for SSL
    By rmu065 in forum PayPal Website Payments Pro support
    Replies: 3
    Last Post: 14 Apr 2013, 06:55 PM
  2. Have PayPal Website Payments Pro - Still getting customer CC info!
    By dejap in forum PayPal Website Payments Pro support
    Replies: 5
    Last Post: 29 Oct 2009, 08:33 PM
  3. PayPal Website Payments Pro for Zen Cart
    By innovita in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 27 Apr 2007, 06:52 PM
  4. PayPal Website Payments Pro support for the UK
    By distanceDemon in forum Addon Payment Modules
    Replies: 2
    Last Post: 18 Jan 2007, 02:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR