Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28
  1. #21
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,302
    Plugin Contributions
    18

    Default Re: errors in admin from ultimate seo urls

    and back to this - this time I installed on a new version of 1.5 that did not already have the Ultimate SEO urls installed. The auto install just doesn't run at all. I've looked at the code and I definitely am out of my depth here. I'm going to PM the fellow who uploaded the 1.5 version and see if he's able to fix this.

  2. #22
    Join Date
    Jan 2006
    Posts
    1,632
    Plugin Contributions
    0

    Default Re: errors in admin from ultimate seo urls

    This is probably my fourth fresh 1.5.0 demo install with Ultimate SEO and it works:

    http://www.prom-mart.com/demo-1/

    I have not tried with an upgraded cart.

    But I'll defer to your experience and greater zencart knowledge that there is an issue with this mod.

  3. #23
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,302
    Plugin Contributions
    18

    Default Re: errors in admin from ultimate seo urls

    Quote Originally Posted by SPH View Post
    This is probably my fourth fresh 1.5.0 demo install with Ultimate SEO and it works:

    http://www.prom-mart.com/demo-1/

    I have not tried with an upgraded cart.

    But I'll defer to your experience and greater zencart knowledge that there is an issue with this mod.
    hmm, you are saying it auto installed on a 1.5 cart and shows up in admin like it supposed to?

  4. #24
    Join Date
    Jan 2006
    Posts
    1,632
    Plugin Contributions
    0

    Default Re: errors in admin from ultimate seo urls

    Yes, 3 or 4 times now, fresh 1.5.0 installs. Is in the Admin.

    First time didn't think it worked. Was looking for it in admin, couldn't find it. Before closing browsers thinking it a failure I noticed that on actual site the urls were rewritten. Went back in to admin and it was there. So I think have to click around on the site to get it going: I guess that's the auto install?

    One of my demo sites blew-up, but I cannot blame that on Ultimate SEO URL. In fact, that was the only thing working after the blow-up.

    Ultimate SEO URL works good enough...in my recent, limited experience...to tempt me to use it when I upgrade main site to 1.5 in a couple of months (actually, that will also likely be a fresh install.) But I understand that it's probably safer to just use default dynamic urls.

    My usual order of mods on 1.5.0 demos:

    1. Dr Byte's DB plugin
    2. Some free Template
    3. Ultimate SEO URL
    Last edited by SPH; 22 Apr 2012 at 12:31 AM.

  5. #25
    Join Date
    Jan 2006
    Posts
    1,632
    Plugin Contributions
    0

    Default Re: errors in admin from ultimate seo urls

    Screen shot of Ultimate SEO in admin, 1.5.0 fresh install:

    http://www.prom-mart.com/demo-1/imag...eoadminpic.jpg

  6. #26
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,302
    Plugin Contributions
    18

    Default Re: errors in admin from ultimate seo urls

    Well, I'm totally confused myself. When I installed it, it was automatically turned on and didn't work. I never saw it appear in admin and so uploaded the original html_output.php file so that I could work on the site. I looked at the install file and saw no way the appropriate stuff was going to be inserted.

    So today I went back in and looked at admin and lo and behold, it's installed. Uploaded the correct html_output.php file and all is fine. I went back to the seo_install.php file and this time found the line to install it for 1.5.

    So I don't know why it didn't show up in admin before - something about sessions? Just don't know but looks like the mod is okay for 1.5.

    Now I thought it didn't install correctly on 1.3.9h. There is no ignore statement in his sql for the line that inserts into admin pages and so thought the install file probably doesn't run completely. The readme directions do say for upgrade "No additional steps. Automatic Update. Contrib config will be reset." I don't see that to be true but now I"m thinking that the forced upgrade I tried was not what worked after all. Looking at that sql statement now, I don't think it would work!

    So based on this, I'm going to post in the original Ultimate seo thread and continue the discussion there: http://www.zen-cart.com/showthread.p...O-URLs/page100

  7. #27
    Join Date
    Jan 2006
    Posts
    1,632
    Plugin Contributions
    0

    Default Re: errors in admin from ultimate seo urls

    Okay, finally had a problem with Ultimate SEO URL disappearing from admin following an upgrade.

    Works flawlessly for me on fresh 1.5 test installs. But just upgraded a third-level site which we hope to turn in to a major site, 1.3.9h to 1.5, fresh 1.5 install with only DB import and upgrade:

    http://www.promdressesglobal.com/

    After several tries, I decided to do a fresh 1.5 install and then Ultimate SEO URL first thing. Worked perfect as expected. Then did DB import and upgrade and Ultimate SEO URL disappeared from admin, although was still re-writing on site.

    Fix in post # 16 above did not work for me.

    Took a good day to get it back into the admin. I THINK it was when I finally went in to the DB and deleted Ultimate SEO entries from admin_pages, configuration and configuration_group. Then it seemed to auto-install again properly.

    Have couple of other second level 1.3.9h carts I'll experiment again with on an upgrade to confirm how I got it working.

  8. #28
    Join Date
    Jan 2006
    Posts
    1,632
    Plugin Contributions
    0

    Default Re: errors in admin from ultimate seo urls

    Clarification: Our site above never had Ultimate SEO URLs before. It actually is coming off of Simple SEO. Ultimate's disappearance from the admin so far happened with every DB upgrade attempt.

    Hmmm...now I'm not sure if I tried upgrading DB then installing Ultimate SEO, but pretty sure I did with same disappearing act. Have to re-test on my other 1.3.9h carts (one Simple SEO URL, other dynamic urls), as I'm thinking of going with Ultimate despite controversy and doubt over wether these url's are necessary.
    Last edited by SPH; 4 May 2012 at 07:57 PM.

 

 
Page 3 of 3 FirstFirst 123

Similar Threads

  1. 1.3.8 Multilingual URLs with Ultimate SEO URLs?
    By vko82 in forum All Other Contributions/Addons
    Replies: 0
    Last Post: 29 Aug 2011, 01:07 PM
  2. Ultimate SEO URLs is messing with my admin URLs
    By Chrome Orange in forum All Other Contributions/Addons
    Replies: 0
    Last Post: 21 Jul 2009, 01:13 PM
  3. Ultimate SEO URLs errors.
    By waterlin in forum All Other Contributions/Addons
    Replies: 2
    Last Post: 16 Jul 2009, 03:55 PM
  4. Shortening URLS on Ultimate URLS
    By gutenburg in forum All Other Contributions/Addons
    Replies: 12
    Last Post: 6 Jul 2006, 02:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •