Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2012
    Posts
    3
    Plugin Contributions
    0

    Default Install error on WAMP while installing

    This is my first attempt at installing zencart. I am running the latest wamp and php releases on a Win Vista OS. I am following the ZenCart manual explicitly and still got the install error.

    I have listed below my zcInstallDEBUG-1334263952-165633.log file. I have no idea how to interpret what my problem is.. Thank you for helping.


    [12-Apr-2012 20:52:33 UTC] PHP Fatal error: 1101:BLOB/TEXT column 'page_parameters' can't have a default value :: CREATE TABLE admin_activity_log ( log_id bigint(15) NOT NULL auto_increment, access_date datetime NOT NULL default '0001-01-01 00:00:00', admin_id int(11) NOT NULL default '0', page_accessed varchar(80) NOT NULL default '', page_parameters text default '', ip_address varchar(20) NOT NULL default '', flagged tinyint NOT NULL default '0', attention varchar(255) NOT NULL default '', gzpost mediumblob NOT NULL default '', PRIMARY KEY (log_id), KEY idx_page_accessed_zen (page_accessed), KEY idx_access_date_zen (access_date), KEY idx_flagged_zen (flagged), KEY idx_ip_zen (ip_address) ) ENGINE=MyISAM COLLATE utf8_general_ci; in C:\wamp\www\store\zen-cart-v150-full-release-12302011\includes\classes\db\mysql\query_factory.php on line 101

    [12-Apr-2012 20:52:33 UTC] PHP Stack trace:

    [12-Apr-2012 20:52:33 UTC] PHP 1. {main}() C:\wamp\www\store\zen-cart-v150-full-release-12302011\zc_install\index.php:0

    [12-Apr-2012 20:52:33 UTC] PHP 2. require() C:\wamp\www\store\zen-cart-v150-full-release-12302011\zc_install\index.php:51

    [12-Apr-2012 20:52:33 UTC] PHP 3. installer->dbLoadProcedure() C:\wamp\www\store\zen-cart-v150-full-release-12302011\zc_install\includes\modules\pages\database_setup\header_php.php:51

    [12-Apr-2012 20:52:33 UTC] PHP 4. executeSql() C:\wamp\www\store\zen-cart-v150-full-release-12302011\zc_install\includes\classes\installer.php:521

    [12-Apr-2012 20:52:33 UTC] PHP 5. queryFactory->Execute() C:\wamp\www\store\zen-cart-v150-full-release-12302011\zc_install\includes\functions\general.php:344

    [12-Apr-2012 20:52:33 UTC] PHP 6. queryFactory->set_error() C:\wamp\www\store\zen-cart-v150-full-release-12302011\includes\classes\db\mysql\query_factory.php:208

    [12-Apr-2012 20:52:33 UTC] PHP 7. queryFactory->show_error() C:\wamp\www\store\zen-cart-v150-full-release-12302011\includes\classes\db\mysql\query_factory.php:86

    [12-Apr-2012 20:52:33 UTC] PHP 8. trigger_error() C:\wamp\www\store\zen-cart-v150-full-release-12302011\includes\classes\db\mysql\query_factory.php:101

  2. #2
    Join Date
    Apr 2012
    Posts
    3
    Plugin Contributions
    0

    Default Re: Install error on WAMP while installing Zen cart

    I forgot to mention that I get this error right after the database config screen:

    Installation In Progress...

    ~
    WARNING: An Error occurred, please refresh the page and try again.

  3. #3
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,565
    Plugin Contributions
    2

    Default Re: Install error on WAMP while installing

    Quote Originally Posted by Brian Schmit View Post
    I have listed below my zcInstallDEBUG-1334263952-165633.log file. I have no idea how to interpret what my problem is.. Thank you for helping.
    This is apparently a known issue with some WAMP installations.

    The following link provides a fix.

    http://www.zen-cart.com/forum/showpo...6&postcount=17

    Cheers
    Rod

  4. #4
    Join Date
    Apr 2012
    Posts
    3
    Plugin Contributions
    0

    Default Re: Install error on WAMP while installing

    I changed that line to page_parameters text NOT NULL, but i still get an error

    Is there anyone who actually got this to install on WAMP? I have had some people tell me its not compatible.

  5. #5
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,565
    Plugin Contributions
    2

    Default Re: Install error on WAMP while installing

    Quote Originally Posted by Brian Schmit View Post
    I changed that line to page_parameters text NOT NULL, but i still get an error
    Same error or different error?
    Quote Originally Posted by Brian Schmit View Post
    Is there anyone who actually got this to install on WAMP?
    Yes, many people.
    Quote Originally Posted by Brian Schmit View Post
    I have had some people tell me its not compatible.
    You win. For an easy life I think I'll believe them too . it won't work, so nothing more I can say.

    Cheers
    Rod

 

 

Similar Threads

  1. installing Zencart on WAMP
    By ravalde in forum General Questions
    Replies: 1
    Last Post: 5 Sep 2010, 02:09 PM
  2. How install template on wamp?
    By webdesigncut in forum Installing on a Windows Server
    Replies: 3
    Last Post: 9 Aug 2010, 02:08 AM
  3. installing locally - blank screen on wamp server
    By tallberg in forum Installing on a Windows Server
    Replies: 4
    Last Post: 28 Jul 2010, 08:13 PM
  4. Installing on local and cannot access phpmyadmin on wamp
    By RenoB in forum Installing on a Windows Server
    Replies: 1
    Last Post: 11 Mar 2010, 11:31 AM
  5. error while installing zen-cart 1.3.7 in wamp
    By srinivasan.rr in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 31 Jan 2007, 04:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •