Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    Default Re: upgrading 1.3.9 to 1.5

    OK I've gone ahead and created a whole new site in a separate folder. Can I now replace /english files from my old site, or should I edit the new files step by step? What about /images /downloads and /my_template files? Thanks

  2. #12
    Join Date
    Jan 2004
    Posts
    59,773
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: upgrading 1.3.9 to 1.5

    As far as the /images/ and /download/ folders, those don't change (other than maybe the .htaccess files, which should be compared).

    But for EVERYTHING else:
    The old versions of those files are not necessarily compatible with the new. That's why the upgrade instructions direct you to compare them, and use the comparison results to see what changes to apply to the new versions.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #13
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    Default Re: upgrading 1.3.9 to 1.5

    OK I'm afraid I got a bit confused when I installed the new version and put it in all in a file under public_html and now I see the upgrade instructions recommended a new database, but I have created 4 MSql databases now, all with 0 bytes info in them and I don't know how to access them. As I am extremely ignorant and of limited abilities, and my store is new and relatively unused, is it possible to safely replace the public_html file with my new version (a subfile at this point), once it has been completely adapted to all my products and layout? Also, I have not been able to access admin for my new site, so I can't switch my overides on or make any other changes via admin, so I am flying blind as to adapting the new version to my layout. Thanks, and I apologize for my ineptness, Lowell

  4. #14
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    database error Re: upgrading 1.3.9 to 1.5

    Well, I never got a response on my previous post,(I know you're busy) so I slugged away with WinMerge until I felt confident that everything was ready, then I backed up the subfolder my previous install was running from and deleted it. Didn't work. On top of everything, my host has problems whenever I move things around and the server is "not found". What I tried to do is what I found on the following forum topic:

    Moving your site to another folder on your server
    1.Determine the new foldername where your Zen CartŪ files will be running from


    2.Go into Admin > Configuration > Sessions and change the Session Directory to reflect the new folder name. If you cannot do this, see the alternate approach in step 5 below.


    3.Move/Rename the folder. You may need to use your FTP program to do this.


    4.Your /includes/configure.php and /admin/includes/configure.php files are used to point Zen CartŪ to the right folders. In those files, you need to update several entries to match the new path information:
    •DIR_WS_CATALOG
    •DIR_WS_HTTPS_CATALOG
    •DIR_FS_CATALOG
    •DIR_FS_SQL_CACHE
    •DIR_WS_ADMIN (in admin)
    •DIR_WS_HTTPS_ADMIN (in admin)
    •DIR_FS_ADMIN (in admin)


    Note that the configure.php files are normally "read-only". You'll need to change their permissions to "writable" before you can upload your changes. Be sure to note level the permissions were at before changing, so that you can put them back to the read-only permissions again after updating.


    5.If you could not set the Session Write Directory in step 1 above, you can use a utility to do it for you. The goal is to make sure that the new path information (specifically the DIR_FS_SQL_CACHE setting in your new configure.php file) matches the Session Write Directory setting. If it doesn't, you may end up with difficulties logging in to the Admin area or maintaining login sessions in the store. The Fix Cache Key Utility from the Downloads > Troubleshooting Tools area on the main Zen CartŪ site will help you to do this if you need assistance. There is no harm running it to have it check that things are set properly. Be sure to delete the file from your server when done.
    I highly suspect that I did it all wrong, but I'm pretty sure this is where my main problems lie. I'm hoping the FIx Cache Key will eventually work, but right now the "server for www.artbylowell.com is not found."

    I would really appreciate any advice you can give. Thank you.

  5. #15
    Join Date
    Jan 2004
    Posts
    59,773
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: upgrading 1.3.9 to 1.5

    Quote Originally Posted by Lowell37 View Post
    my host has problems whenever I move things around and the server is "not found".

    ...

    right now the "server for www.artbylowell.com is not found.
    That's the first thing you need to sort out, and only your hosting company can accurately help you there.
    It does seem very odd.

    Hopefully you're not actually moving the "public_html" folder itself around. That would be very bad. You should only touch stuff "in" or "under" it, not that folder itself or any of its peers in the same folder where you see the public_html folder's name listed along with others.

    But, again, your hosting company is where you need to turn to sort out the "is not found" situation.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Admin when UPgrading
    By ideasgirl in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 2 Feb 2011, 08:16 AM
  2. Question about upgrading and installin security patches
    By SyberTemplates in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 28 Oct 2010, 12:53 PM
  3. certain customers not able to view cart after upgrading
    By volks65 in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 7 May 2010, 06:10 PM
  4. Replies: 3
    Last Post: 19 Jun 2008, 12:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •