Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2012
    Posts
    9
    Plugin Contributions
    0

    Default Fresh install on Ubuntu w/LAMP having cURL setup issues

    I'm trying to get a new box up so I can move my site off of my "wonderful" host. I installed Ubuntu w/LAMP and install PHP cURL packages, restart apache, but I still have no instances of curl in php.ini or a dll for cURL.

    Am I missing a step before all of this?

    Thanks

  2. #2
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,575
    Plugin Contributions
    2

    Default Re: Fresh install on Ubuntu w/LAMP having cURL setup issues

    "restart apache, but I still have no instances of curl in php.ini or a dll for cURL."

    I'm not sure what you are expecting to find. php.ini is a configuration file. You won't find anything about cURL in there.
    DLL's are Windows Library files. You won't find those on a *nix system.

    Perhaps it would help if you explained what your actual problem is?

    Cheers
    Rod

  3. #3
    Join Date
    Jan 2012
    Posts
    9
    Plugin Contributions
    0

    Default Re: Fresh install on Ubuntu w/LAMP having cURL setup issues

    Trying to do the install from a browser and getting: CURL not compiled into PHP - notify server administrator

    Searching the web, users are saying to install the PHP curl packages, restart apache and check your php.ini to see if the extension is now available. I can't help if other people commented with incorrect files names, that is part of the fun of using the web to fix your issues.

  4. #4
    Join Date
    Jan 2012
    Posts
    9
    Plugin Contributions
    0

    Default Re: Fresh install on Ubuntu w/LAMP having cURL setup issues

    Looks like I am in better shape. Was doing a search on some others errors related to php and ran:
    apt-get install php5 libapache2-mod-php5
    apt-get install php5-cgi
    apt-get install php5-gd

    That took care of the cURL errors as well as GD support

  5. #5
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,575
    Plugin Contributions
    2

    Default Re: Fresh install on Ubuntu w/LAMP having cURL setup issues

    Quote Originally Posted by mooseracing View Post
    Searching the web, users are saying to install the PHP curl packages, restart apache and check your php.ini to see if the extension is now available. I can't help if other people commented with incorrect files names, that is part of the fun of using the web to fix your issues.
    I understand that you have solved your problem, and that this probably doesn't need a reply or comment. Nonetherless, in an effort to make your 'fun' continue to be fun (and not an experience in total frustration), I wish to share the following advice:

    1. When seeking solutions to a problem, always try to ensure that the solutions presented pertain to your particular operating system. Your reference to 'dll' files alerted me to the fact that you were probably looking for a solution in all the wrong places.

    2. When using websites for a solution, try to ensure that the solutions are reasonably current. Your reference to looking at your php.ini for a cURL inclusion, in conjuction with your operating system, suggested that you were looking at information that was somewhat dated, because Ubuntu has been placing this configuration setting in an 'include file' (rather than php.ini) for as long as I can remember (possibly forever, in which case refer back to point#1)

    FWI, now that you do have it working, if you take a look in /etc/php5/conf.d/ you'll see where/how ubuntu handles the various extension settings (including curl, dg, mysql, and many others) rather than adding them into the php.ini file.

    Finally, the reason why I asked what the problem was that you were trying to solve (rather than trying to guess at other possible solutions) was because in my experience, ubuntu users generally don't have any issues or problems with installing cURL because it is a 'standard' part of the LAMP installation. Where they *do* have cURL related issues is usually nothing to do with the installation itself, but moreso with them having a problem actually getting it to function, especially when installed on thier localhost.. and I was suspecting that this was the *real* problem that you were having. I wasn't trying to be difficult or giving you a hard time. I simply didn't wish to give you bad or unrelated advice without a little more info. :)

    As you've now got it all sorted, this has become a moot point.

    Cheers
    Rod

 

 

Similar Threads

  1. Curl error during 1.3.9 install. we have curl installed tho
    By bangsters in forum General Questions
    Replies: 1
    Last Post: 16 May 2010, 08:55 AM
  2. Can I setup on ubuntu (local)?
    By raunharman in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 9 Feb 2010, 12:45 PM
  3. 3 layout issues in a fresh install.
    By OnePinkFrog in forum Templates, Stylesheets, Page Layout
    Replies: 4
    Last Post: 16 Oct 2009, 11:10 PM
  4. Admin login issues - fresh install - dreamhost
    By gyo in forum Basic Configuration
    Replies: 5
    Last Post: 4 Aug 2007, 06:25 AM
  5. Ubuntu Dapper Install howto
    By brightidea in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 21 Aug 2006, 08:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •