Thread: Zen Colorbox

Page 4 of 33 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 327
  1. #31
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: Zen Colorbox

    Quote Originally Posted by DivaVocals View Post
    So I am back with more issue regarding product images and product reviews.. I think the issue I reported previously regarding the images and reviews may not be related to TPP at all.. I think the issues with having reviews on the tabs in TPP is caused because of an overall issue with how Colorbox (and Zen Lightbox) display/deal with reviews and product images together in general.

    I reported this new find in the Zen Lightbox thread, but I'm reporting here too since I am seeing the SAME issue with both Colorbox and Zen Lightbox.

    Not sure why, but the Lightbox and Colorbox add-ons are generating some weird/invalid HTML on the product reviews pages. You will see the model number appear in what appears to be some weird link to the left of the product image. Using Zen Lightbox, you can see what I am speaking of on this page:
    http://clientlaserdiscvault(dot)overthehillweb(dot)com/index.php?main_page=product_reviews&products_id=8909


    I found the EXACT same issue with the beta version of the Colorbox add-on as well. You can see the same issue using the Colorbox add-on on this page:
    http://clienthairisle(dot)overthehillweb(dot)com/Hair-Extensions/Economy-Collection/Economy-Unprocessed/Indian-Remy-Micro-Thin-Machine-Weft-Virgin-Curly-Texture-3-Oz/reviews?number_of_uploads=0&

    This weird link goes away when I turn off Lightbox or Colorbox.

    Without Lightbox turned on this is the HTML created:
    Code:
    <div id="productReviewsDefaultProductImage" class="centeredContent back">  
    <div id="productMainImage" class="centeredContent back"> 
    <script language="javascript" type="text/javascript">
    <!-- document.write('<a href="javascript:popupWindow(\'http://myclient.com/index.php?main_page=popup_image&amp;pID=8909\')"><img  src="images/dasPic_24141.jpg" alt="National Geographic - Secrets of the  Titanic [G52000]" title=" National Geographic - Secrets of the Titanic  [G52000] " width="349" height="350" />
    <br /><span class="imgLink">larger image</span></a>'); //-->
    </script> 
    <noscript> 
    <a  href="http://myclient.com/index.php?main_page=popup_image&amp;pID=8909"  target="_blank"><img src="images/dasPic_24141.jpg" alt="National  Geographic - Secrets of the Titanic [G52000]" title=" National  Geographic - Secrets of the Titanic [G52000] " width="349" height="350"  /><br /><span class="imgLink">larger  image</span></a>
    </noscript> 
    </div></div>
    With Lightbox turned off this is the HTML created (note the mis-behaving HTML created is in red):
    Code:
    <div id="productReviewsDefaultProductImage" class="centeredContent back">  
    <div id="productMainImage" class="centeredContent back"> 
    <script language="javascript" type="text/javascript">
    <!-- document.write('<a href="images/dasPic_24141.jpg"  rel="lightbox-g" title="National Geographic - Secrets of the  Titanic<br /><span  class=\"smallText\">[G52000]</span>"><img  src="images/dasPic_24141.jpg" alt="National Geographic - Secrets of the  Titanic [G52000]" title=" National Geographic - Secrets of the Titanic  [G52000] " width="349" height="350" /><br /><span  class="imgLink">larger image</span></a>'); //-->
    </script>
    <a href="images/dasPic_24141.jpg" rel="lightbox-g" title="National Geographic - Secrets of the Titanic&lt;br /&gt;&lt;span class=" smalltext"="">[G52000]"&gt;<img src="images/dasPic_24141.jpg" alt="National Geographic - Secrets of the Titanic [G52000]" title=" National Geographic - Secrets of the Titanic [G52000] " height="350" width="349"><br><span class="imgLink">larger image</span></a> 
    <noscript> 
    <a  href="http://myclient.com/index.php?main_page=popup_image&amp;pID=8909"  target="_blank"><img src="images/dasPic_24141.jpg" alt="National  Geographic - Secrets of the Titanic [G52000]" title=" National  Geographic - Secrets of the Titanic [G52000] " width="349" height="350"  /><br /><span class="imgLink">larger  image</span></a>
    </noscript> 
    </div></div>
    Using either Colorbox or Zen Lightbox, the issue goes away when I turn off these add-ons. It seems clear that there is something with how both of these add-ons deal with product images and reviews that goes awry.

    Any thoughts??
    Found a better solution to this issue..

    Issue:
    If you have both Tabbed Products Pro, and Colorbox installed AND your products have model numbers defined, the problem outlined above will manifest itself.

    To fix this in the includes/modules/pages/product_reviews/header_php.php file replace this:
    Code:
      if (zen_not_null($review->fields['products_model'])) {
        $products_name = $review->fields['products_name'] . '<br /><span class="smallText">[' . $review->fields['products_model'] . ']</span>';
      } else {
        $products_name = $review->fields['products_name'];
      }
    with this:
    Code:
    if (TPP_GLOBAL_ENABLE_TABS == '1') {  
      if (zen_not_null($review->fields['products_model'])) {
        $products_name = $review->fields['products_name'];
      }
    
      } else {
      if (zen_not_null($review->fields['products_model'])) {
        $products_name = $review->fields['products_name'] . '<br /><span class="smallText">[' . $review->fields['products_model'] . ']</span>';
      } else {
        $products_name = $review->fields['products_name'];
      }
    }

    What this change does:
    If you have Tabbed Products Pro and Zen Colorbox installed, the model number field will NOT display on the product reviews page.

    I realize this is pretty much a bandaid solution, but coming up with a solution that allows the product model field to display when both TPP and Zen Colorbox are installed and active is over my paygrade to execute. I don't know if the issue is in the TPP code, or the Zen Colorbox code or if a change needs to be made in both. Again, someone smarter than me will need to figure this out. So I am sharing a down and dirty solution that works.
    Last edited by DivaVocals; 25 Aug 2013 at 10:11 AM.
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  2. #32
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: Zen Colorbox

    Quote Originally Posted by DivaVocals View Post
    Found a better solution to this issue..

    Issue:
    If you have both Tabbed Products Pro, and Colorbox installed AND your products have model numbers defined, the problem outlined above will manifest itself.

    To fix this in the includes/modules/pages/product_reviews/header_php.php file replace this:
    Code:
      if (zen_not_null($review->fields['products_model'])) {
        $products_name = $review->fields['products_name'] . '<br /><span class="smallText">[' . $review->fields['products_model'] . ']</span>';
      } else {
        $products_name = $review->fields['products_name'];
      }
    with this:
    Code:
    if (TPP_GLOBAL_ENABLE_TABS == '1') {  
      if (zen_not_null($review->fields['products_model'])) {
        $products_name = $review->fields['products_name'];
      }
    
      } else {
      if (zen_not_null($review->fields['products_model'])) {
        $products_name = $review->fields['products_name'] . '<br /><span class="smallText">[' . $review->fields['products_model'] . ']</span>';
      } else {
        $products_name = $review->fields['products_name'];
      }
    }

    What this change does:
    If you have Tabbed Products Pro and Zen Colorbox installed, the model number field will NOT display on the product reviews page.

    I realize this is pretty much a bandaid solution, but coming up with a solution that allows the product model field to display when both TPP and Zen Colorbox are installed and active is over my paygrade to execute. I don't know if the issue is in the TPP code, or the Zen Colorbox code or if a change needs to be made in both. Again, someone smarter than me will need to figure this out. So I am sharing a down and dirty solution that works.
    Okay.. I think I found it.. The RIGHT answer.. the key to the answer was in the includes/modules/pages/product_reviews_write/header_php.php file..

    The includes/modules/pages/product_reviews/header_php.php file was using different code to display the model number. And this code would display the model number incorrectly when Zen Colorbox (or Zen Lightbox) was installed and active..


    Here's the correct fix:

    in the includes/modules/pages/product_reviews/header_php.php file replace this:
    Code:
      if (zen_not_null($review->fields['products_model'])) {
         $products_name = $review->fields['products_name'] . '<br    /><span class="smallText">[' .    $review->fields['products_model'] . ']</span>';
      } else {
        $products_name = $review->fields['products_name'];
      }
    with this:
    Code:
    $products_name = $review->fields['products_name'];
    
    if ($review->fields['products_model'] != '') {
      $products_model = '<br /><span class="smallText">[' . $review->fields['products_model'] . ']</span>';
    } else {
      $products_model = '';
    }
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  3. #33
    Join Date
    Apr 2013
    Location
    Florida
    Posts
    56
    Plugin Contributions
    0

    Default Re: Zen Colorbox

    Can anyone help? I installed this on one of these new responsive templates but all I can get it to do is open a new window with the main image... Any ideas?

  4. #34
    Join Date
    Apr 2013
    Location
    Florida
    Posts
    56
    Plugin Contributions
    0

    Default Re: Zen Colorbox

    OOPS! Forgot... ZZ 1.5.1, Go Daddy, using Picaflor Azul's Responsive Apparel Boutique template...

    www(dot)rossales(dot)com/rs3

  5. #35
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: Zen Colorbox

    Quote Originally Posted by chowardart View Post
    OOPS! Forgot... ZZ 1.5.1, Go Daddy, using Picaflor Azul's Responsive Apparel Boutique template...

    www(dot)rossales(dot)com/rs3
    You also seem to have forgotten to post in the correct support thread.. this is the support thread for the colorbox add-on not for your template.
    Last edited by DivaVocals; 27 Sep 2013 at 08:56 PM.
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  6. #36
    Join Date
    Apr 2013
    Location
    Florida
    Posts
    56
    Plugin Contributions
    0

    Default Re: Zen Colorbox

    It's Colorbox I'm having the problem with... When I click on any product image it opens a totally new window and... that's it. No slideshow. I have another 1.51 site where the Colorbox is working but I haven't been able to determine why it won't work in this one - all the code seems to be in place...

  7. #37
    Join Date
    Apr 2013
    Location
    Florida
    Posts
    56
    Plugin Contributions
    0

    Default Re: Zen Colorbox

    I have now found a difference using Inspect Element plug in, but don't know how to change it. When I open a product page and inspect the main image, the generated code on the site I'm working one shows the image class as "product_images", but on the site where the ColorBox works it shows as "product_images cboxElement" (that's with a space before cboxElement). Trouble is, I don't know how to fix this...

  8. #38
    Join Date
    Apr 2013
    Location
    Florida
    Posts
    56
    Plugin Contributions
    0

    Default Re: Zen Colorbox

    Found out where to change it (tpl_modules_main_product_image.php), but it didn't help... (Darn!)... Back to the drawing board...

  9. #39
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: Zen Colorbox

    Quote Originally Posted by chowardart View Post
    Found out where to change it (tpl_modules_main_product_image.php), but it didn't help... (Darn!)... Back to the drawing board...
    If you downloaded the colorbox add on from the free download section I'm afraid that I still can't help you here. This is a support thread for a color box module that was being beta tested but has not been released.
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  10. #40
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: Zen Colorbox

    Quote Originally Posted by DivaVocals View Post
    If you downloaded the colorbox add on from the free download section I'm afraid that I still can't help you here. This is a support thread for a color box module that was being beta tested but has not been released.
    And yeah one of these days I kind of plan on uploading this to be released.. its not my module but it should be made available to the community..
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

 

 
Page 4 of 33 FirstFirst ... 2345614 ... LastLast

Similar Threads

  1. v155 Attribute image swapped for main image using Colorbox
    By soxophoneplayer in forum Templates, Stylesheets, Page Layout
    Replies: 0
    Last Post: 2 Jun 2016, 02:34 PM
  2. Trying to fix inline code with colorbox...
    By toomanyknots in forum General Questions
    Replies: 2
    Last Post: 5 Apr 2015, 04:26 PM
  3. IH and Zen Colorbox vs Zen Lightbox?
    By Feznizzle in forum All Other Contributions/Addons
    Replies: 7
    Last Post: 28 Jan 2015, 02:29 AM
  4. Lightbox OR Colorbox
    By Rizla in forum All Other Contributions/Addons
    Replies: 3
    Last Post: 2 May 2014, 11:55 AM
  5. LightBox, SlimBox, ColorBox, which one is better?
    By waterbender in forum General Questions
    Replies: 0
    Last Post: 13 Aug 2013, 07:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR