Page 11 of 12 FirstFirst ... 9101112 LastLast
Results 101 to 110 of 116
  1. #101
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,726
    Plugin Contributions
    79

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by rlexyd View Post
    Just wondering if this will work on 1.5.7c on PHP 7.4.21?
    Thank you once again :)
    See the post above yours ... it's on my list, but paying clients come first.

  2. #102
    Join Date
    Nov 2006
    Location
    Sydney, Australia
    Posts
    457
    Plugin Contributions
    1

    Default Re: Reviews - Updated [Support Thread]

    Thanks Cindy, I appreciate where you are coming from :)
    Until you get a chance to update it, for the time being I've commented out the login code in (/includes/modules/pages/product_reviews_write/header.php) as suggest in the link below incase anyone else is wondering.

    https://www.zen-cart.com/showthread....26#post1284826
    *Zen Cart eCommerce Solution - Putting the Dream of Owning an Online Business within reach of anyone!

  3. #103
    Join Date
    Nov 2006
    Location
    Sydney, Australia
    Posts
    457
    Plugin Contributions
    1

    Default Re: Reviews - Updated [Support Thread]

    Ok, I was getting an error log every time someone loaded the product write review page, even if they didn't write a review.
    So I decided to undo the change I did and install this plugin.
    I'm running fresh install of Zen Cart 1.5.7c on PHP 7.4.22 with OPC and IH5 Installed.
    It works, guest can leave reviews and their name appears, thank you.
    I am however getting Error Logs with this
    I know you said this hasn't been updated yet, but is there a way you can help resolve some of these errors in the log if it's not too much trouble, or if anyone else with the skills to help!? (I've added the corresponding php line under each php notice!)
    Thank you in advance.

    Code:
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require_once(/01/includes/languages/english/responsive_classic/product_reviews_write.php) called at [/01/includes/modules/require_languages.php:22]
    #2  require(/01/includes/modules/require_languages.php) called at [/01/includes/modules/pages/product_reviews_write/header_php.php:18]
    #3  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined index: customer_id in /01/includes/languages/english/responsive_classic/product_reviews_write.php on line 13.
    if( $_SESSION['customer_id'] ) {
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined index: customer_id in /01/includes/modules/pages/product_reviews_write/header_php.php on line 42.
        if (!$_SESSION['customer_id']) {
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    --> PHP Notice: Undefined index: customer_id in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 16.
        <?php echo zen_draw_form('product_reviews_write', zen_href_link(FILENAME_PRODUCT_REVIEWS_WRITE, 'action=process&products_id=' . $_GET['products_id'], ($_SESSION['customer_id']) ? 'SSL' : 'NONSSL'), 'post', 'onsubmit="return checkForm(product_reviews_write);"'); ?>
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    --> PHP Notice: Undefined index: customer_id in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 38.
        if ($_SESSION['customer_id']) {
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    --> PHP Notice: Trying to get property 'fields' of non-object in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to get property 'fields' of non-object in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
        <div id="textAreaReviews"><?php echo sprintf(SUB_TITLE_REVIEW, $customer->fields['customers_firstname'], $customer->fields['customers_lastname']); ?></div>
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    --> PHP Notice: Undefined index: customer_id in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 58.
        if (!$_SESSION['customer_id']) {
    *Zen Cart eCommerce Solution - Putting the Dream of Owning an Online Business within reach of anyone!

  4. #104
    Join Date
    Feb 2009
    Location
    UK
    Posts
    938
    Plugin Contributions
    0

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by rlexyd View Post
    Ok, I was getting an error log every time someone loaded the product write review page, even if they didn't write a review.
    So I decided to undo the change I did and install this plugin.
    I'm running fresh install of Zen Cart 1.5.7c on PHP 7.4.22 with OPC and IH5 Installed.
    It works, guest can leave reviews and their name appears, thank you.
    I am however getting Error Logs with this
    I know you said this hasn't been updated yet, but is there a way you can help resolve some of these errors in the log if it's not too much trouble, or if anyone else with the skills to help!? (I've added the corresponding php line under each php notice!)
    Thank you in advance.

    Code:
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require_once(/01/includes/languages/english/responsive_classic/product_reviews_write.php) called at [/01/includes/modules/require_languages.php:22]
    #2  require(/01/includes/modules/require_languages.php) called at [/01/includes/modules/pages/product_reviews_write/header_php.php:18]
    #3  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined index: customer_id in /01/includes/languages/english/responsive_classic/product_reviews_write.php on line 13.
    if( $_SESSION['customer_id'] ) {
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined index: customer_id in /01/includes/modules/pages/product_reviews_write/header_php.php on line 42.
        if (!$_SESSION['customer_id']) {
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    --> PHP Notice: Undefined index: customer_id in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 16.
        <?php echo zen_draw_form('product_reviews_write', zen_href_link(FILENAME_PRODUCT_REVIEWS_WRITE, 'action=process&products_id=' . $_GET['products_id'], ($_SESSION['customer_id']) ? 'SSL' : 'NONSSL'), 'post', 'onsubmit="return checkForm(product_reviews_write);"'); ?>
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    --> PHP Notice: Undefined index: customer_id in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 38.
        if ($_SESSION['customer_id']) {
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    --> PHP Notice: Trying to get property 'fields' of non-object in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to get property 'fields' of non-object in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
        <div id="textAreaReviews"><?php echo sprintf(SUB_TITLE_REVIEW, $customer->fields['customers_firstname'], $customer->fields['customers_lastname']); ?></div>
    
    Request URI: /01/index.php?main_page=product_reviews_write&products_id=47&cPath=1
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    --> PHP Notice: Undefined index: customer_id in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 58.
        if (!$_SESSION['customer_id']) {
    These are only notices, not errors so aren't a problem for the time being.

    I think I'm right in saying: because this plugin was written for ZC v1.5.5 it used the

    Code:
    if($_SESSION['customer_id']) {
    to determine whether or not a user was logged in. More recent versions now use

    Code:
    if(zen_is_logged_in()) {
    I'm not sure how straightforward the fix is but This thread has a suggestion for the customer_id, at least.
    Last edited by simon1066; 23 Aug 2021 at 11:02 AM. Reason: changed ZC version
    Simon

  5. #105
    Join Date
    Nov 2006
    Location
    Sydney, Australia
    Posts
    457
    Plugin Contributions
    1

    Default Re: Reviews - Updated [Support Thread]

    Thank you Simon,

    I replaced these:
    if( $_SESSION['customer_id'] ) {
    if (!$_SESSION['customer_id']) {
    with
    if(zen_is_logged_in()) {

    That stopped the Undefined index: customer_id from appearing in the logs.

    Now these are the remaining error logs generated:

    Error Log generates as a (Guest/Not Logged In) when you click on Write Review (Before Submitting Review):
    Code:
     Request URI: /01/index.php?main_page=product_reviews_write&products_id=16&cPath=1, 
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    
    --> PHP Notice: Trying to get property 'fields' of non-object in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 42.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 42.
    --> PHP Notice: Trying to get property 'fields' of non-object in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 42.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 42.
    
    Line 42: <?php echo SUB_TITLE_FROM . zen_output_string_protected($customer->fields['customers_firstname'] . ' ' . $customer->fields['customers_lastname']) . '</h3>';}?>
    
     Request URI: /01/index.php?main_page=product_reviews_write&products_id=16&cPath=1, 
    #1  require(/01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php) called at [/01/includes/templates/responsive_classic/common/tpl_main_page.php:178]
    #2  require(/01/includes/templates/responsive_classic/common/tpl_main_page.php) called at [/01/index.php:94]
    
    --> PHP Notice: Trying to get property 'fields' of non-object in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to get property 'fields' of non-object in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/templates/responsive_classic/templates/tpl_product_reviews_write_default.php on line 45.
    
    Line 45: <div id="textAreaReviews"><?php echo sprintf(SUB_TITLE_REVIEW, $customer->fields['customers_firstname'], $customer->fields['customers_lastname']); ?></div>
    Error Log generates as a (Guest/Not Logged In) when you click submit the information on the Write Review Page (After Submitting Review):
    Code:
     Request URI: /01/index.php?main_page=product_reviews_write&action=process&products_id=48,
    #1  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined variable: extra_info in /01/includes/modules/pages/product_reviews_write/header_php.php on line 137.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/modules/pages/product_reviews_write/header_php.php on line 137.
    
    Line 137: zen_mail('', SEND_EXTRA_REVIEW_NOTIFICATION_EMAILS_TO, $email_subject, $email_text . $extra_info['TEXT'], STORE_NAME, EMAIL_FROM, $html_msg, 'reviews_extra');
    Error Log generates as a (Logged In Customer) when you click submit the information on the Write Review Page (After Submitting Review):
    Code:
     Request URI: /01/index.php?main_page=product_reviews_write&action=process&products_id=16, 
    #1  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined index: review_name in /01/includes/modules/pages/product_reviews_write/header_php.php on line 57.
    
    Line 57: $review_name = zen_db_prepare_input($_POST['review_name']);
    
     Request URI: /01/index.php?main_page=product_reviews_write&action=process&products_id=16, 
    #1  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined variable: name in /01/includes/modules/pages/product_reviews_write/header_php.php on line 133.
    --> PHP Notice: Undefined variable: email_address in /01/includes/modules/pages/product_reviews_write/header_php.php on line 133.
    
    Line 133: $extra_info=email_collect_extra_info($name,$email_address, $customer->fields['customers_firstname'] . ' ' . $customer->fields['customers_lastname'] , $customer->fields['customers_email_address'] );
    Last edited by rlexyd; 24 Aug 2021 at 09:25 AM.
    *Zen Cart eCommerce Solution - Putting the Dream of Owning an Online Business within reach of anyone!

  6. #106
    Join Date
    Feb 2009
    Location
    UK
    Posts
    938
    Plugin Contributions
    0

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by rlexyd View Post
    Thank you Simon,

    I replaced these:
    if( $_SESSION['customer_id'] ) {
    if (!$_SESSION['customer_id']) {
    with
    if(zen_is_logged_in()) {

    That stopped the Undefined index: customer_id from appearing in the logs.
    Not sure if you did but

    Code:
    if (!$_SESSION['customer_id']) {
    needs to be replaced with (exclamation mark before 'zen')

    Code:
    if(!zen_is_logged_in()) {
    Simon

  7. #107
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,726
    Plugin Contributions
    79

    Default Re: Reviews - Updated [Support Thread]

    I've just submitted v1.3.0 of Reviews Updated for the Zen Cart moderators' review; I'll post back here when it's available for download.

    This version supports Zen Cart versions 1.5.7 and later, using the responsive_classic template's layout for the templating change-basis. Anyone wanting an early peek can grab the changes from the plugin's GitHub repository: https://github.com/lat9/reviews_updated.

  8. #108
    Join Date
    Feb 2009
    Location
    UK
    Posts
    938
    Plugin Contributions
    0

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by lat9 View Post
    I've just submitted v1.3.0 of Reviews Updated for the Zen Cart moderators' review; I'll post back here when it's available for download.

    This version supports Zen Cart versions 1.5.7 and later, using the responsive_classic template's layout for the templating change-basis. Anyone wanting an early peek can grab the changes from the plugin's GitHub repository: https://github.com/lat9/reviews_updated.
    Thank you Cindy. I've sent you a long overdue coffee and sugar-free doughnuts.
    Simon

  9. #109
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,726
    Plugin Contributions
    79

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by lat9 View Post
    I've just submitted v1.3.0 of Reviews Updated for the Zen Cart moderators' review; I'll post back here when it's available for download.

    This version supports Zen Cart versions 1.5.7 and later, using the responsive_classic template's layout for the templating change-basis. Anyone wanting an early peek can grab the changes from the plugin's GitHub repository: https://github.com/lat9/reviews_updated.
    Now available for download: https://www.zen-cart.com/downloads.php?do=file&id=1442

  10. #110
    Join Date
    Nov 2006
    Location
    Sydney, Australia
    Posts
    457
    Plugin Contributions
    1

    Default Re: Reviews - Updated [Support Thread]

    THANK YOU very much Cindy!!!
    I've just installed it on my 1.5.7c, PHP 7.4 on Responsive Classic.
    I am no longer getting error logs generate BEFORE submitting, which is great!
    I am however getting a couple of issues, please see below.

    1) When Logged in as a Customer, the part that displays the First name and initial Surname is showing as this %s %1.1s.
    (Note it displays the name correctly after the Written By: First S section, but not the lower privacy warning.)
    https://i.imgur.com/dNCkY0x.jpg

    2) I am getting an Error log generate after submitting a review as a Guest:
    Code:
    [25-Aug-2021 08:31:56 Australia/Sydney] Request URI: /01/index.php?main_page=product_reviews_write&action=process&products_id=16,
    #1  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined variable: extra_info in /01/includes/modules/pages/product_reviews_write/header_php.php on line 150.
    --> PHP Notice: Trying to access array offset on value of type null in /01/includes/modules/pages/product_reviews_write/header_php.php on line 150.
    
    Line 150: zen_mail('', SEND_EXTRA_REVIEW_NOTIFICATION_EMAILS_TO, $email_subject, $email_text . $extra_info['TEXT'], STORE_NAME, EMAIL_FROM, $html_msg, 'reviews_extra');
    3) I am also getting an Error log generate after submitting a review as a Customer:
    Code:
    [25-Aug-2021 08:36:55 Australia/Sydney] Request URI: /01/index.php?main_page=product_reviews_write&action=process&products_id=11,
    #1  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined index: review_name in /01/includes/modules/pages/product_reviews_write/header_php.php on line 66.
    
    Line 66: $review_name = zen_db_prepare_input(zen_clean_html($_POST['review_name']));
    
    [25-Aug-2021 08:36:55 Australia/Sydney] Request URI: /01/index.php?main_page=product_reviews_write&action=process&products_id=11,
    #1  require(/01/includes/modules/pages/product_reviews_write/header_php.php) called at [/01/index.php:35]
    --> PHP Notice: Undefined variable: name in /01/includes/modules/pages/product_reviews_write/header_php.php on line 144.
    --> PHP Notice: Undefined variable: email_address in /01/includes/modules/pages/product_reviews_write/header_php.php on line 144.
    
    Line 144: $extra_info=email_collect_extra_info($name,$email_address, $customer->fields['customers_firstname'] . ' ' . $customer->fields['customers_lastname'] , $customer->fields['customers_email_address'] );
    *Zen Cart eCommerce Solution - Putting the Dream of Owning an Online Business within reach of anyone!

 

 
Page 11 of 12 FirstFirst ... 9101112 LastLast

Similar Threads

  1. ZX Slideshow support thread
    By balihr in forum All Other Contributions/Addons
    Replies: 698
    Last Post: 18 Nov 2021, 08:24 PM
  2. Hebrew Support - latest release [Support Thread]
    By eranariel in forum Addon Language Packs
    Replies: 16
    Last Post: 22 Mar 2021, 01:11 AM
  3. v150 Orders Status History -- Updated By [Support Thread]
    By lat9 in forum Addon Admin Tools
    Replies: 34
    Last Post: 29 Jul 2019, 07:05 PM
  4. v151 Reviews Reply addon [Support Thread]
    By mikestaps in forum All Other Contributions/Addons
    Replies: 9
    Last Post: 17 Oct 2014, 01:29 AM
  5. Replies: 68
    Last Post: 29 Jul 2013, 06:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR