Page 5 of 12 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 116
  1. #41
    Join Date
    Dec 2010
    Location
    UK
    Posts
    1,770
    Plugin Contributions
    3

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by asdfwen View Post
    Hi, I noticed two bugs of this module.
    1.it only accounts for newly written review.
    2. In admin review page,customers' name are shown the same as reviews.php in front website page. I want the customer's full name are shown in admin review page.
    Can you solve this two bugs?
    Thanks!
    Don't you think that these are requests, no 'bugs'?

  2. #42
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,590
    Plugin Contributions
    78

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by picandnix View Post
    Don't you think that these are requests, no 'bugs'?
    As picandnix indicated, the behavior you've identified is how the module was designed to work; it only accounts for newly-written reviews and the reviewer name shows up the same in the admin.

  3. #43
    Join Date
    Aug 2010
    Location
    Hartland, MI
    Posts
    272
    Plugin Contributions
    3

    Default Re: Reviews - Updated [Support Thread]

    I have a couple of things...
    1. message stack/notice is not showing up when customer is not logged in and tries to write a review with Enable product reviews by guests? set to 0.

    2. I had previously added reply to reviews functionality to my 1.3.9h store. I am trying to add it to this with some problems. I am hoping that someone notices and can correct my mistake/s and/or omissions.
    All I have been getting is a blank page with no right side boxes, and no myDebug out put either...???
    here is a list of my mods...

    SQL
    Code:
    ALTER TABLE  `reviews_description`
      ADD  `reviews_reply_text` TEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL;
    modules/pages/product_reviews_info/header_php.php:
    Code:
    // addition of reviews_reply_text below
    
      $review_info_query = "SELECT rd.reviews_text, r.reviews_rating, r.reviews_id, r.customers_name,  rd.reviews_reply_text,
    
                                   r.date_added, r.reviews_read, p.products_id, p.products_price,
    
                                   p.products_tax_class_id, p.products_image, p.products_model, pd.products_name
    
                            FROM " . TABLE_REVIEWS . " r, " . TABLE_REVIEWS_DESCRIPTION . " rd, " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd
    
                            WHERE r.reviews_id = :reviewsID
    
                            AND r.reviews_id = rd.reviews_id
    
                            AND rd.languages_id = :languagesID
    
                            AND r.products_id = p.products_id
    
                            AND p.products_status = '1'
    
                            AND p.products_id = pd.products_id
    
                            AND pd.language_id = :languagesID " . $review_status;
    
    
    
      $review_info_query = $db->bindVars($review_info_query, ':reviewsID', $_GET['reviews_id'], 'integer');
    
      $review_info_query = $db->bindVars($review_info_query, ':languagesID', $_SESSION['languages_id'], 'integer');
    
      $review_info = $db->Execute($review_info_query);
    
    
    
      $products_price = zen_get_products_display_price($review_info->fields['products_id']);
    
    
    
      $products_name = $review_info->fields['products_name'];
    
    //addition of reviews reply
      if ($review_info->fields['reviews_reply_text']) != '') {
    		$reviews_reply_text = $review_info->fields['reviews_reply_text'];
    		}
    
      if ($review_info->fields['products_model'] != '') {
    
        $products_model = '<br /><span class="smallText">[' . $review_info->fields['products_model'] . ']</span>';
    
      } else {
    
        $products_model = '';
    
      }
    languages/english/YOUR_TEMPLATE/product_reviews_info.php
    Code:
    define('TEXT_OF_5_STARS', '');
    
    define('TEXT_PRODUCT_INFO', 'Take Me to the Details');
    
    define('TEXT_REVIEW_ADDITIONAL', 'Read More Reviews');
    //addition of review reply heading
    define('TEXT_REVIEW_REPLY_HEADING','<strong>' . STORE_NAME . ''s Reply:</strong>');
    templates/YOUR_TEMPLATE/templates/tpl_product_reviews_info_default.php
    Code:
    ADDED TO THE BOTTOM, JUST BEFORE THE LAST </div>
    
    <!--bof Reviews Reply -->
    
    <br class="clearBoth"/>
    
    <?php
    if ($reviews_reply_text) != ''){
    ?> 
    <div id="reviewsInfoDefaultMainContent" class="content"><?php echo TEXT_REVIEW_REPLY_HEADING; ?><br /><?php echo zen_break_string(nl2br(zen_output_string_protected(stripslashes($review_info->fields['reviews_reply_text']))), 60, '-<br />'); ?></div>
    
    <?php } ?>
    <!--eof Reviews Reply-->
    </div>
    My hope is to get this working properly, and then add the ability to write your reply on the "edit review" page in the admin. I am currently just writing the reply's through phpMyAdmin and then approving the review there.

    The working 1.3.9 version of this is here

    Non working 1.5.1 is here - (this store is not yet public!)

  4. #44
    Join Date
    Aug 2010
    Location
    Hartland, MI
    Posts
    272
    Plugin Contributions
    3

    Default Re: Reviews - Updated [Support Thread]

    Ok, so the reply is working now. Once I get the edit aspect of it working I'll post it!

  5. #45
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,590
    Plugin Contributions
    78

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by mikestaps View Post
    I have a couple of things...
    1. message stack/notice is not showing up when customer is not logged in and tries to write a review with Enable product reviews by guests? set to 0.
    I'm not sure what notice you're expecting, but on a "stock" Zen Cart v1.5.1 install with this plugin installed ... if "Enable product reviews by guests?" is set to 0, the "Write Reviews" button still shows but clicking it takes the customer to the login page with a message that reads "You need to sign into your account before you can write a review."

  6. #46
    Join Date
    Aug 2010
    Location
    Hartland, MI
    Posts
    272
    Plugin Contributions
    3

    Default Re: Reviews - Updated [Support Thread]

    The message "You need to sign into your account before you can write a review." doesn't show up....
    I'll dig into that tomorrow, I was all focused on the reply thing.

  7. #47
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,590
    Plugin Contributions
    78

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by mikestaps View Post
    The message "You need to sign into your account before you can write a review." doesn't show up....
    I'll dig into that tomorrow, I was all focused on the reply thing.
    It's a header-message, so it will depend on where those messages are displayed in your template. For the "Classic" template, the message shows at the very top of the screen.

  8. #48
    Join Date
    Oct 2013
    Location
    United Kingdom
    Posts
    5
    Plugin Contributions
    0

    Default Re: Reviews - Updated [Support Thread]

    Does this address the duplicate review content issue? Reviews currently appear on multiple pages, which isn't great from an seo standpoint.

  9. #49
    Join Date
    Jan 2014
    Location
    United States
    Posts
    28
    Plugin Contributions
    0

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by pwdan View Post
    Does this address the duplicate review content issue? Reviews currently appear on multiple pages, which isn't great from an seo standpoint.
    Hello, I installed this add on and it isn't working for me. I just created my store recently with the new 1.51 version. I am using the fast and easy checkout, and only using guest checkout, forcing the customer to go to the enter billing information step one page after clicking the go to checkout. my site is http://cardiozonetreadmills.com . I am sure I installed this correct. if I enter in my billing information and go to the next step in the checkout, I am then allowed to write reviews if I go back to a product page and click the write review button. I am sure I have all the configurations set correctly. Everything else is working good. I have done quite alot of customizing to my site and had to learn alot to do it, been spending so much time on it everyday.

    Anyone know what might be needed or fixed?

    I realized with the shopping cart and free shipping in the header add on that the english file needed to be put in the main english folder, not one step further into my templates folder like the instructions says. I'm not using that add on right now until I get it looking right on my site.

    Thanks everyone alot for all the free information and assistance. I've read alot here.

  10. #50
    Join Date
    Dec 2010
    Location
    UK
    Posts
    1,770
    Plugin Contributions
    3

    Default Re: Reviews - Updated [Support Thread]

    Quote Originally Posted by tom97zr2 View Post
    Hello, I installed this add on and it isn't working for me. I just created my store recently with the new 1.51 version. I am using the fast and easy checkout, and only using guest checkout, forcing the customer to go to the enter billing information step one page after clicking the go to checkout. my site is http://cardiozonetreadmills.com . I am sure I installed this correct. if I enter in my billing information and go to the next step in the checkout, I am then allowed to write reviews if I go back to a product page and click the write review button. I am sure I have all the configurations set correctly. Everything else is working good. I have done quite alot of customizing to my site and had to learn alot to do it, been spending so much time on it everyday.

    Anyone know what might be needed or fixed?

    I realized with the shopping cart and free shipping in the header add on that the english file needed to be put in the main english folder, not one step further into my templates folder like the instructions says. I'm not using that add on right now until I get it looking right on my site.

    Thanks everyone alot for all the free information and assistance. I've read alot here.
    To be honest I'm not 100% sure what your actual question is.
    However I'm surmising: if you are using FEC with it set to guest checkout only and only a registered customer can write a review (yes?) then logically you wouldn't be able to write a review until the system knows your information/account details anyway, right? Hence you being able to write a review only *after* submitting your personal details and not beforehand.

 

 
Page 5 of 12 FirstFirst ... 34567 ... LastLast

Similar Threads

  1. ZX Slideshow support thread
    By balihr in forum All Other Contributions/Addons
    Replies: 679
    Last Post: 3 May 2021, 11:09 PM
  2. Hebrew Support - latest release [Support Thread]
    By eranariel in forum Addon Language Packs
    Replies: 16
    Last Post: 22 Mar 2021, 01:11 AM
  3. v150 Orders Status History -- Updated By [Support Thread]
    By lat9 in forum Addon Admin Tools
    Replies: 34
    Last Post: 29 Jul 2019, 07:05 PM
  4. v151 Reviews Reply addon [Support Thread]
    By mikestaps in forum All Other Contributions/Addons
    Replies: 9
    Last Post: 17 Oct 2014, 01:29 AM
  5. Replies: 68
    Last Post: 29 Jul 2013, 06:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR