Page 2 of 140 FirstFirst 12341252102 ... LastLast
Results 11 to 20 of 1400
  1. #11
    Join Date
    Jan 2006
    Posts
    1,678
    Plugin Contributions
    0

    Default Re: Ultimate SEO 2.200+ (new features)

    Quote Originally Posted by lhungil View Post

    Code:
    <!-- BACK BUTTON GENERATED <?php
    if(sizeof($_SESSION['navigation']->path)-2 >= 0) {
        $back = sizeof($_SESSION['navigation']->path)-2; ?>
        SESSION PAGE: <?php echo $_SESSION['navigation']->path[$back]['page']; ?>
        SESSION PARAMS: <?php echo zen_array_to_string($_SESSION['navigation']->path[$back]['get'], array('action'); ?>
        SESSION CONNECTION: <?php echo $_SESSION['navigation']->path[$back]['mode']; ?>
        GENERATED LINK: <?php echo zen_href_link($_SESSION['navigation']->path[$back]['page'],zen_array_to_string($_SESSION['navigation']->path[$back]['get'], array('action')), $_SESSION['navigation']->path[$back]['mode']);
    } ?>
    -->
    I guess I don't know where to add this code.

    I'm trying to test it on my Page 2 on this site here:

    http://www.promdressesforless.us/page_2.html

    I currently have the code on templates/estorenow/templates/tpl_page_2_default.php but the page went blank and cut off my footer area.

    I also tried modules/pages and again under languages but got internal server error on those.

    Where exactly do we add this? Thanks.
    Steve
    prommart.com

  2. #12
    Join Date
    Feb 2012
    Location
    mostly harmless
    Posts
    1,811
    Plugin Contributions
    8

    bug Back Link Debugging

    Back links are NOT actually created by the "Ultimate SEO" plugin and I suspect the same is true for the "Simple SEO" plugin. Back links are actually created by a stock function built into Zen Cart. However these two modules typically hook into the function "zen_href_link" which IS used by the function generating back links.

    The built in function simply looks at a session variable storing "navigation history". If there is history, it sends the historical parameters to the function "zen_href_link" which in turn calls the code for URL (re-)writing. If no history exists and there is a referrer the referrer is used.

    The templates I have attached to this thread (for page2, page3, page4, and contact_us) will add a comment to the webpage source listing the parameters sent to the "zen_href_link" function. They were created against "template_default" so if you are using a custom template, you may want to copy the relevant section to your custom template.

    These templates should give us better insight into what is occurring when people see intermittent 404's on a back link.

    For example, if the parameters do not make sense, have garbled characters, or are to invalid pages we know something else is breaking the back button functionality. If the parameters are correct and the generated link is correct, but you are getting the 404, possibly a rewrite rule is not working as expected. If the parameters are correct and the generated link is wrong... then most likely something went wrong in the URL (re-)writer and further debugging will be necessary.

  3. #13
    Join Date
    Jan 2006
    Posts
    1,678
    Plugin Contributions
    0

    Default Re: Back Link Debugging

    Didn't work, sorry.

    Tried the fix on my problem site here:

    http://www.promdressesforless.us/

    I even tried with the Classic template using page 2 fix. Still didn't work, have back button/page not found problem.

    NOTE: that my bug only happens in the Chrome browser. My IE9 and Firefox work okay.

    Only mods on site are Easy Populate 4, Image Handler 4, DrByte's DB Backup plugin, Column Layout Grid...and the Estorenow template for this purpose. But Classic and Hampshire Cammie (Picaflor) templates didn't work in Chrome re the back button.

    My fresh install on Classic template here does work in Chrome:

    http://www.prom-mart.com/demo-4/

    Only plugin is Ultimate SEO. (No IH)

    Now, this is interesting. I have another 1.5 site here with Ultimate SEO:

    http://www.prom-mart.com/demo-2/

    Plugins: Dynamic Filter (disabled)

    It uses the rather sophisticated Rubik template and is somewhat jacked-up from my messing around. BUT the back button works in Chrome!

    And I just noticed that I have not installed Image Handler 4 on this site.

    Wonder if IH4 could be the problem in Chrome? The sites that work don't yet have IH; and the sites that don't work do have IH.

    Thanks again for your help.

    EDIT: My sister's site - 1.5ZC, Ultimate SEO, Cambridge Pro Template (Picaflor) and *IH4* - back button doesn't work in Chrome. Tried fix with just contact us, didn't work.
    Last edited by SPH; 28 Aug 2012 at 03:55 AM.
    Steve
    prommart.com

  4. #14
    Join Date
    Jan 2006
    Posts
    1,678
    Plugin Contributions
    0

    Default Re: Ultimate SEO 2.200 (new features) [Support Thread]

    Nope, probably isn't IH.

    I have two more demo sites - more serious so less messing around - that I recently installed Ultimate SEO on.

    http://www.webdivision.prommart.com/...h_id=barebones

    http://www.prom-mart.com/demo-3/?tem...h_id=estorenow

    Both sites use template switcher and IH4. One has the Dynamic Filter. One of the templates is Estorenow (same template as on my problem site). The back button WORKS on both sites in Chrome and without the fix.

    Only a problem for me in Chrome. Can't figure it out. But perhaps the pop-up Terms on page two of checkout that I recently discovered and got working on one of my sites will solve the back button problem during checkout, so customers don't get lost. I think that the main issue.

    EDIT: My barebones site in first link with Dynamic Filter even works in Chrome with the backbutton.
    Last edited by SPH; 28 Aug 2012 at 04:13 AM.
    Steve
    prommart.com

  5. #15
    Join Date
    Feb 2012
    Location
    mostly harmless
    Posts
    1,811
    Plugin Contributions
    8

    Default Re: Ultimate SEO 2.200 (new features) [Support Thread]

    Those templates are not a "fix" they just can be used to provide additional debugging information relating to the generation of the back button. With the changes in those templates, the following can be found in the generated website source code right above the generated back button.

    Code:
    <!-- BACK BUTTON GENERATED 
        SESSION PAGE: 'product_info'
        SESSION PARAMS: 'products_id=22'
        SESSION CONNECTION: 'NONSSL'
        GENERATED LINK: 'http://www.earth.local/store/software-c-2/action-c-2_19/unreal-tournament-linked-p-22.html'-->
    Please post the results here from the "broken" chrome link.
    Last edited by lhungil; 28 Aug 2012 at 08:57 PM.

  6. #16
    Join Date
    Mar 2004
    Location
    Ontario, Canada
    Posts
    138
    Plugin Contributions
    6

    Default Re: Ultimate SEO 2.200 (new features) [Support Thread]

    Can you provide a link to download v2.205? Thanks
    Chinese language pack
    Zen Cart plugins demo includes Ultimate SEO, Image Handler, Template Switch, Column Layout, Lightbox and Multi-Language EZ-Pages

  7. #17
    Join Date
    Feb 2012
    Location
    mostly harmless
    Posts
    1,811
    Plugin Contributions
    8

    Default Re: Ultimate SEO 2.200 (new features) [Support Thread]

    Quote Originally Posted by neteasy View Post
    Can you provide a link to download v2.205? Thanks
    The official download page for "Ultimate SEO" is http://www.zen-cart.com/downloads.php?do=file&id=132. Version 2.205 has been uploaded and is currently pending review by a moderator.

  8. #18
    Join Date
    Jan 2006
    Posts
    1,678
    Plugin Contributions
    0

    Default Re: Ultimate SEO 2.200 (new features) [Support Thread]

    Quote Originally Posted by lhungil View Post
    Those templates are not a "fix" they just can be used to provide additional debugging information relating to the generation of the back button. With the changes in those templates, the following can be found in the generated website source code right above the generated back button.

    Code:
    <!-- BACK BUTTON GENERATED 
        SESSION PAGE: 'product_info'
        SESSION PARAMS: 'products_id=22'
        SESSION CONNECTION: 'NONSSL'
        GENERATED LINK: 'http://www.earth.local/store/software-c-2/action-c-2_19/unreal-tournament-linked-p-22.html'-->
    Please post the results here from the "broken" chrome link.
    Misunderstood, sorry.

    I'm posting below the view source for Contact Us and Page 2 - after first going to a product - for Chrome and then IE9:


    Code:
    Contact Us - Chrome
    
    <!-- BACK BUTTON GENERATED 
        SESSION PAGE: 'page_not_found'
        SESSION PARAMS: ''
        SESSION CONNECTION: 'NONSSL'
        GENERATED LINK: 'http://www.promdressesforless.us/index.php?main_page=page_not_found'-->
    <div class="buttonRow back"><a href="http://www.promdressesforless.us/index.php?main_page=page_not_found"><img src="includes/templates/estorenow/buttons/english/button_back.gif" alt="Back" title=" Back " width="70" height="21" /></a></div>
    </form>
    </div>
    
    
    
    Page 2 - Chrome
    
    <!-- BACK BUTTON GENERATED 
        SESSION PAGE: 'page_not_found'
        SESSION PARAMS: ''
        SESSION CONNECTION: 'NONSSL'
        GENERATED LINK: 'http://www.promdressesforless.us/index.php?main_page=page_not_found'-->
    <div class="buttonRow back"><a href="http://www.promdressesforless.us/index.php?main_page=page_not_found"><img src="includes/templates/estorenow/buttons/english/button_back.gif" alt="Back" title=" Back " width="70" height="21" /></a></div>
    
    
    Contact Us - IE9
    
    <!-- BACK BUTTON GENERATED 
        SESSION PAGE: 'product_info'
        SESSION PARAMS: 'products_id=31&cPath=1_3'
        SESSION CONNECTION: 'NONSSL'
        GENERATED LINK: 'http://www.promdressesforless.us/alyce-6116-rts2-p-31.html?cPath=1_3'-->
    <div class="buttonRow back"><a href="http://www.promdressesforless.us/alyce-6116-rts2-p-31.html?cPath=1_3"><img src="includes/templates/estorenow/buttons/english/button_back.gif" alt="Back" title=" Back " width="70" height="21" /></a></div>
    
    
    Page 2 IE9
    
    <!-- BACK BUTTON GENERATED 
        SESSION PAGE: 'product_info'
        SESSION PARAMS: 'products_id=15&cPath=1_2'
        SESSION CONNECTION: 'NONSSL'
        GENERATED LINK: 'http://www.promdressesforless.us/paparazzi-8226-rts2-p-15.html?cPath=1_2'-->
    <div class="buttonRow back"><a href="http://www.promdressesforless.us/paparazzi-8226-rts2-p-15.html?cPath=1_2"><img src="includes/templates/estorenow/buttons/english/button_back.gif" alt="Back" title=" Back " width="70" height="21" /></a></div>
    Steve
    prommart.com

  9. #19
    Join Date
    Feb 2012
    Location
    mostly harmless
    Posts
    1,811
    Plugin Contributions
    8

    Default Re: Back Link Debugging

    From what you posted it appears the back link generation code (NOT PART OF ULTIMATE SEO) is telling Ultimate SEO to create a link to "page_not_found". Probably the same think is happening when using other URL (re-)writers.

    What does this mean? Some other plugin or code is being accessed by Chrome and thus added to the internal "history" component of Zen Cart. Or.... Something with Chrome is modifying the SESSION.

    Next steps? You said this does not occur on a stock installation (and I did not see it on my testing site). Start from scratch, add the templates and Ultimate SEO (or other URL (re-)writer). Then add one plugin / add-on at a time, checking after each installation, until problem shows back up. If it shows up after installing a specific plugin, you can either look at fixing the code in that plugin... or contact the developer. Another thing I would do if you are not already: add a debugger such as Firebug to your Chrome installation (or use a proxy) and watch the page requests. This will let you see what requests are being sent (and might be added to the Zen Cart history).

  10. #20
    Join Date
    Feb 2012
    Location
    mostly harmless
    Posts
    1,811
    Plugin Contributions
    8

    Default Product Cache Generation Patch

    Affected Environments
    This affects users with multiple language sites and sites where the website visitor may be using a language not present in the Zen Cart database. The website visitor can still visit the site without any major issues, just the products url cache is NOT fully populated with their language.

    Credits
    Thanks to ivanqf for finding this bug in the released code.

    Request
    Prior to adding this patch to the next release, if anyone running a site with multiple languages or a non-English site could provide some additional testing and feedback it would be appreciated.
    Last edited by swguy; 11 Sep 2012 at 09:36 PM.

 

 
Page 2 of 140 FirstFirst 12341252102 ... LastLast

Similar Threads

  1. Ultimate Fade-In Slidehow Support thread
    By outeredge2 in forum All Other Contributions/Addons
    Replies: 158
    Last Post: 4 Feb 2017, 03:10 AM
  2. Ultimate Cross Sell [Support Thread]
    By ultimate_zc in forum All Other Contributions/Addons
    Replies: 239
    Last Post: 17 May 2015, 03:25 AM
  3. Ultimate Content Glider [Support Thread]
    By ultimate_zc in forum All Other Contributions/Addons
    Replies: 11
    Last Post: 4 Sep 2012, 05:16 AM
  4. Re: Simple SEO URL [support thread]
    By creamcrackers in forum General Questions
    Replies: 2
    Last Post: 16 Aug 2009, 03:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR