Page 1 of 7 123 ... LastLast
Results 1 to 10 of 1482

Hybrid View

  1. #1
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,030
    Plugin Contributions
    32

    Default Edit Orders v4.0 Support Thread

    Welcome to the new support thread for Edit Orders v4.0.

    Edit Orders v4.0 has been submitted to the downloads I will update this thread when it is available

    Here's the answer to the most frequently asked question: "What does Edit Orders do?"
    (which BTW REALLY IS explained in detail in the readme for those who REALLY wanna know.. it doesn't hurt to download the fileset..)

    PURPOSE & AIM
    Edit Orders is an admin module that allows store owners to edit a customer's order.
    The following edit options are available:

    • Change the customer, billing or shipping information on an order
    • Add or delete products from an order
    • Update product quantities
    • Add or subtract values to/from overall order totals



    Lastly I want to ask a SMALL favor..

    When posting bugs/issues about Edit Orders v4.0, it's a WHOLE LOT more helpful to resolve them if you post details. Just saying "it's broken" or "doesn't work" does not provide nearly enough information to help YOU resolve YOUR issue.

    Please provide as MUCH information as possible including the version of Zen Cart you are running, the version of Super Orders you are running, any other add-ons you may have also installed.. Also hosting/server information (PHP versions, mySQL versions, hosting provider etc) is helpful too.

    AND if you're REALLY detail oriented, tell us the install sequence/method you used to install Super Orders.
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  2. #2
    Join Date
    Aug 2009
    Location
    Washington State
    Posts
    54
    Plugin Contributions
    0

    Default Re: Edit Orders v4.0 Support Thread

    Hello Diva,
    Thank you for updating this add-on. I have only processed a couple of orders and already find myself in a bind needing to edit an order - and can't. I was thrilled to find this add-on and thought I was home free.... or not.
    I am using v1.5.0 (php limitations won't allow update to v1.5.1)
    It was a fresh install of this version
    I added USPS RateV3 January 22, 2012 as instructed
    I added group pricing per item (must have for me) via ftp
    I have a template that I have heavily modified (appearance only)
    I am hosted with godaddy (Linux)

    My challenges:
    My first concern was compatibility with group pricing. I have no idea how to compare/merge files if this is necessary, or how to find out if it is necessary.
    Secondly - I read through your entire read me and I fear I can't use this add-on because of php? The read me says it is not compatible with any php prior to 5.2? I checked my hosting as instructed and it says php 5. I can only assume I am S.O.L because of the php version. Is this the case?

    Thank you in advance for your time and any assistance you can offer.

    Lisa
    Last edited by Bonkycat; 28 Sep 2012 at 11:28 PM.

  3. #3
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,030
    Plugin Contributions
    32

    Default Re: Edit Orders v4.0 Support Thread

    Quote Originally Posted by Bonkycat View Post
    Hello Diva,
    Thank you for updating this add-on. I have only processed a couple of orders and already find myself in a bind needing to edit an order - and can't. I was thrilled to find this add-on and thought I was home free.... or not.
    I am using v1.5.0 (php limitations won't allow update to v1.5.1)
    It was a fresh install of this version
    I added USPS RateV3 January 22, 2012 as instructed
    I added group pricing per item (must have for me) via ftp
    I have a template that I have heavily modified (appearance only)
    I am hosted with godaddy (Linux)

    My challenges:
    My first concern was compatibility with group pricing. I have no idea how to compare/merge files if this is necessary, or how to find out if it is necessary.
    Secondly - I read through your entire read me and I fear I can't use this add-on because of php? The read me says it is not compatible with any php prior to 5.2? I checked my hosting as instructed and it says php 5. I can only assume I am S.O.L because of the php version. Is this the case?

    Thank you in advance for your time and any assistance you can offer.

    Lisa
    Can't advise about compatibility with Group Pricing.. As i state in the readme, you will need to compare the filesets for both add-ons and compare any common files and merge the changes.. If you do not know how to do this you should consider hiring someone to assist you..

    Regarding compatibility with versions lower than 5.3 your are incorrect.. it should be compatible with versions of PHP 5.3 and lower..
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  4. #4
    Join Date
    Aug 2009
    Location
    Washington State
    Posts
    54
    Plugin Contributions
    0

    Default Re: Edit Orders v4.0 Support Thread

    Hi Diva,

    Thank you for taking the time to reply. I will start with baby steps and open each file in both add-ons and see if any of the names are the same. If I find the same file in both add-ons, I will take your advice and hire someone to merge them for me.

    I am still unsure about the php compatibility. I believe you when you say it will work on php 5, but this sentence is in the first paragraph of the read me:
    "Please check your host's PHP version. This module will NOT work for hosting configurations using PHP versions older than 5.2.x"

    If you don't mind, before I go any further, can you confirm that the warning in the read me is in error? Or do I have my wires crossed?

    Thanks again.

  5. #5
    Join Date
    Jan 2007
    Posts
    1,452
    Plugin Contributions
    10

    Default Re: Edit Orders v4.0 Support Thread

    Quote Originally Posted by Bonkycat View Post
    Hi Diva,

    Thank you for taking the time to reply. I will start with baby steps and open each file in both add-ons and see if any of the names are the same. If I find the same file in both add-ons, I will take your advice and hire someone to merge them for me.

    I am still unsure about the php compatibility. I believe you when you say it will work on php 5, but this sentence is in the first paragraph of the read me:
    "Please check your host's PHP version. This module will NOT work for hosting configurations using PHP versions older than 5.2.x"

    If you don't mind, before I go any further, can you confirm that the warning in the read me is in error? Or do I have my wires crossed?

    Thanks again.
    If you click the "Version" link at the top right side of any admin page you will see the PHP version on your server. What does it say? I would be surprised if it just says PHP 5 without some type of minor like 5.1.13 or something like that.

    Zen Cart and it's community are the best!!

  6. #6
    Join Date
    Sep 2008
    Location
    DownUnder, overlooking South Pole.
    Posts
    964
    Plugin Contributions
    6

    Default Re: Edit Orders v4.0 Support Thread

    Should the following line (60 or thereabouts) in v 139-151 of \YOUR_ADMIN\edit_orders.php
    be changed from

    $attribute_table_cost = split("[:,]" , $check_what);

    to

    $attribute_table_cost = preg_split("[:,]" , $check_what);

    Thanks

  7. #7
    Join Date
    Aug 2009
    Location
    Washington State
    Posts
    54
    Plugin Contributions
    0

    Default Re: Edit Orders v4.0 Support Thread

    Quote Originally Posted by lankeeyankee View Post
    If you click the "Version" link at the top right side of any admin page you will see the PHP version on your server. What does it say? I would be surprised if it just says PHP 5 without some type of minor like 5.1.13 or something like that.
    Thank you lankeeyankee! Within Godaddy, it simply stated "php version 5". However, following your instructions to check from within admin, it would appear I am using v. 5.2.17.
    I appreciate your time and assistance.
    Lisa

  8. #8
    Join Date
    Jul 2009
    Posts
    12
    Plugin Contributions
    0

    Default Re: Edit Orders v4.0 Support Thread

    Using Zen Cart 1.5 and PHP Version 5.3.5
    This was a clean install of 1.5 as I was using shop-scrip for the past 10 years or so.

    Have edit orders 4.03 and Super Orders 4.02 installed. Also Image Handler 4 v 4.0.
    fedex web services, USPS services, and ceon processing

    (although in admin/edit orders version it says 4.02) Don't remember what I installed as this hasn't been working for a few months and don't remember what I installed from as I have Version 4.03 on my computer. So maybe I installed 4.02 and downloaded 4.03 but never got around to upgrading?

    Anyway, my issue is that I cannot add a product. It lets me choose the product but when I click Add Now I get "WARNING: An Error occurred, please refresh the page and try again." which gets loopy if I actually follow that instruction.

    I can go into customers and select New Order which creates the order but I cannot add any products.

    Wondering if you can tell me which file might not have updated and I can either replace it or use win-merge to update.

    Thanks!!

  9. #9
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,030
    Plugin Contributions
    32

    Default Re: Edit Orders v4.0 Support Thread

    Quote Originally Posted by charliea View Post
    Using Zen Cart 1.5 and PHP Version 5.3.5
    This was a clean install of 1.5 as I was using shop-scrip for the past 10 years or so.

    Have edit orders 4.03 and Super Orders 4.02 installed. Also Image Handler 4 v 4.0.
    fedex web services, USPS services, and ceon processing

    (although in admin/edit orders version it says 4.02) Don't remember what I installed as this hasn't been working for a few months and don't remember what I installed from as I have Version 4.03 on my computer. So maybe I installed 4.02 and downloaded 4.03 but never got around to upgrading?

    Anyway, my issue is that I cannot add a product. It lets me choose the product but when I click Add Now I get "WARNING: An Error occurred, please refresh the page and try again." which gets loopy if I actually follow that instruction.

    I can go into customers and select New Order which creates the order but I cannot add any products.

    Wondering if you can tell me which file might not have updated and I can either replace it or use win-merge to update.

    Thanks!!
    Are asking about Edit Order or whatever manual order add-on you installed?? Either way you need to post your error log results so we don't have to GUESS what the issue is..
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  10. #10
    Join Date
    Jul 2009
    Posts
    12
    Plugin Contributions
    0

    Default Re: Edit Orders v4.0 Support Thread

    Quote Originally Posted by DivaVocals View Post
    Are asking about Edit Order or whatever manual order add-on you installed?? Either way you need to post your error log results so we don't have to GUESS what the issue is..
    Ok - found it.....
    [26-Jan-2013 21:07:08] PHP Fatal error: 1064:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'S Cinnamon Chips',
    products_price = '89.0000',
    f' at line 5 :: insert into orders_products set
    orders_id = 3883,
    products_id = 5,
    products_model = '14672',
    products_name = 'HERSHEY'S Cinnamon Chips',
    products_price = '89.0000',
    final_price = '89',
    products_tax = '0',
    products_quantity = 1,
    onetime_charges = 0; in /home/my_server/my_store/www/includes/classes/db/mysql/query_factory.php on line 101


    Here's the code preceding line 101 which starts with trigger_eror
    function show_error() {
    if ($this->error_number == 0 && $this->error_text == DB_ERROR_NOT_CONNECTED && !headers_sent() && file_exists('nddbc.html') ) include('nddbc.html');
    echo '<div class="systemError">';
    if (defined('STRICT_ERROR_REPORTING') && STRICT_ERROR_REPORTING == true)
    {
    echo $this->error_number . ' ' . $this->error_text;
    echo '<br />in:<br />[' . (strstr($this->zf_sql, 'db_cache') ? 'db_cache table' : $this->zf_sql) . ']<br />';
    } else {
    echo 'WARNING: An Error occurred, please refresh the page and try again.';
    }
    trigger_error($this->error_number . ':' . $this->error_text . ' :: ' . $this->zf_sql, E_USER_ERROR);

 

 
Page 1 of 7 123 ... LastLast

Similar Threads

  1. v150 Super Orders v4.0 Support Thread (for ZC v1.5.x)
    By DivaVocals in forum All Other Contributions/Addons
    Replies: 716
    Last Post: 13 Nov 2019, 06:07 PM
  2. v150 Orders Status History -- Updated By [Support Thread]
    By lat9 in forum All Other Contributions/Addons
    Replies: 34
    Last Post: 29 Jul 2019, 07:05 PM
  3. Edit Orders v3.0 for ZC 1.3.9 [Support Thread]
    By DivaVocals in forum All Other Contributions/Addons
    Replies: 656
    Last Post: 18 Apr 2016, 06:28 PM
  4. v139h Super Orders v3.0 Support Thread (for ZC v1.3.9)
    By DivaVocals in forum All Other Contributions/Addons
    Replies: 1018
    Last Post: 28 Apr 2014, 11:38 PM
  5. RE: Super Orders v3.0 Support Thread
    By Johnnyd in forum All Other Contributions/Addons
    Replies: 0
    Last Post: 22 Jun 2011, 09:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR