Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2008
    Posts
    85
    Plugin Contributions
    0

    Default PHP 5.3 error in v1.3.8a

    Hello All,

    Recently, i was screwed up when my host took a decision to upgrade to PHP5.3
    I am on 1.3.8a and had completely no idea what to do.

    After looking for the forum, i could get the PHP patch and it worked like a dream !
    Result : Site was up and business up and running.

    Now, after some days, there was an observation : Orders are not showing up in the admin.
    I did some analytical thinking and went and checked the ipn_main_handler.php file.

    I think that while passing data from PayPal to zc admin, there is an error because the eregi function still exists in that file. I tried to replace it with preg_match but was unsuccessful. I think i am wrong with the syntax. I tried googling on it but somehow not able to manage it.

    I am attaching the file.
    Can someone suggest me how do i go about the changes to this file...?

    I think maybe it would be great if we can add this file also in the patch

    Thanks in advance.

    Regards,
    Chetan
    Attached Files Attached Files

  2. #2
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    27,835
    Plugin Contributions
    9

    Default Re: PHP 5.3 error in ipn_main_handler.php

    You need to upgrade due to KNOWN vulnerabilities in 1.3.8a

    IPN has been updated BUT is still unreliable as paypal express is preferred
    Zen-Venom Get Bitten

  3. #3
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: PHP 5.3 error in ipn_main_handler.php

    Quote Originally Posted by mr.chetanladdha View Post
    my host took a decision to upgrade to PHP5.3
    I am on 1.3.8a and had completely no idea what to do
    Zen Cart v1.3.8a (released in 2007) has NEVER been and never will be compatible with PHP 5.3 (released 2009)

    If you want compatibility with PHP 5.3 (released in 2009), you should use software designed for PHP 5.3 and that would mean something that's probably released during or after 2009.

    Today is 2012.

    Time to upgrade.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #4
    Join Date
    Jul 2008
    Posts
    85
    Plugin Contributions
    0

    Default Re: PHP 5.3 error in ipn_main_handler.php

    Hello Kobra / Dr.Byte,

    Thanks for your replies.

    The problem is that I stated the website when I was completely new to this field. I did a customsation with many modules. That time I was not much aware of the overrides folder.

    Now, if i upgrade, there would be a big problem as I do not remember which addons i used , etc.

    However, Can you please help me resolve this problem for this.
    I am planning to invest time for upgrade not sure if i should as it can be loss of business if anything goes wrong.

    Kindly help me resolve this problem.

    Thanks,
    Chetan

  5. #5
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: PHP 5.3 error in ipn_main_handler.php

    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  6. #6
    Join Date
    Jul 2008
    Posts
    85
    Plugin Contributions
    0

    Default Re: PHP 5.3 error in ipn_main_handler.php

    Thanks Dr.Byte.

    I will try this and update the file here.

    Regards,
    Chetan

 

 

Similar Threads

  1. Replies: 1
    Last Post: 24 Nov 2012, 05:32 PM
  2. v150 PHP Fatal error: Out of memory in includes/modules/attributes.php
    By donnyb in forum General Questions
    Replies: 0
    Last Post: 6 Apr 2012, 12:15 AM
  3. Replies: 3
    Last Post: 13 Mar 2009, 05:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR