Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2012
    Posts
    2
    Plugin Contributions
    0

    application error problem with cURL on WAMP

    I'm trying to install zencart on a WAMP (Apache 2.4.2, MySQL 5.5.24, PHP 5.4.3) setup on W7.

    However, The setup inspection screen is telling me that cURL support = OFF, yet my php.ini is showing it as ON (as does the drop-down list from the WAMP system-tray function. Can anyone shed any light on this situation please?

    Thanks,
    Steve R

  2. #2
    Join Date
    Jan 2004
    Posts
    66,373
    Blog Entries
    7
    Plugin Contributions
    274

    Default Re: problem with cURL on WAMP

    The System Inspection screen gets its info by asking PHP what the status is for each of those things.

    In this case, Zen Cart is asking PHP whether the 'curl' extension has been loaded. And PHP is not saying yes back.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Feb 2012
    Location
    mostly harmless
    Posts
    1,809
    Plugin Contributions
    8

    Default Re: problem with cURL on install

    Quote Originally Posted by Porpoise View Post
    ... The setup inspection screen is telling me that cURL support = OFF, yet my php.ini is showing it as ON (as does the drop-down list from the WAMP system-tray function.
    Do a quick double check. If you go to http://localhost/?phpinfo=1 on the computer with WAMP installed, does this page say cURL support is enabled? I seem to remember in the past having some issues using WAMP related to me not modifying the correct "php.ini".

    While probably not the problem, you will also want to make sure both the apache and php executable you are using are added as exceptions to any installed firewall (even the built in Windows Firewall) and can communicate with the outside world (you could temporarily disable any firewalls to see if this is the problem).
    The glass is not half full. The glass is not half empty. The glass is simply too big!
    Where are the Zen Cart Debug Logs? Where are the HTTP 500 / Server Error Logs?
    Zen Cart related projects maintained by lhngl : Plugin / Module Tracker

 

 

Similar Threads

  1. Problem With cURL on XAMPP and Windows 7
    By Grumpy One in forum Installing on a Windows Server
    Replies: 3
    Last Post: 22 Sep 2011, 12:14 PM
  2. Install problem - wamp 2.0
    By BigMike57 in forum Installing on a Windows Server
    Replies: 0
    Last Post: 22 Nov 2009, 12:35 AM
  3. Wamp wamp wamp - can't get wamp to run
    By mw4kids in forum Installing on a Windows Server
    Replies: 36
    Last Post: 21 May 2009, 03:37 AM
  4. Wamp and zen cart = CURL error!
    By johnylee in forum Installing on a Windows Server
    Replies: 2
    Last Post: 20 Mar 2009, 10:12 PM
  5. Problem with cURL
    By Macbos in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 9 Nov 2006, 05:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR