Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2013
    Posts
    3
    Plugin Contributions
    0

    Default Some Grid Images Not Loading After Hosting Service Migration

    Hello,

    We're hosting our ZenCart website (www.atthemeadow.com) on MediaTemple. There're forcing us to upgrade to a new service. I have completed the auto-migration, and everything except one thing seems to be working. The problem is that some photos on the product grids are not loading:

    Name:  missing-pictures.jpg
Views: 518
Size:  61.0 KB

    This is happening the same way in both Chrome and Firefox. When I look at the HTML source, I can't see any difference between the links that load and the ones that don't. Even stranger, the photos that aren't loading are sitting in the proper folder. If I enter in the specific URL for the picture, it loads fine. It just isn't loading as part of the whole page.

    Does anyone have a suggestion of what kind of thing would cause this problem? My initial thought is that there are some customizations on our current server that aren't on the new server. I didn't set up the current server, and I am not intimately familiar with Apache and PHP servers and the types of modifications you can make on them. Anything related to image handling?

    Thanks,
    Mark

  2. #2
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Some Grid Images Not Loading After Hosting Service Migration

    When I choose "browse all salts", I see all the product images fine.
    While the images do load slowly (suggests you need to split them into multiple sizes for better performance), they are indeed loading.

    I wonder if your issue is simply that your browser has cached them against the former server's IP address. In that case, clearing your browser's Cache and Cookies should resolve the problem. Similar proof would be found by visiting the same page from another computer and from another browser. If the problem still persists after that, reset your internet modem by unplugging the power and plugging it back in again.
    If there's still a problem after that, then your hosting company should inspect any caching they've put into their network that could be interrupting things. But that's a pretty big stretch.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Jan 2013
    Posts
    3
    Plugin Contributions
    0

    Default Re: Some Grid Images Not Loading After Hosting Service Migration

    Quote Originally Posted by DrByte View Post
    When I choose "browse all salts", I see all the product images fine.
    While the images do load slowly (suggests you need to split them into multiple sizes for better performance), they are indeed loading.
    I'm sorry, I wasn't clear. The current website at www.atthemeadow.com is on the old server.

    I found that my problem was that I forgot to update the <base> tag in my header. Some of the cached images weren't matching up between sites, and thus weren't loading.

  4. #4
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Some Grid Images Not Loading After Hosting Service Migration

    Quote Originally Posted by ssn1139 View Post
    I found that my problem was that I forgot to update the <base> tag in my header.
    Um ... in original Zen Cart code, the <base> tag is set dynamically based on settings in your configure.php file. Why are you changing the <base> tag directly? That is very likely to cause serious problems later.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Jan 2013
    Posts
    3
    Plugin Contributions
    0

    Default Re: Some Grid Images Not Loading After Hosting Service Migration

    I'm only changing it for testing purposes. So while I am testing at the IP address of the new host, the images were trying to pull from the current URL, which is on the old host. So when I pointed the <base> tag at the new host, everything loads correctly. Then I can switch it back to the normal <base> tag that generates from the config as you mentioned when I switch the DNS to point to the new server.

 

 

Similar Threads

  1. v151 Images not showing after migration
    By bonmot in forum Basic Configuration
    Replies: 8
    Last Post: 2 Apr 2015, 11:21 PM
  2. Some images not loading after mod install
    By Inxie in forum Templates, Stylesheets, Page Layout
    Replies: 3
    Last Post: 21 Sep 2012, 07:45 AM
  3. Some images not loading in Facebook
    By cuysan in forum General Questions
    Replies: 0
    Last Post: 17 Mar 2010, 05:16 PM
  4. Zencart Loading VERY Slowly On My Hosting Service
    By Trailtreks in forum General Questions
    Replies: 3
    Last Post: 17 Mar 2008, 07:52 PM
  5. Images do not show in product page after migration
    By jc307 in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 18 Apr 2007, 05:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR