Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Join Date
    May 2007
    Location
    Virginia, USA
    Posts
    93
    Plugin Contributions
    0

    Default Cannot access admin area - login loops back to admin login page

    Hello! I am getting looped back to to the admin login screen every time I attempt to login. There is no error message, just the loop back to the login page. I looked to see if anyone else is having this problem and though I found admin login problems, I could not find this problem, so I'm hoping you can help.

    First I'll give a little background and then I'll tell you the steps I've taken so far.

    Background

    I have moved a zen cart store v1.5.1 from one server to another. I did a fresh install to get the config file info correct and then moved over all the files (being careful not to overwrite the config files) and imported the database via MyPHPadmin.

    The cataglog is visible and shows the store as "down for maintenance". This was the status of the store prior to the move, so I am assuming it is showing that status because of the settings.

    Steps I've Taken

    I cannot access the admin area using the old passwords. Therefore, I used the forgotten password feature and reset the password. I followed the prompts to enter the temporary password and then I followed the prompts to enter the "current" password and the "new" password. When I clicked to login, I was taken back to the regular login screen.

    So, I entered my username and my new password. I was again taken back to the login screen.
    I did NOT get the pink message about the password or username being incorrect. I simply
    got the login screen. It's like it's in a loop.

    So, I tried something different.

    I followed the steps for resetting the Admin password via MyPHPAdmin. The same thing
    happened. I attempted to login with Admin/admin and I was taken to a screen to reset
    the password. I entered the "current" password and the "new" password. Upon clicking to
    login, I was redirected back to the login screen. No pink error message, just the redirect.
    I waited an hour in case the system was responding to all the attempts from my IP Address.

    Same problem.

    I checked the error logs and found this:

    [28-Mar-2013 10:05:32 CST6CDT] PHP Fatal error: 1146:Table 'vangelo2_tempForTesting.vangelo2_db_cache' doesn't exist :: select * from vangelo2_db_cache where cache_entry_name = 'zc_fe8176fff793509766b16dda44d2f87a' in /home/vangelo2/public_html/demo/includes/classes/db/mysql/query_factory.php on line 120

    I get the general idea but what specifically is it telling me to do? I'm not a programmer, so "plain English" details, please (thanks!).

    Alternatively, if you have other thoughts on what's happening and how to resolve it, I would appreciate those as well.

    Thanks for anything you can share.

    Dianne

  2. #2
    Join Date
    Jan 2004
    Posts
    65,255
    Blog Entries
    7
    Plugin Contributions
    226

    Default Re: Cannot access admin area - login loops back to admin login page

    Quote Originally Posted by Dianne View Post
    I was again taken back to the login screen.
    I did NOT get the pink message about the password or username being incorrect. I simply
    got the login screen. It's like it's in a loop.
    When it loops without an error message, the problem to fix is NOT the password. In that case it's not even processing the password to know whether it's valid or not. It's simply not able to start a valid "session". This is a server configuration problem.

    So, all the password-reset attempts you've done have been in vain.

    I'm guessing you forgot the session-directory reset step, which can be fixed now using the fix_cache_key utility from the plugins area. This is explained in the FAQ article which explains the correct way to move your site to another server http://www.zen-cart.com/content.php?...fferent-server

    Additional related reading:
    http://www.zen-cart.com/content.php?...working-for-me
    http://www.zen-cart.com/content.php?...lling-zen-cart
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    May 2007
    Location
    Virginia, USA
    Posts
    93
    Plugin Contributions
    0

    Default Re: Cannot access admin area - login loops back to admin login page

    Actually, yes, those are the instructions I followed to move the site.

    The original site was v1.3.9h and it is the live store, still in existence while we upgrade. To upgrade, I did a fresh install on a different server. Once it was up, I uploaded the theme and the images and manually made all the other changes needed to duplicate the site on v1.5.1 (I manually updated the home page, etc.). Then, I added the modules (an editor, plus stock by attributes and also column grids), taking care to use updated versions; and then I added Google Analytics.

    Once the new site was in good working order (including ability to login to admin panel), I proceeded to move the site to the other server (which will be its permanent home) by following the instructions you mentioned.

    I forgot to mention in my original post that I had uploaded and used the fix_cache_key.php file. I uploaded it into the same directory as the store index.php file. The result I got when I went to the URL is that it redirected to the home page "down for maintenance" screen (just tried it again with the same result).

    I never got any instructions or list of things to fix. Is the fact that it redirected an indication of a particular problem?

    I'll take a look at the two other links you sent and try what's suggested there and report back my results.

    Thanks for your help.

    Dianne
    Last edited by Dianne; 29 Mar 2013 at 04:45 AM.

  4. #4
    Join Date
    Jan 2004
    Posts
    65,255
    Blog Entries
    7
    Plugin Contributions
    226

    Default Re: Cannot access admin area - login loops back to admin login page

    Quote Originally Posted by Dianne View Post
    I forgot to mention in my original post that I had uploaded and used the fix_cache_key.php file. I uploaded it into the same directory as the store index.php file. The result I got when I went to the URL is that it redirected to the home page "down for maintenance" screen (just tried it again with the same result).

    I never got any instructions or list of things to fix. Is the fact that it redirected an indication of a particular problem?
    Ya, the redirect means it didn't actually run, but something else interrupted it first. That sounds like rogue custom rewrite rules in a self-added .htaccess file maybe.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    May 2007
    Location
    Virginia, USA
    Posts
    93
    Plugin Contributions
    0

    Default Re: Cannot access admin area - login loops back to admin login page

    Oh, my! Happy, happy, happy because I was able to login.

    How?

    Shut down and restart the computer. Could it really have been that simple? LOL! I tried everything under the sun and never even thought to do that one simple step (sheepish grin).

    Ah, well...to be reminded of simplicity.

    Thanks, Dr. Byte! Your help is appreciated.

    Dianne

  6. #6
    Join Date
    Jan 2004
    Posts
    65,255
    Blog Entries
    7
    Plugin Contributions
    226

    Default Re: Cannot access admin area - login loops back to admin login page

    It could very well have been an old cookie that got reset when restarting the browser, which would be a byproduct of rebooting.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Aug 2007
    Location
    Gijón, Asturias, Spain
    Posts
    1,991
    Plugin Contributions
    29

    Default Re: Cannot access admin area - login loops back to admin login page

    I had the same problem with Chrome, on a local install. Fixed after deleting all the cache items.
    Steve
    github.com/torvista: Apsona (php7), BackupMySQL Admin/Auto, Product Listing Sorter, Redsys payment module, Spanish Language Pack and more...

  8. #8
    Join Date
    Jul 2013
    Posts
    58
    Plugin Contributions
    0

    Default Re: Cannot access admin area - login loops back to admin login page

    I have the same issue. On the 28th I was able to access Admin just fine. I have tried on two different computers using Firefox. Clearing cache does not help.
    Yesterday I noticed I could not get in and assumed I was not correctly remembering my password. Same issue today
    Nothing has changed on my site. It has not been moved, I have not installed any new plugins, I have not changed any settings.

    I checked the debug logs and have this error:

    [01-Oct-2014 11:32:35 America/Denver] ERROR: Failed sending email to: "Admin" <admin@localhost> with subject: "Admin login failure notice" (failed validation)

    which doesn't really explain anything, though I am not sure why it's trying to send an email to @localhost since that is not the email for my Admin account.

  9. #9
    Join Date
    Sep 2014
    Location
    Buffalo, New York, United States
    Posts
    10
    Plugin Contributions
    0

    Default Re: Cannot access admin area - login loops back to admin login page

    I am getting this error on version 151 as well. Everything was fine up until a few hours ago. [13-Dec-2014 16:56:16 America/Denver] ERROR: Failed sending email to: "Admin" <admin@localhost> with subject: "Admin login failure notice" (failed validation). I have not touched anything on this site for a year and I have no idea what happened. Please help!

  10. #10
    Join Date
    Jan 2004
    Posts
    65,255
    Blog Entries
    7
    Plugin Contributions
    226

    Default Re: Cannot access admin area - login loops back to admin login page

    Quote Originally Posted by Peter Cefalu View Post
    admin@localhost
    I'm not surprised that you'd get an error trying to email that address, since it's essentially an invalid email address.

    So, it begs the question: Do you have an Admin user in your store's admin area which has "admin@localhost" set as the email address? if so, why?

    If you didn't know that you had one, then perhaps someone has gained access to your website's database and injected one maliciously? In that case you need to immediately do a thorough investigation of your site and find out how they got in and remove whatever damage they've done:
    http://www.zen-cart.com/wiki/index.php/Recovering_From_Hacks
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. v153 Can't login to admin - loops back to login
    By missyenta in forum Basic Configuration
    Replies: 24
    Last Post: 17 Mar 2016, 10:31 PM
  2. Replies: 2
    Last Post: 3 May 2013, 02:49 AM
  3. admin login page is missing. cant access admin area
    By ztotheetothen in forum Customization from the Admin
    Replies: 11
    Last Post: 26 Feb 2011, 05:44 PM
  4. Cannot access Admin login page
    By peter49 in forum Installing on a Windows Server
    Replies: 1
    Last Post: 22 Mar 2010, 11:26 PM
  5. Admin Login Page Loops forever
    By ehdesign in forum General Questions
    Replies: 12
    Last Post: 2 Apr 2008, 02:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR