Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Join Date
    May 2008
    Posts
    402
    Plugin Contributions
    0

    Default Re: "The connection was reset" while adding products to the cart

    Quote Originally Posted by RodG View Post
    Typically, what happens is people wait until their V1.3.8 install has been hacked, which usually involves uploading the 'back door' programs, then the site gets 'updated' leaving these backdoor files intact.
    The hackers come back days, weeks, months, sometimes years later to see 'whats new'. Usually without the site owners knowledge.
    In this case they must have dropped those files back in 2011 but didn't actually do anything to mess up the site. Updated, in this particular case, wasn't due to being hacked or anything, but it does appear that lots of people wait until that point.

    The old files remained on the server but were all in different directories. How could the hacker have been able to find those files again despite the added and renamed dirs?

    And what was the hack that caused the site to add multiple items to the cart and time out when using a form like that? (also strange that apparently they hacked in March according to logs, but this issue started in June.)

  2. #12
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,167
    Plugin Contributions
    7

    Default Re: "The connection was reset" while adding products to the cart

    Quote Originally Posted by pricediscrimination View Post
    How could the hacker have been able to find those files again despite the added and renamed dirs?
    Same way that anyone finds anything on the Internet. Search engines. I'm unsure why you felt the need to ask this???

    Quote Originally Posted by pricediscrimination View Post
    And what was the hack that caused the site to add multiple items to the cart and time out when using a form like that?
    Your guess is as good (probably better) than anyones. My guess is that this is an unexpected/unwanted side effect of whatever it was the hacker(s) had done.

    Quote Originally Posted by pricediscrimination View Post
    (also strange that apparently they hacked in March according to logs, but this issue started in June.)
    I don't find this particularly strange at all. It could be two different hackers that independently found the backdoor(s) a few months apart. The 1st just snooping around, the second probably trying to install additional exploit software, messed something up in the process, which caused the alarm bells to ring.

    Your line of questioning leads to to think that you may have some doubts over this being a possible scenario? It happens far more than you may imagine. The only difference here is the timing of the events. The entire scenario usually playing out over a matter of days/weeks, rather than months/years.

    There is also a lot of speculation here. It is equally possible that this hack has nothing to do with ZenCart at all, and the backdoor code was uploaded via some other means at some other time. I/we don't have enough information available to us that will allow a full/detailed audit of what really happened (or when).

    Cheers
    Rod
    (Adv Dip Network Security)

  3. #13
    Join Date
    May 2008
    Posts
    402
    Plugin Contributions
    0

    Default Re: "The connection was reset" while adding products to the cart

    Quote Originally Posted by RodG View Post
    Same way that anyone finds anything on the Internet. Search engines. I'm unsure why you felt the need to ask this???
    I'm unsure why you felt the need to add three question marks??? It was a perfectly reasonable question. Not everyone is "Adv Dip Network Security" like Rod is.


  4. #14
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,167
    Plugin Contributions
    7

    Default Re: "The connection was reset" while adding products to the cart

    Quote Originally Posted by pricediscrimination View Post
    I'm unsure why you felt the need to add three question marks??? It was a perfectly reasonable question. Not everyone is "Adv Dip Network Security" like Rod is.

    Troll begone!

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Service Connection Failed-The connection to the server was reset while page loading
    By notageek in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 14 Sep 2015, 11:30 PM
  2. Replies: 1
    Last Post: 9 May 2013, 03:51 AM
  3. The connection was reset
    By psvialli in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 1 Apr 2011, 06:08 PM
  4. Reset the "Also purchased" module in "product info"
    By Char3 in forum General Questions
    Replies: 6
    Last Post: 8 Jul 2007, 04:42 PM
  5. Inside the "Categories" box it says "New Products" and "All Products"...
    By john9 in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 25 Feb 2007, 07:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR