Page 19 of 21 FirstFirst ... 91718192021 LastLast
Results 181 to 190 of 208
  1. #181
    Join Date
    Nov 2006
    Location
    Dartmouth, NS Canada
    Posts
    2,381
    Plugin Contributions
    0

    Default Re: Responsive Avonlee Contempo

    I just tried installing the Responsive Avonlee Contempo template on a test site which also has the Winchester Responsive template installed. This template (Responsive Avonlee Contempo) uses a few SQL files during the install. All of them worked fine except for the middle command in the responsive.sql file, which reads.
    Code:
    INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added, use_function, set_function) VALUES 
    (NULL, '<font color="#0044ff">ACTIVATE Responsive Template by selecting Column Widths</font>', 'COLUMN_WIDTH', '2', 'Width of the Left and Right Columns<br />0 = Use Default Template Settings<br />1 = 75px<br />2 = 180px<br />3 = 225px',@configuration_group_id, NULL, NOW(), NULL, 'zen_cfg_select_option(array(\'0\', \'1\', \'2\', \'3\'),');
    That line wouldn't run, and the site is blank now. If I switch back to Winchester the site reappears. All other steps in the install have been followed except the Layout Settings from Step 7, which depend on that SQL command running.

    This is particularly odd because the Winchester template doesn't use SQL install steps, so I can't see how anything could be in the db to conflict with this one.

    Any ideas? (The test site is at www.horsemansshop.com.au/NewZC2/)

    Rob

  2. #182
    Join Date
    Sep 2008
    Location
    WA
    Posts
    555
    Plugin Contributions
    0

    Default Re: Responsive Avonlee Contempo

    Quote Originally Posted by rstevenson View Post
    I just tried installing the Responsive Avonlee Contempo template on a test site which also has the Winchester Responsive template installed. This template (Responsive Avonlee Contempo) uses a few SQL files during the install. All of them worked fine except for the middle command in the responsive.sql file, which reads.
    Code:
    INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added, use_function, set_function) VALUES 
    (NULL, '<font color="#0044ff">ACTIVATE Responsive Template by selecting Column Widths</font>', 'COLUMN_WIDTH', '2', 'Width of the Left and Right Columns<br />0 = Use Default Template Settings<br />1 = 75px<br />2 = 180px<br />3 = 225px',@configuration_group_id, NULL, NOW(), NULL, 'zen_cfg_select_option(array(\'0\', \'1\', \'2\', \'3\'),');
    That line wouldn't run, and the site is blank now. If I switch back to Winchester the site reappears. All other steps in the install have been followed except the Layout Settings from Step 7, which depend on that SQL command running.

    This is particularly odd because the Winchester template doesn't use SQL install steps, so I can't see how anything could be in the db to conflict with this one.

    Any ideas? (The test site is at www.horsemansshop.com.au/NewZC2/)

    Rob
    Hi
    What exactly happened when you tried to run the SQL?
    L

  3. #183
    Join Date
    Nov 2006
    Location
    Dartmouth, NS Canada
    Posts
    2,381
    Plugin Contributions
    0

    Default Re: Responsive Avonlee Contempo

    Sorry, I should have been more specific. When I ran that sql file all at once, I got a blank screen in admin. So I backed up and ran the first statement in it successfully, then the second gave me a blank screen again, then the third statement ran successfully. So it's definitely that second statement, which I quoted above, that wouldn't run. And after all the other sql files were run, all successfully, and the other install steps were performed, the site front end wouldn't load, giving me a blank screen. Reverting to the Winchester template restores the test site. No other edits - of files or admin settings - have been performed yet.

    Checking the logs, I see...
    Code:
    [11-Oct-2015 01:49:13 UTC] PHP Fatal error:  1048:Column 'configuration_group_id' cannot be null :: INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added, use_function, set_function) VALUES (NULL, '<font color="#0044ff">ACTIVATE Responsive Template by selecting Column Widths</font>', 'COLUMN_WIDTH', '2', 'Width of the Left and Right Columns<br />0 = Use Default Template Settings<br />1 = 75px<br />2 = 180px<br />3 = 225px',@configuration_group_id, NULL, NOW(), NULL, 'zen_cfg_select_option(array(\'0\', \'1\', \'2\', \'3\'),'); ==> (as called by) /home/horseman/public_html/NewZC2/[admin folder]/sqlpatch.php on line 304 <== in /home/horseman/public_html/NewZC2/includes/classes/db/mysql/query_factory.php on line 155
    Rob

  4. #184
    Join Date
    Jul 2009
    Location
    picaflor-azul.com
    Posts
    6,930
    Plugin Contributions
    45

    Default Re: Responsive Avonlee Contempo

    Quote Originally Posted by rstevenson View Post
    Sorry, I should have been more specific. When I ran that sql file all at once, I got a blank screen in admin. So I backed up and ran the first statement in it successfully, then the second gave me a blank screen again, then the third statement ran successfully. So it's definitely that second statement, which I quoted above, that wouldn't run. And after all the other sql files were run, all successfully, and the other install steps were performed, the site front end wouldn't load, giving me a blank screen. Reverting to the Winchester template restores the test site. No other edits - of files or admin settings - have been performed yet.

    Checking the logs, I see...
    Code:
    [11-Oct-2015 01:49:13 UTC] PHP Fatal error:  1048:Column 'configuration_group_id' cannot be null :: INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added, use_function, set_function) VALUES (NULL, '<font color="#0044ff">ACTIVATE Responsive Template by selecting Column Widths</font>', 'COLUMN_WIDTH', '2', 'Width of the Left and Right Columns<br />0 = Use Default Template Settings<br />1 = 75px<br />2 = 180px<br />3 = 225px',@configuration_group_id, NULL, NOW(), NULL, 'zen_cfg_select_option(array(\'0\', \'1\', \'2\', \'3\'),'); ==> (as called by) /home/horseman/public_html/NewZC2/[admin folder]/sqlpatch.php on line 304 <== in /home/horseman/public_html/NewZC2/includes/classes/db/mysql/query_factory.php on line 155
    Rob
    If it is the sql for the column layout grid plugin, you do not need to run it again since it was already installed with the Winchester Responsive install.

    Thanks,

    Anne
    Mobile Friendly Responsive Zen Cart Design
    Convert your zen cart easily with our Free Responsive Zen Cart Templates
    Check them out!

  5. #185
    Join Date
    Nov 2006
    Location
    Dartmouth, NS Canada
    Posts
    2,381
    Plugin Contributions
    0

    Default Re: Responsive Avonlee Contempo

    If it is the sql for the column layout grid plugin, you do not need to run it again since it was already installed with the Winchester Responsive install.
    The one that didn't run is the INSERT INTO line from the responsive.sql file, not the clg_install.sql.

    Was the Winchester template able to install sql patches by itself, behind the scenes as it were? That would be a cool thing, considering how often sql patches are problematic for one reason or another. I ask because there were no sql patch files in the Winchester download, which I have here, untouched, as a backup.

    In any case, the issue is what to do now, since if I switch to the Avonlee template, I get a blank front end to the site. Something is wrong in the db, I'm guessing. This is a pretty clean install, as befits a test site. It's a new ZC 1.5.4 with a backup of the current site's db (and absolutely none of the old site's php files, of course) on which only Winchester and Avonlee templates have been installed.

    So far no core files have been touched by me; any edits were either done in admin or in the Winchester files as we were discussing on its thread. There might well be bits left in the db from earlier add-ons, but none of those add-ons have been re-installed yet, so none are active. Ah! That rings a bell... the old site had Single Listing Template installed, which now that I look at my backups did install the column layout grid as part of its install. So that was in the db already. Can you suggest which table or row to delete from the db so the required INSERT INTO from your responsive.sql patch will run? I'm comfortable editing dbs with PHPMyAdmin.

    Rob

  6. #186
    Join Date
    Jul 2009
    Location
    picaflor-azul.com
    Posts
    6,930
    Plugin Contributions
    45

    Default Re: Responsive Avonlee Contempo

    Quote Originally Posted by rstevenson View Post
    The one that didn't run is the INSERT INTO line from the responsive.sql file, not the clg_install.sql.

    Was the Winchester template able to install sql patches by itself, behind the scenes as it were? That would be a cool thing, considering how often sql patches are problematic for one reason or another. I ask because there were no sql patch files in the Winchester download, which I have here, untouched, as a backup.

    In any case, the issue is what to do now, since if I switch to the Avonlee template, I get a blank front end to the site. Something is wrong in the db, I'm guessing. This is a pretty clean install, as befits a test site. It's a new ZC 1.5.4 with a backup of the current site's db (and absolutely none of the old site's php files, of course) on which only Winchester and Avonlee templates have been installed.

    So far no core files have been touched by me; any edits were either done in admin or in the Winchester files as we were discussing on its thread. There might well be bits left in the db from earlier add-ons, but none of those add-ons have been re-installed yet, so none are active. Ah! That rings a bell... the old site had Single Listing Template installed, which now that I look at my backups did install the column layout grid as part of its install. So that was in the db already. Can you suggest which table or row to delete from the db so the required INSERT INTO from your responsive.sql patch will run? I'm comfortable editing dbs with PHPMyAdmin.

    Rob
    The Winchester Responsive has already uploaded the responsive.sql

    If you get a blank page, check your logs folder for errors.

    Thanks,

    Anne
    Mobile Friendly Responsive Zen Cart Design
    Convert your zen cart easily with our Free Responsive Zen Cart Templates
    Check them out!

  7. #187
    Join Date
    Nov 2006
    Location
    Dartmouth, NS Canada
    Posts
    2,381
    Plugin Contributions
    0

    Default Re: Responsive Avonlee Contempo

    Quote Originally Posted by picaflor-azul View Post
    If you get a blank page, check your logs folder for errors.
    See post #183 above for the most recent logged error. There is one before that, likely from my first stab at loading that sql file which reads...
    Code:
    [11-Oct-2015 01:17:31 UTC] PHP Fatal error:  1062:Duplicate entry 'COLUMN_WIDTH' for key 'unq_config_key_zen' :: INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added, use_function, set_function) VALUES (NULL, '<font color="#0044ff">ACTIVATE Responsive Template by selecting Column Widths</font>', 'COLUMN_WIDTH', '2', 'Width of the Left and Right Columns<br />0 = Use Default Template Settings<br />1 = 75px<br />2 = 180px<br />3 = 225px',@configuration_group_id, NULL, NOW(), NULL, 'zen_cfg_select_option(array(\'0\', \'1\', \'2\', \'3\'),'); ==> (as called by) /home/horseman/public_html/NewZC2/[my admin folder]/sqlpatch.php on line 304 <== in /home/horseman/public_html/NewZC2/includes/classes/db/mysql/query_factory.php on line 155
    Do either of these suggest something I can do? If necessary I can just redo the install completely, but I'd rather fix this one if possible.

    Thanks,

    Rob

  8. #188
    Join Date
    Sep 2008
    Location
    WA
    Posts
    555
    Plugin Contributions
    0

    Default Re: Responsive Avonlee Contempo

    That error looks like it came from the SQL install. If you just run the program, where you get the blank screen, do you get any error files in your log folder?

    l

  9. #189
    Join Date
    Jul 2009
    Location
    picaflor-azul.com
    Posts
    6,930
    Plugin Contributions
    45

    Default Re: Responsive Avonlee Contempo

    Quote Originally Posted by rstevenson View Post
    See post #183 above for the most recent logged error. There is one before that, likely from my first stab at loading that sql file which reads...
    Code:
    [11-Oct-2015 01:17:31 UTC] PHP Fatal error:  1062:Duplicate entry 'COLUMN_WIDTH' for key 'unq_config_key_zen' :: INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added, use_function, set_function) VALUES (NULL, '<font color="#0044ff">ACTIVATE Responsive Template by selecting Column Widths</font>', 'COLUMN_WIDTH', '2', 'Width of the Left and Right Columns<br />0 = Use Default Template Settings<br />1 = 75px<br />2 = 180px<br />3 = 225px',@configuration_group_id, NULL, NOW(), NULL, 'zen_cfg_select_option(array(\'0\', \'1\', \'2\', \'3\'),'); ==> (as called by) /home/horseman/public_html/NewZC2/[my admin folder]/sqlpatch.php on line 304 <== in /home/horseman/public_html/NewZC2/includes/classes/db/mysql/query_factory.php on line 155
    Do either of these suggest something I can do? If necessary I can just redo the install completely, but I'd rather fix this one if possible.

    Thanks,

    Rob
    This error is related to the sql patch. There should be a different error for the blank page.

    Thanks,

    Anne
    Mobile Friendly Responsive Zen Cart Design
    Convert your zen cart easily with our Free Responsive Zen Cart Templates
    Check them out!

  10. #190
    Join Date
    Nov 2006
    Location
    Dartmouth, NS Canada
    Posts
    2,381
    Plugin Contributions
    0

    Default Re: Responsive Avonlee Contempo

    Quote Originally Posted by lruskauff View Post
    That error looks like it came from the SQL install. If you just run the program, where you get the blank screen, do you get any error files in your log folder?
    Yes...
    Code:
    [11-Oct-2015 01:51:44 UTC] PHP Parse error:  syntax error, unexpected 's' (T_STRING) in /home/horseman/public_html/NewZC2/includes/languages/english/responsive_avonlee_contempo/header.php on line 26
    Rob

 

 
Page 19 of 21 FirstFirst ... 91718192021 LastLast

Similar Threads

  1. Avonlee Contempo Template Support Thread
    By picaflor-azul in forum Addon Templates
    Replies: 542
    Last Post: 1 Feb 2018, 05:55 PM
  2. Avonlee Contempo - Center column width
    By Forum5 in forum Templates, Stylesheets, Page Layout
    Replies: 3
    Last Post: 7 Feb 2014, 03:54 AM
  3. v152 Slide Show - Avonlee Contempo
    By Forum5 in forum Addon Templates
    Replies: 2
    Last Post: 3 Feb 2014, 06:11 PM
  4. V1.51 Responsive Avonlee left column margin
    By satello in forum Templates, Stylesheets, Page Layout
    Replies: 1
    Last Post: 22 Jan 2014, 04:51 PM
  5. Avonlee Contempo template
    By nothingnuaghty in forum Addon Templates
    Replies: 2
    Last Post: 15 Dec 2010, 08:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR