Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32
  1. #1
    Join Date
    Feb 2007
    Posts
    1,707
    Plugin Contributions
    0

    Default Random ┬ all over my site

    since upgrading from 1.3.9 to 1.5.1 my site has random

    all over it it random places.

    any one know why??

    i have been going through my products and checking the sauce and removing these one by one, but some pages I seem to be able to remove.... for example, title in EZpages and products. There is no code just text in these titles why are this random things popping up??


  2. #2
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    74

    Default Re: Random ┬ all over my site

    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Feb 2007
    Posts
    1,707
    Plugin Contributions
    0

    Default Re: Random ┬ all over my site

    great thanks!!


  4. #4
    Join Date
    Oct 2009
    Posts
    15
    Plugin Contributions
    0

    Default Re: Random ┬ all over my site

    Quote Originally Posted by kitcorsa View Post
    great thanks!!

    I have the same problem. I use 1.3.8a but i did not upgraded. This character "�" appeared spontaneously all over my site (ez pages, product pages, category descriptions).

    I did not installed any modules or plugins lately so i jut can't explain it. The site worked perfectly for 5 years and know that happened.

    I converted the database to utf-8 (same with English and configure.php) and the problem persist.

    Here is how it looks on my site:
    http://www.vapori.ro/vaporii_din_med..._fumatul_pasiv


    If any of you have an idea about to solve this mystery i appreciate it!

    Janos

  5. #5
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    5,621
    Plugin Contributions
    211

    Default Re: Random ┬ all over my site

    If you do a view source, you'll find at the top of your page it has

    Code:
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    This means you have more things to change. Did you set DB_CHARSET in your includes/configure.php file? And CHARSET in includes/languages/<YOUR_TEMPLATE>/YOUR_LANGUAGE.php ?
    That Software Guy, Plugin Moderator. Store: Zen Cart Modifications
    Contributions: Quantity Discounts, Better Together, SMS on Sale, Gift Wrap at Checkout, and more.

  6. #6
    Join Date
    Oct 2009
    Posts
    15
    Plugin Contributions
    0

    Default Re: Random ┬ all over my site

    Quote Originally Posted by swguy View Post
    If you do a view source, you'll find at the top of your page it has

    Code:
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    This means you have more things to change. Did you set DB_CHARSET in your includes/configure.php file? And CHARSET in includes/languages/<YOUR_TEMPLATE>/YOUR_LANGUAGE.php ?
    Thank you for your reply! Since my earlier post i did a full site and database restore from a backup. So the changes made were not saved. I reedited the configure.php, english php both in includes and in admin.

    The same result

  7. #7
    Join Date
    Oct 2009
    Posts
    15
    Plugin Contributions
    0

    Default Re: Random ┬ all over my site

    define('DB_TYPE', 'mysql');
    define('DB_PREFIX', '');
    define('DB_CHARSET', 'utf8');
    define('DB_SERVER', 'localhost');

    This is the line added in configure.php. Maybe it should had been "utf-8" instead of "utf8"?

  8. #8
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    5,621
    Plugin Contributions
    211

    Default Re: Random ┬ all over my site

    This suggests that your data is not UTF8. Did you see the second post in this thread from Dr. Byte?
    That Software Guy, Plugin Moderator. Store: Zen Cart Modifications
    Contributions: Quantity Discounts, Better Together, SMS on Sale, Gift Wrap at Checkout, and more.

  9. #9
    Join Date
    Oct 2009
    Posts
    15
    Plugin Contributions
    0

    Default Re: Random ┬ all over my site

    Name:  screen.jpg
Views: 198
Size:  78.3 KB

    I attached a printscreen of my database my database was converted successfully form iso to Utf8. It was the first thing i did today when i sow the strange character appearing out of the blue. That's why i am so frustrated. I did everything by the book but nothing changes.

  10. #10
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,166
    Plugin Contributions
    7

    Default Re: Random ┬ all over my site

    Quote Originally Posted by romancoins View Post
    I converted the database to utf-8
    How did you do this conversion? It isn't enough to simply change the field types. The data they contain also needs to be converted.

    There's a module in the plugs section of this site that will do this for you.
    http://www.zen-cart.com/downloads.php?do=file&id=1318

    Don't forget the usual stuff. Backup your database first.

    Cheers
    RodG
    Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

 

 
Page 1 of 4 123 ... LastLast

Similar Threads

  1. Random Error: images not adding to items! started over night
    By kitcorsa in forum General Questions
    Replies: 3
    Last Post: 28 Oct 2011, 10:22 AM
  2. Random loading of Over-rides
    By borillion_star in forum General Questions
    Replies: 4
    Last Post: 30 Dec 2010, 03:58 AM
  3. The word "Products" showing up all over site
    By smoke133 in forum General Questions
    Replies: 4
    Last Post: 17 Sep 2008, 05:27 PM
  4. Machine Code Bad Characters - Little ┬ 's all over the site
    By milobloom in forum General Questions
    Replies: 2
    Last Post: 31 Aug 2007, 10:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR