Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1
    Join Date
    Feb 2014
    Location
    USA
    Posts
    8
    Plugin Contributions
    0

    Default USPS module suddenly not giving correct insurance rates?

    Zen cart 1.5.0

    I'm having trouble getting correct insurance rates using the latest USPS shipping module.
    Insurance does not gets up to the value of the goods. Only the following basic $ 2.10.
    For product value $ 60 add $ 2.10 and for goods value $ 600 also adds $ 2.10

    Please help solve this problem.

    Thank you very much.

  2. #2
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,402
    Plugin Contributions
    6

    Default Re: USPS module suddenly not giving correct insurance rates?

    I am waiting on an answer from USPS about a question that I have on this before I post the final solution for testing ...

    You do win a prize for being the first person to ever notice that the Insurance was not coming back with correct results ...

    And your prize is ...

    I will get this fixed asap!

    But before I try various solutions ... I see other issues that the solution will fix that need addressing but USPS has got to provide some better information than what I have found in 100s and 100s of docs ...

    If they do not respond early tomorrow, I will post a quickie fix for this for you prior to posting a better solution once I have more information from USPS ...

    Let me just say I am not amused at the moment with what I am coming across in trying to come up with the one solution for all fix to this problem ... but, never fear! I will come up with something livable for everyone ... I think ...

    NOTE: your example was perfect to really make this problem stand out ... it is amazing no one has said anything about this before now ...
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

  3. #3
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,402
    Plugin Contributions
    6

    Default Re: USPS module suddenly not giving correct insurance rates?

    I have not yet heard back from USPS so I am going to give you a temporary fix for the insurance ...

    On the file:
    /includes/modules/shipping/usps.php

    around line 891 add the code in RED:
    Code:
            else
            {
              continue;
            }
    
    $specialservices =
      '<SpecialServices>' .
        '  <SpecialService>1</SpecialService>' .
      '</SpecialServices>';
    
    //echo 'USPS $requested_type: ' . $requested_type . ' $service: ' . $service . ' $Container: ' . $Container . '<br>';
            $request .=  '<Package ID="' . $package_count . '">' .
    then further down in the code around line 908, add the code in RED:
    Code:
                     '<Value>' . number_format($order->info['subtotal'] > 0 ? $order->info['subtotal'] + $order->info['tax'] : $_SESSION['cart']->total, 2, '.', '') . '</Value>' .
    $specialservices .
                         '<Machinable>' . ($this->machinable == 'True' ? 'TRUE' : 'FALSE') . '</Machinable>' .
    Only check the checkbox for Insurance in the:
    Extra Services (Domestic)

    Now, test out the $60 and $600 shipping like you did before ...

    NOTE: This is NOT a final solution, it is just a temporary work around for you, until USPS gets back to me with the right information ...
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

  4. #4
    Join Date
    Feb 2014
    Location
    USA
    Posts
    8
    Plugin Contributions
    0

    Default Re: USPS module suddenly not giving correct insurance rates?

    Thank you very much for your prompt response. I'll be testing tonight.

    Thank you!

  5. #5
    Join Date
    Feb 2014
    Location
    USA
    Posts
    8
    Plugin Contributions
    0

    Default Re: USPS module suddenly not giving correct insurance rates?

    Hello,


    Thank you for the code.

    Just now I finished the test. Packages weighing 1 pound or larger are calculated properly with Priority Mail Parcel.
    Packages less like 1 pound I have two options for Priority Mail Parcel and First-Class Mail Parcel. With Priority Mail Parcel is calculated properly. First-Class Mail Parcel gives me the incorrect price. But on my favor.
    I'm very happy with that.

    Thank you very much.

  6. #6
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,402
    Plugin Contributions
    6

    Default Re: USPS module suddenly not giving correct insurance rates?

    What is the:
    Ship From
    Ship To
    Weight
    Value

    that you are testing?
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

  7. #7
    Join Date
    Feb 2014
    Location
    USA
    Posts
    8
    Plugin Contributions
    0

    Default Re: USPS module suddenly not giving correct insurance rates?

    Hello ,

    Below is given a list of a test.

    Test 1
    From ZIP Code 07407 to ZIP Code 11801
    -------------------------------------

    A large pack of 8 lbs. Value $ 688.00

    Zen Cart.
    ---------
    Priority Mail Parcel - $ 21.45

    United State Postal Service .
    ----------------------------
    Priority Mail Parcel - $ 21.45


    Small pack 3 oz . value of $ 36.0

    Zen Cart .
    ---------
    First -Class Mail Parcel - $ 5.45
    Priority Mail - $ 5.60

    United States Postal Service .
    -----------------------------
    First -Class Mail Parcel - $ 4.42
    Priority Mail - $ 5.60


    Test 2
    From ZIP Code 07407 to ZIP Code 40216
    -------------------------------------

    A large pack of 8 lbs. Value $ 688.00

    Zen Cart .
    ---------
    Standard Parcel Post - $ 25.82
    Priority Mail Parcel - $ 31.75

    United States Postal Service .
    -----------------------------
    Standard Parcel Post - $ 25.82
    Priority Mail Parcel - $ 31.75

    Small pack 3 oz . Value $ 36.00

    Zen Cart .
    ---------
    First - Class Mail Parcel - $ 5.47
    Priority Mail - $ 6.00
    Standard Parcel Post - $ 7.97

    United States Postal Service .
    -----------------------------
    First - Class Mail Parcel - $ 4.42
    Priority Mail - $ 6.00
    Standard Parcel Post - $ 7.97

    It looks like the problem is only with First - Class Mail Parcel .

    Thank you for your help.

  8. #8
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,402
    Plugin Contributions
    6

    Default Re: USPS module suddenly not giving correct insurance rates?

    3oz $36.00 from 07407 to 11801 with insurance on I am getting:
    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (First-Class Mail Letter (2 - 5 days)) $3.22
    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (First-Class Mail Large Envelope (2 - 5 days)) $4.42
    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (First-Class Mail Parcel (2 - 5 days)) $4.42

    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (Priority Mail™ (1-day)) $5.60
    3oz $36.00 from 07407 to 40216 I get:
    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (First-Class Mail Letter (2 - 5 days)) $3.22
    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (First-Class Mail Large Envelope (2 - 5 days)) $4.42
    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (First-Class Mail Parcel (2 - 5 days)) $4.42

    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (Priority Mail™ (2-day)) $6.00
    United States Postal Service (1 Boxes) (0 lbs, 3 oz) (Standard PostŪ (4 - 7 days)) $7.97
    Perhaps you can check the 3oz $36.00 ones again just to be sure ...

    Should you have something other than the correct rates come up, could you please turn on the Debug to Log in the USPS shipping module and then try them again and Zip the Shipping log files and attach them to your post?
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

  9. #9
    Join Date
    Feb 2014
    Location
    USA
    Posts
    8
    Plugin Contributions
    0

    Default Re: USPS module suddenly not giving correct insurance rates?

    Hello,

    I tested again and I got the same result.

    In an attachment is usps_logs. zip file

    Thank you for your help.
    Attached Files Attached Files

  10. #10
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,402
    Plugin Contributions
    6

    Default Re: USPS module suddenly not giving correct insurance rates?

    Could you also Zip the file, from your server, for:
    /includes/modules/shipping/usps.php
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. USPS module suddenly not giving quotes?
    By SPembleton in forum Addon Shipping Modules
    Replies: 45
    Last Post: 14 Feb 2014, 03:11 AM
  2. v139h USPS module suddenly giving error and blank page on checkout
    By sharon1175 in forum Addon Shipping Modules
    Replies: 5
    Last Post: 14 Nov 2013, 04:19 AM
  3. usps module suddenly giving an error
    By stantdesign in forum Addon Shipping Modules
    Replies: 32
    Last Post: 6 Jun 2012, 04:19 AM
  4. CanPar Module not giving shipping rates
    By RobertG in forum Addon Shipping Modules
    Replies: 0
    Last Post: 23 Aug 2010, 06:42 PM
  5. USPS api rates: All foreign and domestic rates correct except for Airmail Letter Post
    By dharma in forum Built-in Shipping and Payment Modules
    Replies: 0
    Last Post: 23 Nov 2006, 02:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR